Jump to content
recneps

Moved a osCommerce 2.2-MS2 site from one host to another. Sessions have quit working

Recommended Posts

Posted (edited)

So I have an osCommerce 2.2-MS2 site that I have to support for a while longer. I lost the host that I had so I had to move the site to another host. Now all account login and add-to-cart options aren't working. So I suspect that the sessions aren't remembering things saved in them. (I added some temporary checkpoint code that proved it to me.)

Does anybody have any idea which PHP settings I should look at that might be set incorrectly? The PHP version I'm using is 5.1.6. I'm a PHP programmer but not an osCommerce expert...

Edited by recneps

Share this post


Link to post
Share on other sites

That can be caused by a number of things. The first things I would try would be to turn off the cache and gzip options, if they are enabled, and empty the sessions table.

By the way, the version of your shop should work with php 5.3. While it is long dead, it is a far-better version than 5.1 so you should consider upgrading.

Share this post


Link to post
Share on other sites

Yeah, try turning off the cache and gzip options if they are enabled.


A friend of mine recommended reading this best flushing toilet review article https://bestflushingtoilet.org/, before deciding to purchase one. I think that is a good idea to have a wise decision.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×