Jump to content

Recommended Posts

Hello I have installed  Phoenix 1.0.1.0 and this Wholesale (SPPC lite) 4.0.1  version that according with the manuals are Compatibility: for this versions.

but

the shop works but when I press the management Tool

I got this:

Warning: Use of undefined constant DIR_WS_HTTP_CATALOG - assumed 'DIR_WS_HTTP_CATALOG' (this will throw an Error in a future version of PHP) in C:\xampp\htdocs\CE-Phoenix-1.0.1.0\admin\includes\application_top.php on line 49

Warning: Use of undefined constant DIR_WS_HTTP_CATALOG - assumed 'DIR_WS_HTTP_CATALOG' (this will throw an Error in a future version of PHP) in C:\xampp\htdocs\CE-Phoenix-1.0.1.0\admin\includes\application_top.php on line 52

Warning: require(includes/classes/hooks.php): failed to open stream: No such file or directory in C:\xampp\htdocs\CE-Phoenix-1.0.1.0\admin\includes\application_top.php on line 108

Fatal error: require(): Failed opening required 'includes/classes/hooks.php' (include_path='C:\xampp\php\PEAR') in C:\xampp\htdocs\CE-Phoenix-1.0.1.0\admin\includes\application_top.php on line 108

do you have any idea please

Share this post


Link to post
Share on other sites

Version 1.0.1.0 is a very old version. If you are referring to this addon, it states that will work with 1.0.7.3 so you should start over, in my opinion. Also, whenever you have a question about an addon, you are better off posting in that addons support thread since that is where the person that wrote the addon is more likely to see it.

Share this post


Link to post
Share on other sites

Are you sure Phoenix version 1.0.1.0 has all the hooks files. I would upgrade to a later version of Phoenix. !.0.5.0 is a safe version and lots of addons were made for it, or you could go up to 1.0.7.0 or higher if you really need to , but you may have to wait for addons to be updated if you cant do it yourself.


REMEMBER BACKUP, BACKUP AND BACKUP

Get the latest Responsive osCommerce CE (community edition) here

It's very easy to over complicate what are simple things in life

Share this post


Link to post
Share on other sites
Posted (edited)

These errors are not related to the wholesale add on.
The first error points to a wrong configured includes/configure.php file.
The second is a missing class file.

Edited by raiwa

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×