Jump to content
HowardR

Payments by credit card stopped working on Friday

Recommended Posts

On June 4, my store suddenly stopped working right. People can still pay in my store if they log into their PayPal accounts, but if they try to pay by credit card without doing so, the payments are successfully captured by PayPal, but the customer receives no confirmation, so they sometimes pay multiple times. Meanwhile my store doesn't find out about them. My guess is that PayPal is not succeeding in logging into my store to tell it that a payment has succeeded.

My website is indeed outmoded:

  • OS Commerce Edge 2.3.4. 
  • PayPal App 6.010.
  • Centos 6.9
  • TLS 1.2 according to OpenSSL, but the store PayPal module test says that only TLS1.1 is available.
  • PHP version is 5.5

Does anybody have any idea of what is going on?  Might installing an improved .pem file for php help? If so, please refer me to detailed instructions as I am not a php programmer. 

If the solution requires a complete upgrade, can anybody tell me the minimum that would be needed to guarantee that it would work. 

Share this post


Link to post
Share on other sites

@HowardR If something used to work, and 'suddenly' stopped, something has to have changed. If you did nothing to your store, then either your host changed something, or Paypal did. Have you contacted either of them?

Oh, and do you have a full backup of your store (code AND database)?

Malcolm


Get the latest Responsive osCommerce CE (community edition) here .

Share this post


Link to post
Share on other sites

What paypal module are you using? If standard:

Check the paypal log via your admin menus and confirm if you are getting notifications or not - look for _notify-validate [IPN] entries.

Do you see the balance displayed on your admin dashboard? That would tell us the app is talking to paypal ok. There will be corresponding successful GetBalance log entries.

In your paypal account, go to the settings and check them. This has all moved again. It's now on the drop down from your name, then account settings; check Instant Payment Notifications are turned on. If they are, from that page click through to the IPN History page, check there are entries corresponding to the orders. Try resending one of them.


For a new install or if your store isn't mobile-friendly, get the community-supported responsive osCommerce (Phoenix).

here: on the official osc download page

Working on generalising bespoke solutions for Quickbooks integration, Easify integration and pay4later (DEKO) integration at 2.3.x

Share this post


Link to post
Share on other sites

Thank you so much for the feedback. It's interesting to hear that a similar problem is happening to Phoenix. By the way, if anybody else starts getting this problem with PayPal and credit cards, I've found a quick fix that just requires changing the PayPal module's configuration:

1.  In the Direct Payment tab, change Status from "Live" to "Disabled". (This means that Express Checkout will be the only form of payment.)

2. In the Express Checkout Tab:

  • Status: leave it set to "Live"
  • Checkout Flow: change from "Classic" to "In-Context".
  • PayPal Account Optional: Change from False to True (So people can pay by credit card without having to create a PayPal Account.)
  • Instant Update: can be either "Enabled" or "Disabled" - It works both ways. (My store uses Flat Rate shipping, so I don't need it to be "Enabled".) 
  • Transaction Method: leave it set to "Sale"

The key changes are:

  1. Disable Direct Payment because it's not working.
  2. Change Checkout Flow to "In-Context"
  3. Make PayPal Account optional so that customers can pay by credit card.

My guess is that this configuration works because PayPal has a lower level of security requirement for In Context than it does for Direct Payment and Classic Checkout Flow. Ponce de Leon did an excellent job with putting together this PayPal module. His configuration setting tool gives store owners so many options! I couldn't have fixed this problem without them.

 

Share this post


Link to post
Share on other sites

I found the cause of my problem in the response of another thread when, on September 1, my remaining PayPal payment option stopped working. The problem was simple. My paypal.com.crt file was an old one that was only about 12K. Once I put the current one, which is about 14K in the ext/modules/payment/paypal folder everything started working again. Here's the one that works:

 

 

paypal.com.crt

Edited by HowardR

Share this post


Link to post
Share on other sites

Thankyou HowardR,

We've been down all day.  I got involved about 3:30 to try and fix the problem with no success.

Just checked this thread again and there was your post.

Saved the day!!

How will I know that these certificate files need to get updated in the future?

Edited by Vee Leskien

Share this post


Link to post
Share on other sites
8 hours ago, directdepot said:

Where did the paypal.com.crt come from?

It's in recent phoenix releases. This problem hit UK sites in February but the US is only getting it now.

 


For a new install or if your store isn't mobile-friendly, get the community-supported responsive osCommerce (Phoenix).

here: on the official osc download page

Working on generalising bespoke solutions for Quickbooks integration, Easify integration and pay4later (DEKO) integration at 2.3.x

Share this post


Link to post
Share on other sites
On 9/3/2020 at 12:13 PM, ecartz said:

It's also in the PayPal App in the Marketplace. 

hi

the latest paypal app is 2017 it says.

i tried that and nothing happened

but the file above which HowardR works.

is there a link to the phoenix paypal app?

i only just discovered this error today on mine

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×