Jump to content
eaglik

Google search console errors OSC v2.3.4.1

Recommended Posts

Hi all

Recently I keep receiving Google Search Error report emails from goolge similar to this

Products issues detected on http://www.classicfuelinjection.co.uk/

To the owner of http://www.classicfuelinjection.co.uk/:

Search Console has identified that your site is affected by 9 Products issues:

Top Warnings

Warnings are suggestions for improvement. Some warnings can affect your appearance on Search; some might be reclassified as errors in the future. The following warnings were found on your site:

Missing field "availability"

Missing field "priceValidUntil"

Missing field "brand"

Missing field "review"

Missing field "url"

We recommend that you fix these issues when possible to enable the best experience and coverage in Google Search.

Does anybody know how to fix ?

My typical product listings have the following fields so ( unless i am missing something ) I do not have the spots to enter for example " price valid until "  etc. etc.

 

 

New Product in "Weber Throttlebody > Classic Fuel Injection - Parts and Components" pixel_trans.gif
pixel_trans.gif
Products Status: pixel_trans.gif  In Stock  Out of Stock
pixel_trans.gif
Date Available: pixel_trans.gif (YYYY-MM-DD)
pixel_trans.gif
Products Manufacturer: pixel_trans.gif 
pixel_trans.gif
Products Name: English 
pixel_trans.gif
Products Title for SEO:
Replaces the product name in the <title> Meta Element
and optionally in the Breadcrumb Trail.
Leave blank to default to product name.
English 
pixel_trans.gif
Tax Class: pixel_trans.gif 
Products Price (Net): pixel_trans.gif 
Products Price (Gross): pixel_trans.gif 
pixel_trans.gif
Products Description:
English  <br><br>Classic Fuel Injection<br> Weber DCOE Throttle Body - Injector mounting adaptor<br><br> This is a new throttle body to replace the Weber Sidedraft DCOE or Downdraft IDF <br><br> To suit <br> Weber DCOE ( all sizes ) <br> Weber IDF ( all sizes ) <br><br> This list is for a single throttle bodies comprising 1 x Master <br><br> Bolt spacing dimensions for flange to inlet manifold as per standard Weber DCOE footprint<br> <br> This is the DCOE adator designed and manufactured by Webcon. <br> We are authorised dealers for this part <br><br> This is a new replacement throttle body to replace the carburettor.<br> It is a direct bolt on part and all throttle linkages etc. are retained. <br> It looks very similar to the original carburettor so the original look of the vehicle is retained.<br> No non reversible engine modifications are needed.<br><br> This Weber DCOE contains mounting points for injectors ( injectors not included) <br><br> These throttle bodies are available as <br> Master Throttle Body ( which includes the Throttle Postion Sensor ) <br> and <br> Slave Throttle Body ( which do not include the Throttle Position Sensor <br> <br><br> We will be expanding our range soon to design and produce adaptors to suit a wide range of vehicles, engines and carburettor types<br><br><br>
pixel_trans.gif
Products Quantity: pixel_trans.gif 
pixel_trans.gif
Products Model: pixel_trans.gif 
pixel_trans.gif
Products GTIN:
1 of UPC, EAN, ISBN etc
pixel_trans.gif 
pixel_trans.gif
Products Image:
Main Image (100 x 80px)
WEBER_LOGO_150x38.gif |
Add Large Image
pixel_trans.gif
Products URL:
(without http://)
English 
pixel_trans.gif
Products Weight: pixel_trans.gif 
pixel_trans.gif
Product Meta Description for SEO:
Add a <description> Meta Element.
HTML is not allowed.
English

 

Any help / suggestions as always greatly appreciated

 


Thanks

Kevin Eagling

KEE Automotive Ltd

Share this post


Link to post
Share on other sites

sorry that did not display well on the screen.  Please see screen shot attached instead.

Capture.JPG


Thanks

Kevin Eagling

KEE Automotive Ltd

Share this post


Link to post
Share on other sites

@eaglik

check if you have the module installed (Product Schema JSON-LD
your admin -> modules -> Header Tag -> Product Schema JSON-LD


Get the latest Responsive osCommerce CE (community edition) here .

Share this post


Link to post
Share on other sites

Omar

I do not have this installed

Looked in the market place and ( unless I am blind ) could not find it by searching for Product Schema

Or is it known by some other name ?


Thanks

Kevin Eagling

KEE Automotive Ltd

Share this post


Link to post
Share on other sites
Posted (edited)

if is not installed then 

your admin -> modules -> Header Tag -> install -> Product Schema JSON-LD

Edited by Omar_one

Get the latest Responsive osCommerce CE (community edition) here .

Share this post


Link to post
Share on other sites

it is not shown when I look for extra modules to install,  all I have listed as possible installs is as per attached screen shotCapture.thumb.JPG.959f12b9454af4f04fed436194e4e80d.JPG


Thanks

Kevin Eagling

KEE Automotive Ltd

Share this post


Link to post
Share on other sites

It is v 2.3.4.1

anxious about updating as I have several mods and I am not sure I know what all of them are

i have a record of some but I think some details of the earlier mods ( most due to layout ) have been lost when I changed PC


Thanks

Kevin Eagling

KEE Automotive Ltd

Share this post


Link to post
Share on other sites
Posted (edited)

Warnings are not Errors

Fixing problems that don't exist is not a productive use of time for any Shopowner, surely ?

Edited by burt

Help shape the future of Phoenix; join the Phoenix Club

Share this post


Link to post
Share on other sites

The warnings are related to the use of structured data which is hard coded into the product_listing.php module file. 

Share this post


Link to post
Share on other sites

You are using an old oscommerce version, you must to read Google Help and hardcode the data.

The best option is upgrade oscommerce an use the new structured data and other many upgrades :)

Share this post


Link to post
Share on other sites

@eaglik Kevin,

Two thoughts ...

1) You stated you were:

On 6/1/2020 at 10:07 AM, eaglik said:

anxious about updating as I have several mods and I am not sure I know what all of them are

While understandable, can you tell us what version of PHP your shop is running?

You stated that your shop is running osC v2.3.4.1. Since your shop is responsive, you are running a Community Edition version of osC (the 'official' release of osC is not responsive), created somewhere between 8/2017 and 7/2019. Numerous releases were made during this period, all with the same 'version number'. Unfortunately, the only way of know when your version was released is to look at the dates in the original ZIP file.

Earlier releases were not PHP 7.x ready. This was introduced gradually throughout the development of the code. What this means is: IF you are running an earlier release, and WHEN your host upgrades the version of PHP running on their server(s), your shop will have serious problems.

So, if for this reason only, it would be strongly recommended to at least begin looking at upgrading to Phoenix.

2) Your initial post also states:

 

On 6/1/2020 at 7:48 AM, eaglik said:

Search Console has identified that your site is affected by 9 Products issues:

Top Warnings

Warnings are suggestions for improvement. Some warnings can affect your appearance on Search; some might be reclassified as errors in the future. The following warnings were found on your site:

Missing field "availability"

Missing field "priceValidUntil"

Missing field "brand"

Missing field "review"

Missing field "url"

 

We recommend that you fix these issues when possible to enable the best experience and coverage in Google Search.

As the message states, these are 'warnings', and not errors.

While Google is trying to make available (collect?) as much information as possible regarding your products, some of this information may not be available, or even pertinent to your products.

In addition, to create, store, and share this information will require making modifications to your database, as well as the code used to enter, edit, and display this information. This will require core code changes to your store. I'm not saying that this is not possible, but the direction the Phoenix development team has been heading is to create a code base that can be enhanced without making changes to the core code.

To summarize,  you can add these fields to your shop. I do not know of an existing add-on that does this, and even if one does exist, it will require a lot of core code changes (both on the shop side, and the admin side). IMHO, your time and effort would be better spent getting ready to upgrade your shop to Phoenix.

But, it's your shop. You do you.

Malcolm


Get the latest Responsive osCommerce CE (community edition) here .

Share this post


Link to post
Share on other sites

Thanks all for your thoughts and input.

Currently running PHP 5.6.4

About a year ago I tried changing to PHP 7 something but it did not play well with my shop and I received all kinds of errors I could not seem to fix.

My hosting company gives the option of running earlier versions of PHP so I just back tracked to 5.6

However I appreciate as time goes on that they my well take this option away from me

With regards to my exact version the email conversations with the guy who converted for me to 2.3.4 are dated November 2016, so assume it was pretty much the latest release ( albeit hacked by him ? ) around this date.

Just noticed that Omar ( further up this post ) was the guy who converted for me when I had the shop under kauto.co.uk - small world heh !!

 

Assuming I take the plunge and exchange some beer tokens with somebody to convert my shop for me ( it is beyond me ! ) what are your good people's thoughts and recommendations as to which version I should be converting to ?

Obviously this is a changing world in terms of software and versions so nobody can be certain but if I do convert I would like the new one to have the highest potential shelf life before being forced to convert again to fix some other problem over the horizon

 

 


Thanks

Kevin Eagling

KEE Automotive Ltd

Share this post


Link to post
Share on other sites

@eaglik Kevin,

First, I would suggest you join the Phoenix club. See what the developers are doing with it. I also strongly encourage you to support the effort with a paid membership. In addition to supporting the ongoing development, you will receive valuable additional code and modules.

Second, IIRC, the current version of Phoenix is 1.0.7.1. You can download v1.0.7.0 (for free) from the osC download page. Do note that there was a small bug in the v1.0.7.0 release which was quickly fixed in the v1.0.7.1 release. Significant enhancements and upgrades have been happening since Phoenix was first released in July of last year (v1.0.0.0).

Third, and probably most important, is that the current direction the developers are taking is to have store owners use or write add-ons that do not make any changes to the core code. This way, the shop core can be upgraded quickly and easily, without the pain up upgrading a heavily modified shop.

Lastly, there are a number of developers that can assist you in upgrading your shop. There is also a list of 'approved developers' in the Phoenix club.

HTH

Malcolm

 


Get the latest Responsive osCommerce CE (community edition) here .

Share this post


Link to post
Share on other sites

@eaglik as @ArtcoInc said there is a list of approved developres in the Phoenix club they will take your shop to the next level.. 

 


Get the latest Responsive osCommerce CE (community edition) here .

Share this post


Link to post
Share on other sites

thanks guys, I have joined the phoenix club but not too many approved developers listed

anybody got any recommendations as to who they worked with to change over their store to phoenix ?

I have posted similar question in the club so will see what comes back from there.


Thanks

Kevin Eagling

KEE Automotive Ltd

Share this post


Link to post
Share on other sites

You have to program this manually. If you are logged in to google, you will get the error message again and again. the error of google is only ended when this is fixed. there are several files that need to be modified. alternatively, you can program something for header tags, but it does not produce the desired results so that all pages are covered. only from experience.

Share this post


Link to post
Share on other sites
4 hours ago, eaglik said:

thanks guys, I have joined the phoenix club but not too many approved developers listed

anybody got any recommendations as to who they worked with to change over their store to phoenix ?

I have posted similar question in the club so will see what comes back from there.

Each of the Certified Developers comes highly recommended.

Not all developers become certified.

Peter

 


CE PHOENIX SUPPORTER

Support the Project, go PRO and get access to certified add ons

Full-time I am a C-suite executive of a large retail company in Australia. In my spare time, I enjoying learning about web-design.

Download the latest version of CE Phoenix from gitHub here

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×