Jump to content
weser

shop stopped sending email notifications

Recommended Posts

dear all

i just realised that my oscommerce shop v2.3.3.4 stopped sending me email notifications informing me of new orders. has anyone ever had this problem? obviously i checked my email server, spam box etc, but it seems that the shop just stopped sending the emails. any help much appreciated!

daniel

 

Share this post


Link to post
Share on other sites

A previously working email system that stops working is usually the result of a change at the hosting level.  I.e. ask your host what changed since (last time you received an email).  One common problem is using a sending email address with a different domain than your store.  Many hosts restrict that. 

Before doing that, you may want to find out if it is sending emails to customers or through Contact Us. 

And you might try Harald's test script: 

 


Always back up before making changes.

Share this post


Link to post
Share on other sites
Posted (edited)

thanks! i will look into possibile changes with my provider.

and, no, my customers don't get emails anymore either.

Edited by weser

Share this post


Link to post
Share on other sites

when browsing the other thread and seeing screenshots posted by other oscommerce users i noted that in the "E-mail Options" in my shop the option "Send HTML or Text Invoices to Customers" is not there at all. any idea why that is? was it never there? did it disappear all of a sudden?

i was using the shop like it is for almost 8 years and until last tuesday everything was working just fine, then it just stopped sending out order notifications & confirmation emails.

Share this post


Link to post
Share on other sites
6 minutes ago, weser said:

when browsing the other thread and seeing screenshots posted by other oscommerce users i noted that in the "E-mail Options" in my shop the option "Send HTML or Text Invoices to Customers" is not there at all. any idea why that is? was it never there? did it disappear all of a sudden?

It looks like an App, so probably never there.  There are only five configuration entries in the current base version, and that looks familiar to me.  I.e. I think it has been that way for a while.  Eight years seems quite possible. 


Always back up before making changes.

Share this post


Link to post
Share on other sites

@weser

In v2.3.3.4, there are only 5 configurable email options in Admin

85130871_ScreenCapture04-06-2020.jpg.3f6637ec6ff0b4e43c9d33a9cae39378.jpg

(please ignore the 4 crossed out options ... these were part of an add-on that is not part of the stock installation)

HTH

Malcolm


Get the latest Responsive osCommerce CE (community edition) here .

Share this post


Link to post
Share on other sites

thanks for the clarifications.

unfortunately, so far i had no luck fixing the notifivation/confirmation problem. i am quite sure everything is in order on my part and my server/provider hasn't made any relevant changes either.

Share this post


Link to post
Share on other sites

@weser

1) Use the script that @ecartz posted in his first reply. This will determine if your (host's) server (and/or your shop's configuration) is configured correctly to send emails, and in what form.

2) Hosts have often made changes to their servers, but won't admit that they made any changes. Stuff happens.

3) Email security and 'best practices' have changed in the last 8 years. So, even if you and your host has not made any changes, changes anywhere along the path where an email travels could result in the inability to have your emails received.

but, let's start with first things first. Run the script mentioned above ...

Malcolm


Get the latest Responsive osCommerce CE (community edition) here .

Share this post


Link to post
Share on other sites

@ArtcoInc

thanks for the reply and patience.

i ran the script now and received this error in my browser:-

Parse error: syntax error, unexpected '?' in /homepages/39/d26756199/htdocs/catalog/email_test.php on line 2"

but unfortunately i received no emails. in my shop configs both the "email from" and "send extra order email" have the same domain as the shop.

so i guess i will give my host a call tomorrow and see if they have something to say.

cheers!

 

Share this post


Link to post
Share on other sites

@weser

What version of PHP is your shop running?

The script in the link above was 'updated' for PHP v7.x , and it may fail under an older version of PHP.

Check out this thread. There are scripts in there that should work with older versions of PHP

 

Malcolm


Get the latest Responsive osCommerce CE (community edition) here .

Share this post


Link to post
Share on other sites

@ArtcoInc

thank you! it seems the other script worked.

i got the following message in my browser: 

Mail function succeeded
Mail function succeeded with -f parameter

and i received 2 emails.

so does this mean the problem is with oscommerce as the other thread suggests?

cheers!

Share this post


Link to post
Share on other sites

hello again

it seems the trouble i have with the notification emails has indeed something to do with my server / provider. 

now my oscommerce shopped stopped working altogether sending me a "1142 insert ..." warning. i can neither login into my backend, nor does the frontend / shop appear anymore. just talked to my provider and the problem is that my database has exceeded it's limit of 1gb.

so i was looking through the database and noticed a folder named "sessions" which has 1.1gb alone. it is filled with around 1.7 million  files named like this:

sesskey: 013cd4dfbde0cf3f3fa8e76adf4ba439 / expiry: 1555101834 / value: sessiontoken|s:32:"a214357d9eebd7a36954f08e9f3f478...

does anybody know what those files are? can (some of) those be deleted?

at first i wanted to delete product pictures, but realised the entire folder of my shop is just 150 mb in size, so i have to make room somewhere else in the database.

any hints would be much appreciated!

daniel

Share this post


Link to post
Share on other sites

Just truncate (EMPTY) the sessions table.  Do not delete (DROP) the table.


Help shape the future of Phoenix; join the Phoenix Club

Share this post


Link to post
Share on other sites
29 minutes ago, burt said:

Just truncate (EMPTY) the sessions table.  Do not delete (DROP) the table.

great, thanks! so, just to make sure - i can delete all the 1.7 million files in "sessions" and just leave the folder empty, yes? i'm quite anxious ;-)

do i have to just do this from time to time? will those files keep piling up again?

merci!

Share this post


Link to post
Share on other sites
40 minutes ago, burt said:

Oui.

it worked! merci beaucoup!! 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×