Jump to content
ce7

Warning: mysqli_fetch_array() expects parameter 1 to be mysqli_result, null given

Recommended Posts

hi,

in my BS frozen version, i install Special Products Content Module(BS)

It works ok, but few days ago, notice that it show up this error message when i click on admin/modules/content/

MODULE_CONTENT_SPECIAL_PRODUCTS_HEADING

Warning: mysqli_fetch_array() expects parameter 1 to be mysqli_result, null given in /admin/includes/functions/database.php on line 103

And other specials index module also not working anymore. 

here is the original code
{php]

<?php
/*
  $Id$

  osCommerce, Open Source E-Commerce Solutions
  http://www.oscommerce.com

  Copyright (c) 2016 osCommerce

  Released under the GNU General Public License
*/

?>
<div class="col-sm-<?php echo $content_width; ?> special-products">
  <h3><?php echo sprintf(MODULE_CONTENT_SPECIAL_PRODUCTS_HEADING, strftime('%B')); ?></h3>
 
  <div class="row list-group" itemtype="http://schema.org/ItemList">
    <meta itemprop="numberOfItems" content="<?php echo (int)$num_special_products; ?>" />
    <?php
    while ($special_products = tep_db_fetch_array($special_products_query)) {
      ?>

    <div class="col-sm-<?php echo $product_width; ?>" itemprop="itemListElement" itemscope="" itemtype="http://schema.org/Product">
           <div class="ribbon blue"><span><?php echo sprintf(MODULE_CONTENT_SPECIAL_PRODUCTS_RIBBONS); ?> </span></div>
        <div class="thumbnail equal-height">
          <a href="<?php echo tep_href_link('product_info.php', 'products_id=' . (int)$special_products['products_id']); ?>"><?php echo tep_image('images/' . $special_products['products_image'], $special_products['products_name'], SMALL_IMAGE_WIDTH, SMALL_IMAGE_HEIGHT , 'itemprop="image"'); ?></a>
        <div class="caption">
          <p class="text-center"><a itemprop="url" href="<?php echo tep_href_link('product_info.php', 'products_id=' . (int)$special_products['products_id']); ?>"><span itemprop="name"><?php echo $special_products['products_name']; ?></span></a></p>
          <hr>
    
          <p class="text-center">
          <?php echo $currencies->display_price($special_products['products_special_price'], tep_get_tax_rate($special_products['products_tax_class_id'])); ?></span></p>
          <meta itemprop="priceCurrency" content="<?php echo tep_output_string($currency); ?>" /></p>
                
          
          
<div class="text-center">
<div class="btn-group">
<a href="<?php echo tep_href_link('product_info.php', tep_get_all_get_params(array('action')) . 'products_id=' . (int)$special_products['products_id']); ?>" class="btn btn-default" role="button"><?php echo MODULE_CONTENT_SPECIAL_PRODUCTS_BUTTON_VIEW; ?></a>
<a href="<?php echo tep_href_link($PHP_SELF, tep_get_all_get_params(array('action')) . 'action=buy_now&products_id=' . (int)$special_products['products_id']); ?>" class="btn btn-success btn-index btn-buy" role="button"><?php echo MODULE_CONTENT_SPECIAL_PRODUCTS_BUTTON_BUY; ?></a>
</div>
</div>
        
        
        </div>
      </div>
    </div>
    <?php
  }
  ?>
  </div>
 
</div>
        

[/php]

can any please help me how to understand the warning message, and where to change the code, many thanks!  Lyn

Share this post


Link to post
Share on other sites

@cr79
I have it working well .. do you have the last update for it because languages folder was in wrong location in the early version..

so I  moving languages folder to right location on last version..
try it 


Get the latest Responsive osCommerce CE (community edition) here .

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×