Jump to content
phi148

Authorize.net Failing - New Update Today - PLEASE HELP

Recommended Posts

Posted (edited)

All, today an update was rolled out with authorize.net

They call it Phase 4b.  You can see it here: https://support.authorize.net/s/article/Authorize-Net-Network-Change-FAQ

Ever since this happened, I noticed something very odd.  Intermittently I couldn't connect to authorize.net.  I narrowed it down to the IP address 198.241.207.102

Interestingly enough, the other IP that they use (198.241.206.93) works fine.  These 2 IP addresses seem to change at random times.  You can see these are the IPs that are allocated to:  secure.authorize.net/gateway/transact.dll   as shown here: https://support.authorize.net/s/article/Authorize-Net-Domains-and-IP-Addresses

So essentially, depending on which IP that the endpoint resolves to, either a payment goes through or it doesn't.

I think this must be a problem that has to do with me having an outdated certificate (This is my guess)

Does anyone else have this problem AND does anybody have an updated certificate that goes here /public_html/ext/modules/payment/authorizenet/authorize.net.crt

I was able to temporarily get around this problem by setting Verify SSL Certificate to False in my authorize.net settings in oscommerce.

Thank you,

Edited by phi148

Share this post


Link to post
Share on other sites

I was able to capture some output:

 

*   Trying 198.241.207.102:443...
* TCP_NODELAY set
* Connected to secure.authorize.net (198.241.207.102) port 443 (#0)
* ALPN, offering h2
* ALPN, offering http/1.1
* successfully set certificate verify locations:
*   CAfile: /home/xxxx/public_html/ext/modules/payment/authorizenet/authorize.net.crt
  CApath: none
* SSL certificate problem: self signed certificate in certificate chain
* Closing connection 0

 

Notice the error -->   * SSL certificate problem: self signed certificate in certificate chain

Share this post


Link to post
Share on other sites

I think I fixed it.  Downloaded this new file  http://curl.haxx.se/ca/cacert.pem

And replaced it here: /home/xxxx/public_html/ext/modules/payment/authorizenet/authorize.net.crt

I *think* this is the answer.  Will keep you all posted if it fails again.

Share this post


Link to post
Share on other sites

I created an account just to be able to say thanks for posting this - I was actually trying to resolve the same issue on a Wordpress site, but your solution gave me the info I needed to figure it out - saving me a lot of time and frustration for sure. Thank you so much for posting a follow up with the resolution - I appreciate you!

edit: more info here for anyone that happens to find this via Google like I did

https://community.developer.authorize.net/t5/Integration-and-Testing/SSL-Certificate-Problem-Another-Authorize-net-Outage/td-p/62246

Edited by cruss

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×