Jump to content
greasemonkey

Allow_url_fopen Fresh Phoenix Install

Recommended Posts

Hey all, I’m starting fresh with Phoenix 1.0.5.0 and I’m stuck on the first page of install. 
 

I’ve confirmed with cPanel mutliPHP INI editor that it is turned on for this add on domain (URL). And also uploaded a phpinfo file and confirmed. 
 

 

6FC62591-A8A8-415F-922D-96429480F732.jpeg

Share this post


Link to post
Share on other sites

@azpro no didn’t restart - however would (not an expert) presume because it’s recognized by phpinfo and cPannel that it wouldn’t necessary?

 

@burt I’ll give it a try tmr. 

Share this post


Link to post
Share on other sites
17 hours ago, burt said:

https://stackoverflow.com/questions/13433660/how-to-check-if-allow-url-fopen-is-enabled-or-not

Upload a new .php file containing;


<?php
echo (ini_get('allow_url_fopen')) ? 'Fopen ON' : 'Fopen OFF';

And see what it says...

@burt the output is

Fopen ON

Could it be a cache issue (I don't think so, I've tried in in a couple different browsers)? Or maybe its looking at the wrong dir php.ini file? Example: html_public in place of html_public/myaddondomain.com

Share this post


Link to post
Share on other sites

https://github.com/gburton/CE-Phoenix/blob/master/install/templates/pages/index.php#L56

comment it out, by adding a double slash in front.  That will allow your install to continue.

I may need to change that line of code - thanks for the heads up. 

Edited by burt

Help shape the future of Phoenix; join the Phoenix Club

Share this post


Link to post
Share on other sites

Even better, instead of commening out that line, would you instead change this line

https://github.com/gburton/CE-Phoenix/blob/master/install/templates/pages/index.php#L55

to

if(!ini_get('allow_url_fopen')) {

 

and that should allow you to continue.  And is a better fix.


Help shape the future of Phoenix; join the Phoenix Club

Share this post


Link to post
Share on other sites

@burt it will only allow me past if I comment it out.

/*	if(!ini_get('allow_url_fopen')) { 
      $warning_array['allow_url_fopen'] = 'Fopen Wrappers must be turned on.  This is a <em>hosting</em> setting which you or your host may be able to change by setting allow_url_fopen to "1" or "On" in php.ini';
    }*/

I'm in no huge rush if you wanted to test something else....

Of course it still gives the thumbs down - which I presume is only a display...

Edited by greasemonkey
added text

Share this post


Link to post
Share on other sites

@burt as a follow up. After install i do see the error in dashboard

allow_url_fopen must be enabled in php.ini
This is a hosting setting and may be able to be performed via your hosting control panel - if not, ask your host.

and the export fort server info shows

allow_url_fopen = 0
allow_url_include = 0

Despite the earlier test (and just recheck) shows

Fopen ON

 

Share this post


Link to post
Share on other sites

I'm also having this issue.

If you put @burt code in a new file in your admin folder and check the output my guess is that it will still be: Fopen  Off

If your custom php.ini is not recursive then the PHP Values In Your custom php.ini are not inherited by any Subdirectories, so Fopen will be on in the root folder, but nowhere else.

I've not fixed mine yet because it's throwing another error due to a missing dll, but to make your custom php.ini recursive add this code to .htaccess :

suPHP_ConfigPath /home/USERNAME/public_html

Some information here:

https://www.inmotionhosting.com/support/website/recursive-php-ini/

 

Share this post


Link to post
Share on other sites

Here's how I fixed it.
I removed the recursive code that I'd put in my .htaccess and simply copied the php.ini file to my admin directory instead. Fopen On in admin
Voila, simple as that.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×