Jump to content
gueweb

welche Version hat unser Shop, läuft der mit PHP 7.3?

Recommended Posts

Hallo,

 

Unsere Firma hat Anfang 2017 einen Webshop aufgebaut. Der Entwickler steht nicht mehr zur Verfügung.

Wie kann ich feststellen, welche Shop-Version installiert ist? Die aktuelle Version 2.3.4.1 ist ja laut Wikipedia vom 18.August 2017, dann werden wir wohl die Vorgängerversion haben? 2.3.4.0?

Auf dem Web-Server ist zur Zeit noch PHP 7.1 eingestellt, ich möchte gerne auf 7.3 ändern. Sind Probleme zu erwarten? Wenn ja, was muss ich tun?

 

Danke - Günther

 

 

Share this post


Link to post
Share on other sites

Hab es gefunden: Tools - Version Checker - TITLE_INSTALLED_VERSION osCommerce Online Merchant v2.3.4

 

sind Probleme mit PHP 7.3 bekannt?

Share this post


Link to post
Share on other sites

Ist das die Bootstrap oder die alte version von osCommerce ?

So oder so musst du alle notwendigen updates vornehmen.

Share this post


Link to post
Share on other sites

Bootstrap? alte Version? Wir haben 2.3.4. Januar 2017.

Alle notwendigen Updates? Welche sind das? Wo bekomme ich die her?

Share this post


Link to post
Share on other sites

Es war mal auf github vom gburton. frag mal beim Gary einfach mal nach ob diese bereits überschrieben wurden oder ob die updates für die EDGE noch irgendwo existieren

Share this post


Link to post
Share on other sites

Also inzwischen weiß ich, dass Bootstrap ein Framework ist.  Und die 2.3.4 ist dann mit Bootstrap erstellt, oder gibt es da noch eine andere, ältere Version 2.3.4? Deine Frage oben hat mich etwas irritiert.

Dann habe ich gefunden:

Wenn ich dem darin enthaltenen Link folge, komme ich auf: https://github.com/gburton/CE-Phoenix/releases

Da ist dann ein Download-Link der mir die Datei CE-Phoenix-1.0.4.0.zip auf die Festplatte schaufelt. Der Inhalt der Datei hat große Ähnlichkeit mit unseren vorhandenen Dateien. Nur, dass die in der Zip-Datei vom 25.11.2019 sind. Also einfach überschreiben? Na ja, ich werde mir erst ein Test-System erstellen...

Danke - Günther

 

Share this post


Link to post
Share on other sites

Bootstrap = Responsive?

Nee, da müssen wir was älteres haben. In dem Shop ist nix responsive.

Ich mach ein Test-System und probiere aus.

 

Share this post


Link to post
Share on other sites

Ja, dann hast du noch die originalversion installiert.
Ich halte derzeit nicht sehr viel von der phoenix weil du mind. 1 Jahr brauchen wirst um diese optimal auf unsere Vorgaben in der EU einzustellen.
Zudem gibt es immer wieder neue updates die sehr lästig sind wenn man eine eigene Interpretation haben möchte.
Ich kann dir nur empfehlen, gut zu überlegen was du haben möchtest und erst entscheiden womit du klarkommst.

Instaliere xampp auf deinem Rechner und somit kannst du deine jetzige software intern mit php 7.4 testen
Sollte es Fehler geben findest du die Lösungen hier im Forum.

Share this post


Link to post
Share on other sites

×