Jump to content

Recommended Posts

30 minutes ago, edfaught said:

Does the hotfix also take care of this?

Answered: Yes it does. However now I see this:

Warning
: Use of undefined constant MODULE_PI_GALLERY_KISSIT_SMALL_IMAGE_WIDTH - assumed 'MODULE_PI_GALLERY_KISSIT_SMALL_IMAGE_WIDTH' (this will throw an Error in a future version of PHP) in
includes/modules/pi/product_info/pi_gallery_kissit.php on line 84

Because previously and by mistake I didn't have the module installed.

Edited by edfaught

Share this post


Link to post
Share on other sites
14 minutes ago, edfaught said:

Answered: Yes it does. However now I see this:


Warning
: Use of undefined constant MODULE_PI_GALLERY_KISSIT_SMALL_IMAGE_WIDTH - assumed 'MODULE_PI_GALLERY_KISSIT_SMALL_IMAGE_WIDTH' (this will throw an Error in a future version of PHP) in
includes/modules/pi/product_info/pi_gallery_kissit.php on line 84

Because previously and by mistake I didn't have the module installed.

Seems I missed to add these constants during the last update to abstract module.

Here the fixed module (needs uninstall/reinstall):

pi_gallery_kissit.php

 

Quote

(Also, the support link in the download documentation is outdated.) 

Thanks, I'll also update it.

 

Please confirm and I'll upload the update with these fixes tomorrow.

Edited by raiwa

Share this post


Link to post
Share on other sites
On 1/12/2021 at 3:27 PM, Denzel said:

Found the list messed up again after searching a product, which is linked to a 2nd folder. Decided to add classes to the <th> tags, so we can exclude the choosen classes:


$('table tbody td:has([href*="pID={$products_id}&"])').parent().find('th').not('.pmodel').not('.pname').addClass('pname').before('<th class="pmodel">{$products_model}</th>');

  this works for me even with three links 😉 

Hi Dennis,

Your solution includes other customizations like the product model and I believe you posted the wrong line which adds {$products_model}. It should be {$products_thumb}.

Please post generic solutions for a unmodified installation, not custom solutions.

What works for me is this:

$('table tbody td:has([href*="pID={$products_id}&"])').parent().find('th').not('.pname').addClass('pname').before('<th class="pname">{$products_thumb}</th>');

Thank you 😉

Edited by raiwa

Share this post


Link to post
Share on other sites

Uploaded update with the above fixes for Phoenix 1.0.7.13:

KissIT image thumbnailer 3.5.0r1

Requires Phoenix 1.0.7.4+
Tested with Phoenix 1.0.7.13

Change log 3.5.0r1:

- updated gallery modules for Phoenix 1.0.7.13.
- fixed error in admin thumbs category hook. Thanks to @Denzel
- updated pi gallery module to abstract_module

Change log 3.5.0:

- moved and cleaned up thumbs subdirectory creation and removed unnecessary .htaccess. Thanks to @vmn
- fixed error in admin thumbs showing duplicated images in product and category listing. Thanks to @Denzel
- added support for webp image format
- updated pi gallery module to abstract_module
- Added optional convert jpeg, png and gif images to webp thumbs (Pro Version)

 

Share this post


Link to post
Share on other sites
vor 3 Stunden schrieb raiwa:

I believe you posted the wrong line

That's true, I'm sorry 🙂

Share this post


Link to post
Share on other sites

Running with 1.0.7.13: 

just a question: is it intended, that the main-image is not thumbnailed? Because neither an image width or height is specified in pi_gallery_kissit.php Line 68. By adding some numbers there, the main image is cached as well. 

Share this post


Link to post
Share on other sites
38 minutes ago, cupidare said:

Running with 1.0.7.13: 

just a question: is it intended, that the main-image is not thumbnailed? Because neither an image width or height is specified in pi_gallery_kissit.php Line 68. By adding some numbers there, the main image is cached as well. 

Yes, it is intended. It's supposed you wish to show the full original image size in the pop up. Only if watermark is used, KissIt will produce a new "thumb", but also in the original image size. There is no "cache" effect, the original image is there and does not need to be "cached" in the thumbs folder.

Share this post


Link to post
Share on other sites

Thank you for the answer. I personally store images in full resulution (>4mb) because maybe I will need it in the future ...  but for the pi-site it is sufficient to show a much smaller image. So am I right putting the "sufficient"-file-size in this position?

Edited by cupidare

Share this post


Link to post
Share on other sites
48 minutes ago, cupidare said:

Thank you for the answer. I personally store images in full resulution (>4mb) because maybe I will need it in the future ...  but for the pi-site it is sufficient to show a much smaller image. So am I right putting the "sufficient"-file-size in this position?

Yes, if it's ok for your needs.

Share this post


Link to post
Share on other sites

Uploaded update with the above fixes for Phoenix 1.0.7.13:

KissIT image thumbnailer 3.5.1

Requires Phoenix 1.0.7.4+
Tested with Phoenix 1.0.7.13

 

Change log 3.5.1:

- cast to int image width and height

 

Change log 3.5.0r1:

- updated gallery modules for Phoenix 1.0.7.13.
- fixed error in admin thumbs category hook. Thanks to @Denzel
- updated pi gallery module to abstract_module

Change log 3.5.0:

- moved and cleaned up thumbs subdirectory creation and removed unnecessary .htaccess. Thanks to @vmn
- fixed error in admin thumbs showing duplicated images in product and category listing. Thanks to @Denzel
- added support for webp image format
- updated pi gallery module to abstract_module
- Added optional convert jpeg, png and gif images to webp thumbs (Pro Version)

Edited by raiwa

Share this post


Link to post
Share on other sites

Hello @raiwa and thanks again for your great addon.

I wanted to have language specific default images. To achieve this I made the following change to kiss_it_image.php:

    if (defined('DEFAULT_IMAGE') && tep_not_null(DEFAULT_IMAGE) && !is_file(DIR_FS_CATALOG . $src)) {
      //VMN$src = DEFAULT_IMAGE;
      $src = 'includes/languages/' . $_SESSION['language'] . '/images/' . DEFAULT_IMAGE;
    } elseif ( (empty($src) || ($src == 'images/')) && (IMAGE_REQUIRED == 'false') ) {
      return false;
    }

I wonder whether you would like to include this change into a future version of the addon:).

Share this post


Link to post
Share on other sites

Share this post


Link to post
Share on other sites

And, in the modern world:

$src = Text::ltrim_once(language::map_to_translation('images/' . DEFAULT_IMAGE), DIR_FS_CATALOG);

Share this post


Link to post
Share on other sites
15 hours ago, micheleangle said:

dculley - How did you get rid of the watermark?

If you do not wants to use Watermark at all, switch it off in the settings: Admin : Images

If you only wish to remove it from some image(s), read the instructions, example store logo.

Don't forget to reset the thumbs and browsers cahe after changing the settings.

 

Share this post


Link to post
Share on other sites
3 hours ago, raiwa said:

If you do not wants to use Watermark at all, switch it off in the settings: Admin : Images

If you only wish to remove it from some image(s), read the instructions, example store logo.

Don't forget to reset the thumbs and browsers cahe after changing the settings.

 

@micheleangle

Sorry I did not get back to you earlier.  I have been away.  @raiwa is correct that is what I did.  Under the section: Check and adjust the Confiuration Setting in Admin for your need:  section  C - "0=no watermark. 

Hope this helps some. 

Share this post


Link to post
Share on other sites

@raiwa

I am facing this issue after installing KissIT image thumbnailer 3.5.1 that I am not able to see many images on products at front end.

In Admin side, there is no issue and all product  images are displaying without issue.

This issue is with the products I uploaded few hours ago using easypopulate, All images were tested and working without any problem before. But when I installed KissIt Moudule it only effected these new products. weirdly it is still showing 3 items images from this bulkuploaded products but not showing for 99 % of them.

All previously listed products are still displaying images correctly. Kindly advise what could be the reason?

Thanks

Share this post


Link to post
Share on other sites

Thanks @raiwa if you referring to Image cache,

image.png.4207a0b7fa789119ed4876036550bb62.png

yes I reset it, with no effect on my images issue. 

I am using Phoenix v1.0.7.15 on Php: 7.4.15

One thing I noticed, may not be relevant and hence your comments will be important, when looking on your "Uninstall" instructions 

catalog/includes/functions/html_output.php   -- I do not have these lines in this file.

delete the folder “kiss_image_thumbnailer” in: catalog/includes/modules/   -     I do not have this folder

catalog/ADMIN/includes/functions/general.php -     I do not have these lines in this file.
 

I believe I followed the installation instructions carefully, but not sure why above lines are not there & why some images are not displayed.

Share this post


Link to post
Share on other sites

The uninstall instructions seems are not updated. You would just remove all kissit files.

For your not showing images issue:

Can you show a sceenshot. If it's that the thumbs are not created, it can be due to memory limit if you are using very big images. Try to use smaller images or increase your server's memory.

Share this post


Link to post
Share on other sites
18 minutes ago, raiwa said:

The uninstall instructions seems are not updated. You would just remove all kissit files.

And run the db uninstall file.

Share this post


Link to post
Share on other sites

Thanks,

Screen shots:

Product info, shop front: (no image)

image.png.65a7c149d9a9f79af7e97f3ec6a5659a.png

Admin side: 

Product info summary:

image.png.234e40d94c88691b9350d092880eea0f.png

Admin Side

Product detail (with Image)

image.png.d346b1462d78165b94196e145f89ca5c.png

Images seems to be normal sizes, and as I mentioned earlier, products which were uploaded yesterday are affected, on all older products images are displaying with no issue.

How to increase server memory? is this to be do with hosting provider?

Shall I re-Install?

Thanks

image.png

Share this post


Link to post
Share on other sites

How big is “normal size” for you?

Just try with one smaller image for testing, if it then works, it’s this.

For memory increasing ask your hosting.

EDIT: Make also sure to use only standard characters in the image names.

Try to find out any characteristic difference between the working and non working images.

 

In admin it says:

IMAGE DOES NOT EXIST

Edited by raiwa

Share this post


Link to post
Share on other sites

I have this mostly working with PHP8 except for this warning:

Deprecated: Required parameter $quality follows optional parameter $save_in in /home/includes/modules/kiss_image_thumbnailer/classes/Image.php on line 137

    protected function _output( $save_in = null, $quality, $filters = null ) {
      switch ($this->_mime_type) {
        case self::IMAGETYPE_GIF :
          return imagegif ( $this->_image, $save_in );
          break;
        case self::IMAGETYPE_JPEG :
        case self::IMAGETYPE_JPG :
          $quality = is_null ( $quality ) ? 75 : $quality;
          return imagejpeg ( $this->_image, $save_in, $quality );
          break;
        case self::IMAGETYPE_PNG :
          $quality = 9;
          $filters = is_null ( $filters ) ? null : $filters;
          return imagepng ( $this->_image, $save_in, $quality, $filters );
          break;
        default :
          trigger_error ( 'Image cannot be created.', E_USER_NOTICE );
          break;
      } // end switch
    } // end method

I see this warning in the "what's new?" box.


The water in a vessel is sparkling; the water in the sea is dark. The small truth has words which are clear; the great truth has great silence.

- Rabindranath Tagore

Share this post


Link to post
Share on other sites
protected function _output( $save_in = '', $quality = '', $filters = null ) {

This seems to clear the warning.


The water in a vessel is sparkling; the water in the sea is dark. The small truth has words which are clear; the great truth has great silence.

- Rabindranath Tagore

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×