Jump to content
Jack_mcs

Easy Populate V 3.0

Recommended Posts

This is a new version of Easy Populate. The basic code is still the same and previous catalog files are compatible with this version, as long as they don't reference outdated addons. This is mainly a cleaned-up version meant for Frozen and Phoenix shops. The changes in it are below.

  •  Changed code to be php 7.3 compatible.
  •  Corrected the system stats code in the right column.
  •  Moved the settings to the database and added the code to change them via the gui.
  •  Removed code for older shops.
  •  Removed code for outdated addons, like MoPics.
  •  Removed references to definitions.

Share this post


Link to post
Share on other sites

Hi Jack @Jack_mcs

First of all I wanted to thank you for your constant support to OSC in all these years.
Today I went to try this magnificent addon on my Frozen test page and I see in the addon file, in the catalog \ Frozen \ admin \ includes folder, the languages and boxes folders are missing. These folders are in the phoenix version.

Will that be correct?

Greetings and very happy 2020

Valqui


:heart: Community Oscommerce fan :heart: You'll find the latest osC community version here.

 

Share this post


Link to post
Share on other sites

@valquiria23I appreciate your kind words and the "likes" you do for my addons.

As for a Frozen installation, please see the readme file and make the code change mentioned there. That is all that is needed for a Frozen shop. 

Share this post


Link to post
Share on other sites

Hi Jack,

I hope you started the year very well. Many blessings to you and your family !!

It is good that you know that we are very much those who appreciate your contributions to the community, besides that you are very kind and give excellent support.

I was looking at the installation file and as always it is super complete and clear.
I may not express myself well, but when you download the files from market , the directories: languages and boxes are missing.

Could you please download the file from the market and look at the following path: catalog \ Frozen \ admin \ includes, you'll see what I mean.

Best regards

Valqui


:heart: Community Oscommerce fan :heart: You'll find the latest osC community version here.

 

Share this post


Link to post
Share on other sites
1 hour ago, valquiria23 said:

It is good that you know that we are very much those who appreciate your contributions to the community, besides that you are very kind and give excellent support.

:blush::biggrin:

I understood what you were saying but there are not any language or box files. There never have been with Easy Populate. Whoever originally coded it entered all of the text into the main file and placed the link to it in the catalog box.. I had planned on moving the text to a language file but ran out of time. So if you just make the one change to the catalog box file, the addon will work as expected, though all text is in English, of course.

Share this post


Link to post
Share on other sites
20 hours ago, gsmiley007 said:

Is there a version that supports phoenix v1.07.12?

Yes. It will be released this week.

Share this post


Link to post
Share on other sites

A new version has been uploaded with these changes:

Free Version:

  • Added an option (bottom of the page) to clear the temp directory.
  • Added a language file (not complete).
  • Added the old tableblock class since the new one removes the table, which is needed here for display purposes.
  • Changed code to remove php warnings.
  • Changed the options code to use the stored settings.
  • Changed the model setting to a database option and loaded the model size dynamically so it no longer needs to be set.
  • Changed the Export section to allow clicking on the text to set the checkbox, as opposed to having to click the checkbox.
  • Changed all references of Froogle to Google Shopping since that is once again free, sort of.
  • Changed Header Tags SEO names to use the Phoenix names.
  • Changed layout to use BS4 controls.
  • Fixed many security holes.
  • Fixed the custom create section.
  • Fixed the additional images code to load properly.
  • Fixed some problems found in the original addon as well as some of mine in the previous version.
  • Moved the information message on file creations to the header instead of it blocking the page.
  • Removed definitions from the functions file.
  • Removed the magic quotes code.
  • Replaced the block of code for deleting a product with a call to the stock functions.

PRO Version:

  • Added an option to upload all images from within Easy Populate.
  • Added an option to check image usage.

Please note: Since google shopping is once again, partially, free, I changed the old Froogle code to work with it. But the output still follows the rules of the original Froogle. So while this option may work for some shops, if you plan to upload to Google Shopping, you would probably be better off using the Google Feeder addon. I may change the code in this addon to provide a full Google Shopping feed at some point but I'm not sure it is worth the time since the other addon exists.

Share this post


Link to post
Share on other sites

Hi Jack

Thanks for the latest version

Added all the files and when I click on "Easypopulate" I get a HTTP ERROR 500

Previous version was working to a point. I completely removed that before installing this version

Double/triple checked that I put the files in the correct places

Share this post


Link to post
Share on other sites
8 hours ago, FEEL Distribution said:

when I click on "Easypopulate" I get a HTTP ERROR 500

Unfortunately, that is a catch-all error and can be caused by many things. First, note that this addon is only for newer shops. It will work in Phoenix. It should work in Frozen though I haven't tested it. What version is your shop?

If it is the correct version, see if there is a file named error_log in the admin directory. If there is see if there are entries dealing with this addon. If the file is not there, your host can tell you what is causing the error, if they will.

 

Share this post


Link to post
Share on other sites

I'm using the latest Phoenix

I removed it and reinstalled version 3 with the alternative functions.php file and I can upload files ok just can't select what I download

I'll use that version for now until I get everything transferred then look into why with the latest version I'm getting a 500 error

Share this post


Link to post
Share on other sites
5 minutes ago, FEEL Distribution said:

I'm using the latest Phoenix

I removed it and reinstalled version 3 with the alternative functions.php file and I can upload files ok just can't select what I download

I'll use that version for now until I get everything transferred then look into why with the latest version I'm getting a 500 error

I've just removed the the admin/easypopulate.php (dated 03 01), from the latest version and replaced it with the one from the previous version (dated 28 12 attached), and I no longer get the http error

Just don't have the build now button

 

Screenshot 2021-01-09 at 7.04.44.png

easypopulate.php

Share this post


Link to post
Share on other sites
Posted (edited)

I am using this app for few days now, if I stop error reporting, all seems to work as normal, but with error reporting on, getting following errors, unable to find any solution discussed about this earlier:

Using Phoenix 1.0.7.12  - PHP 7.4.13

Easy Populate 3.1
Warning: Use of undefined constant EP_VERSION_TYPE - assumed 'EP_VERSION_TYPE' (this will throw an Error in a future version of PHP) in /homepages/31/d************/htdocs/H*********/admin/easypopulate.php on line 922
Warning: Use of undefined constant EP_SUPPORT_THREAD - assumed 'EP_SUPPORT_THREAD' (this will throw an Error in a future version of PHP) in /homepages/31/d************/htdocs/H*********/admin/easypopulate.php on line 928
EP_SUPPORT_THREAD	Please backup your database before performing any Easy Populate operations!
Warning: Use of undefined constant TITLE_UPLOAD_IMPORT - assumed 'TITLE_UPLOAD_IMPORT' (this will throw an Error in a future version of PHP) in /homepages/31/d************/htdocs/H*********/admin/easypopulate.php on line 1180
TITLE_UPLOAD_IMPORT
Warning: Use of undefined constant IMAGE_INSERT_INTO_DB - assumed 'IMAGE_INSERT_INTO_DB' (this will throw an Error in a future version of PHP) in /homepages/31/d************/htdocs/H*********/admin/easypopulate.php on line 1189
---
Warning: Use of undefined constant TITLE_UPLOAD_SPLIT - assumed 'TITLE_UPLOAD_SPLIT' (this will throw an Error in a future version of PHP) in /homepages/31/d************/htdocs/H*********/admin/easypopulate.php on line 1195
TITLE_UPLOAD_SPLIT
Warning: Use of undefined constant IMAGE_SPLIT_FILE - assumed 'IMAGE_SPLIT_FILE' (this will throw an Error in a future version of PHP) in /homepages/31/d************/htdocs/H*********/admin/easypopulate.php on line 1199
-----
Warning: Use of undefined constant TITLE_IMPORT_FILE_FROM_TEMP - assumed 'TITLE_IMPORT_FILE_FROM_TEMP' (this will throw an Error in a future version of PHP) in /homepages/31/d************/htdocs/H*********/admin/easypopulate.php on line 1205
TITLE_IMPORT_FILE_FROM_TEMP
Warning: Use of undefined constant IMAGE_INSERT_INTO_DB - assumed 'IMAGE_INSERT_INTO_DB' (this will throw an Error in a future version of PHP) in /homepages/31/d************/htdocs/H*********/admin/easypopulate.php on line 1237
-----
Warning: Use of undefined constant TITLE_EXPORT_FILE - assumed 'TITLE_EXPORT_FILE' (this will throw an Error in a future version of PHP) in /homepages/31/d************/htdocs/H*********/admin/easypopulate.php on line 1242
TITLE_EXPORT_FILE
---
Warning: Use of undefined constant TITLE_QUICK_LINKS - assumed 'TITLE_QUICK_LINKS' (this will throw an Error in a future version of PHP) in /homepages/31/d************/htdocs/H*********/admin/easypopulate.php on line 1362
TITLE_QUICK_LINKS
---
Warning: Use of undefined constant TITLE_ADDITIONAL_OPTIONS - assumed 'TITLE_ADDITIONAL_OPTIONS' (this will throw an Error in a future version of PHP) in /homepages/31/d************/htdocs/H*********/admin/easypopulate.php on line 1420
TITLE_ADDITIONAL_OPTIONS

Warning: Use of undefined constant TEXT_CHECK_IMAGE_USAGE - assumed 'TEXT_CHECK_IMAGE_USAGE' (this will throw an Error in a future version of PHP) in /homepages/31/d************/htdocs/H*********/admin/easypopulate.php on line 1425
TEXT_CHECK_IMAGE_USAGE

Warning: Use of undefined constant TEXT_CLEAR_TEMP - assumed 'TEXT_CLEAR_TEMP' (this will throw an Error in a future version of PHP) in /homepages/31/d************/htdocs/H*********/admin/easypopulate.php on line 1431
TEXT_CLEAR_TEMP

Warning: Use of undefined constant TEXT_UPLOAD_IMAGES - assumed 'TEXT_UPLOAD_IMAGES' (this will throw an Error in a future version of PHP) in /homepages/31/d************/htdocs/H*********/admin/easypopulate.php on line 1440

Warning: Use of undefined constant TEXT_OVERWRITE_IMAGES - assumed 'TEXT_OVERWRITE_IMAGES' (this will throw an Error in a future version of PHP) in /homepages/31/d************/htdocs/H*********/admin/easypopulate.php on line 1442

Any suggestion how to get rid of these warnings. Thanks

 

 

Edited by zeeshop

Share this post


Link to post
Share on other sites

@FEEL DistributionWithout having an indication of the failure I can't help. All I can suggest is to be sure all of the new files have been uploaded. This version uses several files that weren't present in the previous version and a missing file can cause the problem you are having.

Share this post


Link to post
Share on other sites

It turns out there is a missing file in the last released version. Please upload the attached to the includes/languages/english/ directory. I apologize to everyone for the mistake.

easypopulate.php

Share this post


Link to post
Share on other sites
38 minutes ago, Jack_mcs said:

@FEEL DistributionWithout having an indication of the failure I can't help. All I can suggest is to be sure all of the new files have been uploaded. This version uses several files that weren't present in the previous version and a missing file can cause the problem you are having.

I put the easy populate.php from version 3.1 back and the error I get is   Warning: require_once(includes/languages/english/easypopulate.php)

the only language file in the download is on the admin side,  catalog_easy_populate.php which is there

Share this post


Link to post
Share on other sites
Just now, FEEL Distribution said:

I put the easy populate.php from version 3.1 back and the error I get is   Warning: require_once(includes/languages/english/easypopulate.php)

the only language file in the download is on the admin side,  catalog_easy_populate.php which is there

Ignore this, I was writing as you Jack were writing your reply for the missing file

Share this post


Link to post
Share on other sites

@Jack_mcs

I noticed that when using this version to update stock, it add products, quantity, but changes in description is not updating. 

Does this require any setting to adjust or this function is unavailable in EP? 

Thanks

Share this post


Link to post
Share on other sites
6 hours ago, zeeshop said:

I noticed that when using this version to update stock, it add products, quantity, but changes in description is not updating. 

I verified this isn't working when updating. It does work for new products. It is a mistake in the code but I don't have a fix at this point. I will get to it as soon as I can. Thank you for reporting it.

Share this post


Link to post
Share on other sites

Hi,

I am trying to updated stock/ price using EP and no error coming in, but data does not seem to update. No warning coming in.

I also tried split file still not updating any thing and no error reported. This is a first time I used EP after updating to ver 1.0.7.13,not sure if this could be the cause. But strangely no error is shown.

image.thumb.png.af98b7216906a80b23992a542757b04e.png

 

Perhaps at present EP is working for new products only and update on any column is not happening.

Edited by zeeshop

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×