Jump to content
Jack_mcs

Easy Populate V 3.0

Recommended Posts

Be sure you are running a Phoenix shop, or maybe a later Frozen. If not, you are using the wrong addon. Otherwise, it seems your server has the display errors setting off so if you don't have access to the log file you will need to troubleshoot the file. But that is not something I can help with here, except for general comments.

Share this post


Link to post
Share on other sites
9 hours ago, gsmiley007 said:

Just wondering if this could support more images

Try changing the product images setting in the right column.

Share this post


Link to post
Share on other sites

Not sure where you are talking about: The only thing I see in the right column is Category depth: 7, but I don't see anything about number of images.

 

image.thumb.png.3fd851c3b96816444ed2222baad888cf.png

Share this post


Link to post
Share on other sites

Hello Jack @Jack_mcs, I hope you are very well and healthy.

I am testing this addon on frozen and it gives me the following error:

Fatal error: Class 'tableBlock_easy_populate' not found in C:\xampp7\htdocs\frozen\admin\easypopulate.php on line 248

Do you have any clues?

Best regards

Valqui


:heart: Community Oscommerce fan :heart: You'll find the latest osC community version here.

 

Share this post


Link to post
Share on other sites
15 hours ago, gsmiley007 said:

The only thing I see in the right column is Category depth: 7, but I don't see anything about number of images.

I said to enable the product images in the right column, which clearly shows in your image. In the EP file, the maximum number of images is controlled by the EP_PRODUCTS_IMAGES_MAX setting.

Share this post


Link to post
Share on other sites
12 hours ago, valquiria23 said:

Do you have any clues?

The file is included in the package. You need to upload it to the server.

Share this post


Link to post
Share on other sites

Hello Jack @Jack_mcs, 

9 hours ago, Jack_mcs said:

The file is included in the package. You need to upload it to the server.

I have it uploaded correctly to:
C:\ xampp \ htdocs \ frozen\ admin \ includes \ classes 


But nevertheless it keeps giving me the error. Any other idea?

Best regards.

Valqui


:heart: Community Oscommerce fan :heart: You'll find the latest osC community version here.

 

Share this post


Link to post
Share on other sites

@valquiria23In the EP file in admin, please find this

// modify tableBlock for use here.
class epbox extends tableBlock_easy_populate {

and add this above it

require 'includes/classes/table_block_easy_populate.php';

 

Share this post


Link to post
Share on other sites

I will continue to support all of my addons since I have clients that use them. Whether or not I can offer the support here is unknown at the moment. Phoenix isn't allowed here but my addons work for other versions that are allowed so I don't know where that leaves things.

As for it not working, it works fine in 1.0.8.0. I don't support minor upgrades, for free, since they come out too often and I have other things to do. This is the same for any developer, or at least it used to be. So if you want to always use the very latest version of Phoenix, you will have problems like this. You can post the problem you are having here, at least for now, and if it an easy fix I will post that. Otherwise, you will need to wait for the next release or pay for support.

Share this post


Link to post
Share on other sites

A new version has been uploaded with these changes:

  • Added statement to load the table class in the Frozen version.
  • Correct code for php warnings.
  • Updated for the latest shop.

 

Share this post


Link to post
Share on other sites

Hi,

Many thanks for providing continuous support. Really appreciated.

I am using Phoenix 1.0.8.8 and for some reason, my CSV file seems a bit broken, cells are not in order. attaching file for review, hopefully, it is something simple to resolve.

Many thanks and Merry Christmas to all

 

EP2021Dec22-1907.csv

Share this post


Link to post
Share on other sites

@Jack_mcs

While uploading updates to product, not updating instead giving below errors: PHP 7.4.25

Filename: EP_Split2.csv

Notice: Undefined index: v_status in /homepages/31/d854685020/htdocs/Test/admin/easypopulate.php on line 2236

Notice: Undefined index: in /homepages/31/d854685020/htdocs/Test/admin/easypopulate.php on line 2236

Notice: Trying to access array offset on value of type null in /homepages/31/d854685020/htdocs/Test/admin/easypopulate.php on line 2429

Notice: Undefined variable: v_status in /homepages/31/d854685020/htdocs/Test/admin/easypopulate.php on line 2532

Notice: Undefined variable: v_status in /homepages/31/d854685020/Test/admin/backoffice/easypopulate.php on line 2535
| FT_42231 | Fortune Te | 13.4595 Updated

Fatal error: DB: [1064] You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '00:00:00, products_last_modified='2021-12-' at line 9 from /homepages/31/d854685020/htdocs/Test/includes/system/versioned/1.0.8.1/database_core.php on line 44

Thanks

Share this post


Link to post
Share on other sites

@zeeshopPlease changing this line

    } elseif ( $items[$filelayout['v_status']] == EP_DELETE_IT ) {

to this

    } elseif ( isset($items[$filelayout['v_status']]) && $items[$filelayout['v_status']] == EP_DELETE_IT ) {

 

Share this post


Link to post
Share on other sites
Posted (edited)

Thanks,

On Phoenix v1.0.8.9

Made suggested change, still not updating products, getting below error/ message:
 

 

image.thumb.png.3b627a5b181f1e04aeddc0b9ab06dd09.png

Thanks

Edited by zeeshop

Share this post


Link to post
Share on other sites
19 hours ago, zeeshop said:

Made suggested change, still not updating products, getting below error/ message:

if ($temprow['v_categories_image_' . $categorylevel] != ''){

to this

if (isset($temprow['v_categories_image_' . $categorylevel]) && $temprow['v_categories_image_' . $categorylevel] != ''){

There are probably others but until I have time to go through the file I have to wait for reports so keep them coming. :)

Share this post


Link to post
Share on other sites

Thanks,

more errors but not updating the data, errors as below:

 

File uploaded.
Temporary filename: /tmp/phpvcbuSj
User filename: upload.csv
Size: 2852

Notice: Undefined index: v_status in /homepages/31/d854685020/htdocs/**********/************/easypopulate.php on line 2236

Notice: Trying to access array offset on value of type null in /homepages/31/d854685020/htdocs/**********/************/easypopulate.php on line 2429

Notice: Undefined variable: v_status in /homepages/31/d854685020/htdocs/**********/************/easypopulate.php on line 2532

Notice: Undefined variable: v_status in /homepages/31/d854685020/htdocs/**********/************/easypopulate.php on line 2535
| BW_48238 | Pack of 6 | A box of 6 | 5000 Updated

Fatal error: DB: [1064] You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '23:20:24, products_last_modified='2022-01-' at line 9 from /homepages/31/d854685020/htdocs/ZeeshopLive/includes/system/versioned/1.0.8.1/database_core.php on line 44

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×