Jump to content
fixfredssite

What version is my site using and php version required?

Recommended Posts

I have a website with errors:
http://www.digitalcontentagency.com/music/
http://music.digitalcontentagency.com/

Q. Can someone kindly tell me what version my site is?
(it was heavily modified by a programmer some years ago)

Q. What php version should I be running?
Q. The files the errors say are missing are actually there.
Q Could it be a permissions issue?

Wordpress is on the root and I have put the music library in /music folder.

===

The errors for:
http://music.digitalcontentagency.com/

Warning: require_once(/content/digitalcontentagency.com/music/local/class.memcacher.php): failed to open stream: No such file or directory in /homepages/41/d312843039/htdocs/clickandbuilds/digitalcontentagency/music/includes/functions/cache.php on line 13

Fatal error: require_once(): Failed opening required '/content/digitalcontentagency.com/music/local/class.memcacher.php' (include_path='/homepages/41/d312843039/htdocs/clickandbuilds/digitalcontentagency/music') in /homepages/41/d312843039/htdocs/clickandbuilds/digitalcontentagency/music/includes/functions/cache.php on line 13

===

The errors for: 
http://www.digitalcontentagency.com/music/

Deprecated: The each() function is deprecated. This message will be suppressed on further calls in /homepages/41/d312843039/htdocs/clickandbuilds/digitalcontentagency/music/includes/functions/compatibility.php on line 22

Warning: Use of undefined constant GZIP_COMPRESSION - assumed 'GZIP_COMPRESSION' (this will throw an Error in a future version of PHP) in /homepages/41/d312843039/htdocs/clickandbuilds/digitalcontentagency/music/includes/application_top.php on line 98

Warning: Use of undefined constant SEARCH_ENGINE_FRIENDLY_URLS - assumed 'SEARCH_ENGINE_FRIENDLY_URLS' (this will throw an Error in a future version of PHP) in /homepages/41/d312843039/htdocs/clickandbuilds/digitalcontentagency/music/includes/application_top.php on line 113

Warning: Use of undefined constant SEO_ENABLED - assumed 'SEO_ENABLED' (this will throw an Error in a future version of PHP) in /homepages/41/d312843039/htdocs/clickandbuilds/digitalcontentagency/music/includes/functions/html_output.php on line 16

Warning: Use of undefined constant USE_CACHE - assumed 'USE_CACHE' (this will throw an Error in a future version of PHP) in /homepages/41/d312843039/htdocs/clickandbuilds/digitalcontentagency/music/includes/application_top.php on line 145

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; shoppingCart has a deprecated constructor in /homepages/41/d312843039/htdocs/clickandbuilds/digitalcontentagency/music/includes/classes/shopping_cart.php on line 14

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; easy_discount has a deprecated constructor in /homepages/41/d312843039/htdocs/clickandbuilds/digitalcontentagency/music/includes/classes/easy_discount.php on line 2

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; navigationHistory has a deprecated constructor in /homepages/41/d312843039/htdocs/clickandbuilds/digitalcontentagency/music/includes/classes/navigation_history.php on line 13

Warning: require_once(/content/digitalcontentagency.com/music/local/class.memcacher.php): failed to open stream: No such file or directory in /homepages/41/d312843039/htdocs/clickandbuilds/digitalcontentagency/music/includes/functions/cache.php on line 13

Fatal error: require_once(): Failed opening required '/content/digitalcontentagency.com/music/local/class.memcacher.php' (include_path='/homepages/41/d312843039/htdocs/clickandbuilds/digitalcontentagency/music') in /homepages/41/d312843039/htdocs/clickandbuilds/digitalcontentagency/music/includes/functions/cache.php on line 13

Many thanks!

Fred

Share this post


Link to post
Share on other sites

Your server is most likely on php 7.

Your shop version is anything up to the last official version of osCommerce, which is not php 7 compliant.

Share this post


Link to post
Share on other sites

In includes/application_top.php look for code like

// define the project version --- obsolete, now retrieved with tep_get_version()
  define('PROJECT_VERSION', 'OSCOM CE Phoenix');

If it tells you to use tep_get_version, try looking in includes/version.php

To get the PHP version, try looking in Tools > Server Info

If your version of osCommerce doesn't have that, try looking for a file named phpinfo.php  Unfortunately, I don't remember where that appeared. 

If you can't find that, you could try making one.  The phpinfo function is available in all versions of PHP that I've used.  Save

<?php
  phpinfo();

as a file on your webserver.  If your admin is protected by htpasswd, then put it there.  If not, delete it after viewing it. 


Always backup before making changes.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×