Jump to content
rsthornton

Stripe Payment Module Not Working (Phoenix)

Recommended Posts

I installed the Stripe payment module from the list of options, however, I'm in "Test" mode and continue to get the following error.

 

There has been an error processing your credit card

Please try again and if problems persist, please try another payment method.

 

Any Ideas on what would be causing this error?

Share this post


Link to post
Share on other sites

Issued resolved by updating to Stripe SCA

Also, when testing the module you must use the Test Card numbers provided by Stripe on their website.

Share this post


Link to post
Share on other sites

You can also set your actual account to test mode and see all the information there to.

Why couldnt you get the old Stripe module to work,. I have it working on an old test site and it tests fine, but as Stripe say it may cause payments to fail, but as SCA is not currently required it should not really matter.


REMEMBER BACKUP, BACKUP AND BACKUP

Get the latest Responsive osCommerce CE (community edition) here

It's very easy to over complicate what are simple things in life

Share this post


Link to post
Share on other sites

I have the same issue.  I simply loaded the Phoenix 1.0.4.0 Stripe module, input the correct information (a live API is still working on my 2.3.4 store), but testing doesn't work.  Stripe shows a 404 error from using a "GET" with the following string: /v1/charges/oscommerce_connection_test.

I don't know if that will help someone find the issue, but I'm going to try the SCA, since the current Stripe module in Phoenix appears to use APIs that originated in 2014 and have been updated twice by Stripe since then, according to their site.

Share this post


Link to post
Share on other sites
15 hours ago, TomB01 said:

I have the same issue.  I simply loaded the Phoenix 1.0.4.0 Stripe module, input the correct information (a live API is still working on my 2.3.4 store), but testing doesn't work.  Stripe shows a 404 error from using a "GET" with the following string: /v1/charges/oscommerce_connection_test.

I don't know if that will help someone find the issue, but I'm going to try the SCA, since the current Stripe module in Phoenix appears to use APIs that originated in 2014 and have been updated twice by Stripe since then, according to their site.

I think this was mentioned somewhere else in another thread and the advice was to uload the latest Stripe SCA addon as you have suggested.


REMEMBER BACKUP, BACKUP AND BACKUP

Get the latest Responsive osCommerce CE (community edition) here

It's very easy to over complicate what are simple things in life

Share this post


Link to post
Share on other sites

Do not attempt to use the Stripe module that comes with Phoenix. Uninstall it and use the SCA version here.

It is the only version that will work with ALL customers cards.


OsC 2.3.4.1 CE Frozen   PHP 7.2   MySQL 10.1.36-MariaDB-cll-lve. Phoenix in development

Is your version of osC up to date? You'll find the latest osC community version (CE Phoenix 1.0.4.0) here.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×