Jump to content
LinkVanyali

Admin Login Not Working

Recommended Posts

Hi all,

I am truly puzzled. I have installed the latest version of oscommerce, run the setup and have a shop filled with demo items - all as expected

Problem is, when I try to log in to the admin side, making sure the password IS CORRECT, it doesn't log in and just seems to reload the admin login page. There are no error messages, it just doesn't log in.

I have tried after a fresh install, with default settings, and get the same results. 
I've found several explanations on-line and all the script changes I've found don't solve the issue

Is this a known issue and how can I get it fixed?

Share this post


Link to post
Share on other sites
10 minutes ago, LinkVanyali said:

I am truly puzzled. I have installed the latest version of oscommerce, run the setup and have a shop filled with demo items - all as expected

What latest version of oscommerce are you talking about?  See my signature file below.

If you're referring to that version you'll find updates to it in this thread.

Dan

Edited by Dan Cole
Add link to updates.

Share this post


Link to post
Share on other sites

Thanks for the quick reply and required information

I am using OsCom 2.3.4.1 Responsive, fresh install, PHP 7.2, description as previous post.

 

Share this post


Link to post
Share on other sites
Just now, LinkVanyali said:

Thanks for the quick reply and required information

I am using OsCom 2.3.4.1 Responsive, fresh install, PHP 7.2, description as previous post.

 

Look through the link I posted and get the latest version....1.0.2.8 I think.  You'll see it.

Dan

Share this post


Link to post
Share on other sites
23 minutes ago, LinkVanyali said:

I have installed the version recommended and am experiencing the same error.

So that isolates to the problem being specific to your server and configuration.
Double check you have user and password correct as the behaviour you describe is exactly what it does when they have been input incorrectly.
The only other workaround for this is via your database.

 

Edited by Heatherbell

Share this post


Link to post
Share on other sites

Check in public_html/error_log

It should show any errors that have been loged.

Also if you have wrong username or passowrd you should get an error on screen?

Go to public_html/youradmin/includes/configure.php

and check the settings for your admin name and password and make sure they match what you are using. Also make sure the login path you use match the path set for admin.

Edited by JcMagpie

 

Share this post


Link to post
Share on other sites

Thank you for your replies. 

The password entered is definitely correct - and is rejected with no error

Using credentials that do not exist is also rejected with no error

public_html/error_log does not exist

public_html/youradmin/includes/configure.php appears as follows:

<?php
  define('HTTP_SERVER', 'http://www.customcookie.co.za');
  define('HTTPS_SERVER', 'http://www.customcookie.co.za');
  define('ENABLE_SSL', false);
  define('HTTP_COOKIE_DOMAIN', '');
  define('HTTPS_COOKIE_DOMAIN', '');
  define('HTTP_COOKIE_PATH', '/eshop/oscomadmin');
  define('HTTPS_COOKIE_PATH', '/eshop/oscomadmin');
  define('HTTP_CATALOG_SERVER', 'http://www.customcookie.co.za');
  define('HTTPS_CATALOG_SERVER', 'http://www.customcookie.co.za');
  define('ENABLE_SSL_CATALOG', 'false');
  define('DIR_FS_DOCUMENT_ROOT', '/home/custozdy/public_html/eshop/');
  define('DIR_WS_ADMIN', '/eshop/oscomadmin/');
  define('DIR_WS_HTTPS_ADMIN', '/eshop/oscomadmin/');
  define('DIR_FS_ADMIN', '/home/custozdy/public_html/eshop/oscomadmin/');
  define('DIR_WS_CATALOG', '/eshop/');
  define('DIR_WS_HTTPS_CATALOG', '/eshop/');
  define('DIR_FS_CATALOG', '/home/custozdy/public_html/eshop/');
  define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');
  define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');
  define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');
  define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');
  define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');
  define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');
  define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');
  define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

  define('DB_SERVER', 'REDACTED');
  define('DB_SERVER_USERNAME', 'REDACTED');
  define('DB_SERVER_PASSWORD', 'REDACTED');
  define('DB_DATABASE', 'REDACTED');
  define('USE_PCONNECT', 'false');
  define('STORE_SESSIONS', 'mysql');
  define('CFG_TIME_ZONE', 'UTC');

The directory structure of /public_html/  looks as follows: 

dirstruct.png.a2e06f4f906957bd4973aa5295e126e3.png

 

Share this post


Link to post
Share on other sites

Looks like you are missing styling and js links to your admin. Probably down to the fact it's in a subdirectory you will need to check paths for admin.

Also you have SSL active on your main site so you will need to make osC paths https: also to avoid probelems.

image.png.b3bb4abb830194b5a3157ca97ae0493f.png

Edited by JcMagpie

 

Share this post


Link to post
Share on other sites

The login page looks like JcMagpie's attached picture if Chrome has 'load unsafe scripts' turned off

As I understand it, Chrome doesn't load scripts on non-https pages anymore

 

You mentioned a subdirectory - do you mean /public_html/eshop or something else?

Edited by LinkVanyali

Share this post


Link to post
Share on other sites

Actualy it's not so bad it's just your js beeing blocked as you are not using SSL on Phoenix. Change all paths in your config file to https and it should work.

image.thumb.png.d527a8c67ec9166841fe165c761aad7b.png


 

Share this post


Link to post
Share on other sites

Making the following changes to

/public_html/eshop/oscomadmin/includes/configure.php 

and

/public_html/eshop/includes/configure.php 

  define('HTTP_SERVER', 'https://customcookie.co.za');
  define('HTTPS_SERVER', 'https://customcookie.co.za');
  define('ENABLE_SSL', true);

has allowed me to log in

I still get the Chrome did not load unsafe scripts' error in the address bar but I can log in and manage the shop

Thanks for your help!

Share this post


Link to post
Share on other sites
3 minutes ago, LinkVanyali said:

I still get the Chrome did not load unsafe scripts' error in the address bar

Use the chrome inspection tool to track down which script is beeing flaged as unsafe and make sure it's beeing called from https.


 

Share this post


Link to post
Share on other sites

Looks like you have missed some changes in your  config file. It's pulling the stylesheet from http

www.customcookie.co.za/eshop/ext/jquery/ui/jquery-ui-1.10.4.min.js

You have 2 config file one in shop side one in admin side both need to have all paths set to https

Edited by JcMagpie

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×