Jump to content
Philo2005

New Products (products_new.php) - Sequences

Recommended Posts

Version 2.3.4 of OS Commerce shows new products in sequence of last entered products backwords.

With Phoenix Version 1 0 2 5 the sequence is implemented in a different way,
there is a choice of sorting by: Product Name Manufacturer or Price.

The choice of sort order does not work on my installation., no clue way I have not touched the products_new.php 

refers to. https://www.attias.ch/ishop/products_new.php/language/en/page/1

1. What do I wrong that the sort order can not be choosen (any settings)?
2. Is there any possibilities to change sequence to last added products (date added descending up to the earliest once)?

Thanks for any ideas

 

NewProducts.jpg

Edited by Philo2005

Share this post


Link to post
Share on other sites

This is what the delivered code does:

 

Screenshot 2019-10-18 09.00.04.png


For a new install or if your store isn't mobile-friendly, get the community-supported responsive osCommerce (Phoenix).

here: on the official osc download page

Working on generalising bespoke solutions for Quickbooks integration, Easify integration and pay4later (DEKO) integration at 2.3.x

Share this post


Link to post
Share on other sites

presumably you have changed

includes/modules/product_listing.php


For a new install or if your store isn't mobile-friendly, get the community-supported responsive osCommerce (Phoenix).

here: on the official osc download page

Working on generalising bespoke solutions for Quickbooks integration, Easify integration and pay4later (DEKO) integration at 2.3.x

Share this post


Link to post
Share on other sites
22 minutes ago, BrockleyJohn said:

presumably you have changed

includes/modules/product_listing.php

I have not changed the code of product_listing.php

But I saw you are using an other version of phoenix than i do.
You are using 2.3.4.1 CE Phoenix.
I am using OSCOM CE Phoenix v1.0.2.5.


 

 

Share this post


Link to post
Share on other sites

This is what the delivered code does; https://template.me.uk/phoenix/index.php?cPath=1

sort_by.jpg.328d0ce3543494aa1351b2908cf747b6.jpg

So, it is obvious that something in your site is incorrect.  And I suspect that is a problem in your language files.

Download a new 1.0.2.5 now and compare your main english language file to the one in 1.0.2.5.

In addition check your tep_create_sort_heading function in /includes/functions/general.php


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites
5 minutes ago, Philo2005 said:

I have not changed the code of product_listing.php

But I saw you are using an other version of phoenix than i do.
You are using 2.3.4.1 CE Phoenix.
I am using OSCOM CE Phoenix v1.0.2.5.


 

 

@BrockleyJohn

I solved the issue:

The Problem was a wrong setting in Product Listing
Sort Option: Latest Added (0=disable; 1=enable) set to 1

Thank you anyway 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×