Jump to content
Sign in to follow this  
Philo2005

product_info.php - pictures overpainted

Recommended Posts

With "CE Phoenix 1 0 2 0"  my picture of the article is overpainted on the "product_info.php" page ,
i have no clue why.

I tried  in the section "/admin/modules_content.php" but it is still overpainted/overwritten somewhere!

Any Ideas what I do wrong?

 

Share this post


Link to post
Share on other sites

Here the screenshot 

all product info settings are enabled

 

Should show 4 Pictures of article.
see printscreen of live shop: www.attias.ch/ishop
test shop: www.attias.ch/tshop (user Test1 Password Test.1Test.1) 

 

product_info1.jpg

productsettings.jpg

product_info2.jpg

Share this post


Link to post
Share on other sites

Your screenshots show it fairly obvious that your configure.php files are incorrect.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites
1 hour ago, burt said:

Your screenshots show it fairly obvious that your configure.php files are incorrect.

I disagree: There are two installation therefore also two different configure.php : one live shop v 2 3 4 1 "/ishop", the other the new CE Phoenix 1 0 2 0 5 test "/tshop"

Edited by Philo2005

Share this post


Link to post
Share on other sites
54 minutes ago, ArtcoInc said:

@Philo2005

In addition to what @burt pointed out, you have another issue here:

870501048_ScreenCapture09-30-2019.jpg.f1a0d2e86bcdbf155a9b81cb64033474.jpg

Malcolm

Yes I see this also inspecting the html code, but I dont know where to change the settings?

Share this post


Link to post
Share on other sites

It *looks* like you're using Burt's modular product info bundle. I don't have it installed anywhere, so I'm going by guess-and-by-golly. In the cm_pi_gallery module, look in the template file. The inspection says that it is in-line styling.

M


Get the latest Responsive osCommerce CE (community edition) here .

Share this post


Link to post
Share on other sites

You have a problem with your SSL settings, The images are not beeing shown as they are comming from none SSL links. Check your config files to make sure all Paths are SSL.

Most browsers now will not show images or links that are from none SSL path. The images are visable for a milisecond before they get hidden

image.png.48e8cdea0ea3ce422ff11b51f61b04d9.png


 

Share this post


Link to post
Share on other sites
14 minutes ago, ArtcoInc said:

It *looks* like you're using Burt's modular product info bundle.

He's definitely not. 

But I believe I found the cause;

http://www.attias.ch/tshop/ext/photoset-grid/jquery.photoset-grid.min.js

Gives 500 error, get that sorted. 
 


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

I found the problem:

in Admin "Header Tags" the "Colorbox Scripts" was active, which forced to overwrite my "product_info.php" page!


I have set this option to false and now the pictures are shown now! :-)

Problem solved... Thanks for the help

Share this post


Link to post
Share on other sites
1 hour ago, Philo2005 said:

what should happen running this script?

 

Colorbox is required for displaying multiple images in a gallery. If you use the picture gallery, then re-instate a copy of http://www.attias.ch/tshop/ext/photoset-grid/jquery.photoset-grid.min.js as Gary suggested, then the image will display just fine.

Share this post


Link to post
Share on other sites

Oh thank you it was a security issue, now it runs and everything looks better!!!

Share this post


Link to post
Share on other sites
5 hours ago, Philo2005 said:

I am testing various browser and found out compatibility Problems between Edge, Firefox, Chrome and Safari browser.

http://www.attias.ch/ishop/product_info.php?products_id=2661

works fine with Internet Explorer, Firefox, Opera and Chrome on Windows 7
works fine with Internet Explorer, Edge, Firefox on Windows 10
works fine with Safari on iPhone (6s).
Does not work properly with Chrome and Safari on iPad (Air 2)
Does not work properly with Chrome on iPhone (6s)

not tested yet Opera and Chrome on Windows 10

all browser latest release installed…
anybody knows compatibility Problems or setting issues?

Content.jpg

product.jpg

 

Edited by Philo2005

Share this post


Link to post
Share on other sites
On 10/8/2019 at 3:13 PM, Philo2005 said:

 

Google browser on iPad and iPhone runs properly on the inkognito modus. Maybe a security issue because i do not use SSL Connection up to day.
Safari on iPad runs properly after setting off the option "Reading list - automatically save offline" to false  

Problem solved temporary.

Share this post


Link to post
Share on other sites

it seems that Safari on iPad cached old webdata. 
To delete these data i had to remove the reading list links as the Favorit items.
then deleted all webdata on settings safari.
This issue on PC i resolve with ccCleaner, but i dont know any tool doing this on apple products.
Safari issue running now! 🙂

 

Share this post


Link to post
Share on other sites
On 9/30/2019 at 11:42 PM, JcMagpie said:

image.png.efc285a7ecf22fba5a5c172d386140b9.png

I let install by the internet host Company a new SSL Certificate on my server, so this issue is resolved
and all requests are newly rerouted to https:// ...

It means that some browser such as google on iPhone and iPad requires an SSL Certificate and TLS Connection to show and run Phoenix correctly.
Thank you for your idea, Maybe this should be mentioned in the installation guide!

Share this post


Link to post
Share on other sites
On 10/10/2019 at 11:01 AM, Philo2005 said:

it seems that Safari on iPad cached old webdata. 
To delete these data i had to remove the reading list links as the Favorit items.
then deleted all webdata on settings safari.
This issue on PC i resolve with ccCleaner, but i dont know any tool doing this on apple products.
Safari issue running now! 🙂

 

It was definitly the missing SSL Certificate and the TLS Connection, now it's installed and works fine on all browser…
for me as an amateur this was a hard issue.
 

Share this post


Link to post
Share on other sites
9 hours ago, Philo2005 said:

requires an SSL Certificate and TLS Connection to show and run Phoenix correctly

This is not correct as I understand it - SSL is not required but is advised in any case.
It seems this problem was browser cache - some servers also have cached data which can cause problems too.
Glad you have the problem sorted now :)

Share this post


Link to post
Share on other sites
13 hours ago, Philo2005 said:

It was definitly the missing SSL Certificate

Yes SSL is a MUST now for any ecart, Also most browsers wll now NOT show images or links that are from NONE SSL links on a SSL site.


 

Share this post


Link to post
Share on other sites

For anyone stumbling upon this thread and still wondering about should they use SSL?

3 Reasons Why Your Website Needs HTTPS

1. Maintain lead generation. Starting in October 2017, the Google Chrome web browser started showing a “not secure” warning when users started filling out a simple contact form or entering data in search field on a non-HTTPS website. Starting in July 2018, Google Chrome now displays a “not secure” error on any website not using the HTTPS protocol — regardless if users are filling out a form. So if you depend on your website generating leads and sales inquiries, your site needs to use the HTTPS protocol so users don’t freak out and abandon your site due to “non secure” warnings.

2. Improve your search engine rankings. In August 2014, Google announced that HTTPS is a ranking factor in their search algorithm. The jury’s still out as to how much of a factor HTTPS plays in your search rankings, but research suggests it’s becoming a stronger ranking factor. Just do any type of a Google search, and you’ll notice that nearly all of the page 1 results begin with an HTTPS URL. Google has also indicated that a HTTPS site can serve as a tie-breaker between two sites offering similar information.

3. Everybody’s doing it. Perhaps the most important reason to have an HTTPS site is perception. We live in a world where hacking and data breaches are everyday news, and people are concerned about online privacy and security. Even though your website isn’t collecting sensitive information, the fact that you have an HTTPS site and visitors can see the little padlock in their browser gives them comfort. And that translates to confidence and trust in your company. HTTPS is quickly becoming the norm, and even non-techie visitors are now starting to feel a little uneasy when they don’t see that padlock.

extract from, https://www.markbrinker.com/secure-https-website


 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×