Jump to content
asro2004

Stripe v3 module for SCA

Recommended Posts

Thinking of the idea of subscriptions/recurring billing as an option using the stripe api. Could perhaps be worked into this add-on. Thoughts?

https://stripe.com/docs/billing/subscriptions/overview

 


The water in a vessel is sparkling; the water in the sea is dark. The small truth has words which are clear; the great truth has great silence.

- Rabindranath Tagore

Share this post


Link to post
Share on other sites

I hope someone else is having this problem with Stripe.

I am getting a few instances a week where the Stripe payment module is taking the payments twice. Customers are claiming that they are only pressing the checkout button once, and there is only one order per customer. Is this happening to anyone else, and is there a cure for it. I am using the latest version of the addon on a frozen store.


REMEMBER BACKUP, BACKUP AND BACKUP

Get the latest Responsive osCommerce CE (community edition) here

It's very easy to over complicate what are simple things in life

Share this post


Link to post
Share on other sites

I can throw you that popup thing you tested (Supp Code) early if you like to try it on your live site.
Although it is for Bootstrap 4, it *might* work.


Help shape the future of Phoenix; join the Phoenix Club

Share this post


Link to post
Share on other sites
3 hours ago, 14steve14 said:

am getting a few instances a week where the Stripe payment module is taking the payments twice.

I've not seen any issue, as customers have been using PayPal over the last few weeks.  I'll keep an eye on this and let you know if any issue appears.


osC CE live - developing osC Phoenix adding modules with no core changes(awesome and easy!)

Share this post


Link to post
Share on other sites
5 hours ago, burt said:

I can throw you that popup thing you tested (Supp Code) early if you like to try it on your live site.
Although it is for Bootstrap 4, it *might* work.

Sorry Gary, been a bit busy. That would be good if you don't mind me having it.

I have narrowed it down to just Stripe where payments are being taken twice as it seems not to be affecting PayPal, but for the life of me I cannot find out why. Customers say that they are only clicking the button once, but there may be other things that they are not telling me. Its also not every payment as many go through fine. For now I have turned off Stripe partially due to another reason with them locking access to my account but they do say that they do not know of it happening to others. Again don't know whether or not to believe them.


REMEMBER BACKUP, BACKUP AND BACKUP

Get the latest Responsive osCommerce CE (community edition) here

It's very easy to over complicate what are simple things in life

Share this post


Link to post
Share on other sites
8 hours ago, 14steve14 said:

I hope someone else is having this problem with Stripe.

I am getting a few instances a week where the Stripe payment module is taking the payments twice. Customers are claiming that they are only pressing the checkout button once, and there is only one order per customer. Is this happening to anyone else, and is there a cure for it. I am using the latest version of the addon on a frozen store.

I do get the occasional duplicate payment, but it's quite rare.

 


The water in a vessel is sparkling; the water in the sea is dark. The small truth has words which are clear; the great truth has great silence.

- Rabindranath Tagore

Share this post


Link to post
Share on other sites
1 hour ago, 14steve14 said:

Sorry Gary, been a bit busy. That would be good if you don't mind me having it.

I have narrowed it down to just Stripe where payments are being taken twice as it seems not to be affecting PayPal, but for the life of me I cannot find out why. Customers say that they are only clicking the button once, but there may be other things that they are not telling me. Its also not every payment as many go through fine. For now I have turned off Stripe partially due to another reason with them locking access to my account but they do say that they do not know of it happening to others. Again don't know whether or not to believe them.

What people say is sometimes what they think you want to hear, and sometimes does not reflect reality.  I'll dig out that code and email you tomorrow.


Help shape the future of Phoenix; join the Phoenix Club

Share this post


Link to post
Share on other sites
21 hours ago, 14steve14 said:

I hope someone else is having this problem with Stripe.

I have had one yesterday, the two payments were 4 minutes apart and the first one although completing the payment has this error.

Error message
"message": "This PaymentIntent's amount could not be updated because it has a status of succeeded. You may only update the amount of a PaymentIntent with one of the following statuses: requires_payment_method, requires_confirmation, requires_action."
"type": "invalid_request_error"
 
I can see that both payments are coming to my Bank, now going to contact Stripe

Live Phoenix 1.0.5.0 on PHP 7.3

Is your version of osC up to date? You'll find the latest osC community version (CE Phoenix 1.0.7.6) here.

Share this post


Link to post
Share on other sites

Developments.. Large amount of heel digging by me.

Transcript of Chat.

OK. I have a duplicated transaction of £44.22 for the first time ever using CE Phoenix (Oscommerce) with their Stripe approved SCA Addon. Yesterday another user reported the same issue to you and you stated that no one else had had the issue, but now I have. There is error text in the first one Error message "message": "This PaymentIntent's amount could not be updated because it has a status of succeeded. You may only update the amount of a PaymentIntent with one of the following statuses: requires_payment_method, requires_confirmation, requires_action." "type": "invalid_request_error"

J

I'm currently reading your inquiry, give me a few minutes while I pull up your information.

OK

J

To clarify you were using the Stripe plugin from CE Phoenix (Oscommerce), is that correct?

Yes. It has worked flawlessly for nearly a year up to now

J

In this case, to update the integration, I wish I could be of a bit more help here, but since CE Phoenix (Oscommerce) built their integration with Stripe, they’ll be best able to help you with this directly.

Me

I understand, but nothing has changed in the Phoenix software. I and the other users update it ourselves when there is a new version released. So something must have changed at the Stripe end of the process. This is too much of a coincidence.

 

J

It looks like there was indeed more than one payment made by this customer. It’s possible that this customer may have gone through your checkout flow a second time, or they may have clicked “Pay” more than once while awaiting confirmation.

 

Me

Possibly BUT, only one instance of the order in Phoenix exists, only one Webhook response exists against the order and it is timed at 21.35 which is the first payment. The second one is 21.38 which presumably is your system trying again. The customer would have received an email confirmation immediately so why click a second time. She would have had to create a second order to achieve this anyway.

 

J

I'm afraid that this wouldn't be an issue we could best help with in chat, but I’d be happy to create a support request for you and have one of my colleagues follow up via email shortly. Is that ok with you?

 

Ah, the email has just arrived, I will report back.

 


Live Phoenix 1.0.5.0 on PHP 7.3

Is your version of osC up to date? You'll find the latest osC community version (CE Phoenix 1.0.7.6) here.

Share this post


Link to post
Share on other sites
1 hour ago, mhsuffolk said:

I have had one yesterday, the two payments were 4 minutes apart and the first one although completing the payment has this error.

I would love to look furthe rinto the Stripe side of things with mine, but I am currently unable to access my Stripe account. They say I have never had an account with them. I feel I have a way to go yet but will report oin the errors if there are any when I can get access. I cant even use chat as I cannot access my account.


REMEMBER BACKUP, BACKUP AND BACKUP

Get the latest Responsive osCommerce CE (community edition) here

It's very easy to over complicate what are simple things in life

Share this post


Link to post
Share on other sites
20 hours ago, burt said:

What people say is sometimes what they think you want to hear, and sometimes does not reflect reality.  I'll dig out that code and email you tomorrow.

I take a lot of things customers say with a large pinch of salt. Its never their fault and they do nothing wrong but still things happen that the website gets the blame for. Its as if they think it can do things on its own. I even had one customer once claim that the website must have created an account in his name using all his correct details because he never did, and he wanted the account deleted. He apparently only found out that an account was created when he received the welcome email.


REMEMBER BACKUP, BACKUP AND BACKUP

Get the latest Responsive osCommerce CE (community edition) here

It's very easy to over complicate what are simple things in life

Share this post


Link to post
Share on other sites
Posted (edited)

Many customers do not know where they live.

I have had, entering the incorrect Postal Town or using the village name instead. Giving me the Post Code for their previous address, and cramming the entire address into Address Line 1 with a random entry in the City field are just a few examples.

Edited by mhsuffolk

Live Phoenix 1.0.5.0 on PHP 7.3

Is your version of osC up to date? You'll find the latest osC community version (CE Phoenix 1.0.7.6) here.

Share this post


Link to post
Share on other sites
1 minute ago, mhsuffolk said:

Many customers do not know where they live.

I have had, entering the incorrect Postal Town or using the village name instead. Giving me the Post Code for their previous address, and cramming the entire address into Address Line 1 with a random entry in the City field are just a few examples.

Totally off topic but I am glad to see that its not only my customers.


REMEMBER BACKUP, BACKUP AND BACKUP

Get the latest Responsive osCommerce CE (community edition) here

It's very easy to over complicate what are simple things in life

Share this post


Link to post
Share on other sites

Whilst I have no idea what any of this means, and again, have no idea whether this is already implemented on the stripe module I found this page after a google search on others that are or were having the same duplicated payments problem.

https://stripe.com/docs/api/idempotent_requests


REMEMBER BACKUP, BACKUP AND BACKUP

Get the latest Responsive osCommerce CE (community edition) here

It's very easy to over complicate what are simple things in life

Share this post


Link to post
Share on other sites

I did a fresh install of Phoenix v 1.0.7.5 I was have issues with another program.  Thought it would be best to start over.  I'm also under PHP7.3

Reinstalling Stripe SCA V 1.0.16r1

Having trouble with installing cards management.  Moduels > Content  When I go to install I get this

1146 - Table 'phoenix.TABLE_CONFIGURATION' doesn't exist

insert into TABLE_CONFIGURATION (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, set_function, date_added) values ('Enable Stripe Card Management', 'MODULE_CONTENT_ACCOUNT_STRIPE_SCA_CARDS_STATUS', 'True', 'Do you want to enable the Stripe Card Management module?', '6', '1', 'tep_cfg_select_option(array(\'True\', \'False\'), ', now())

[TEP STOP]

 

 

Share this post


Link to post
Share on other sites

Just a warning to those users of this module. I had a customer place a fraudulent order the other day. He entered an address in Finland and changed the country to the UK as I only use this module to accept payments from UK based customers. The payment went through fine believe it or not. The order was not sent as the incorrect country was used which used the incorrect shipping option. 

I spoke to stripe about this and apparently this could happen. They have suggested a few changes to my Stripe account settings which may prevent it from happening again. It looks like the checks returned as "Unavailable" in the payment. This can happen as some banks do not carry out these checks at the time of payment. The checks in Stripe radar will only pick this up if the checks are actually failed when the checks are made. The changes I made were to what checks are actually required. Its in the Settings - Radar - Rules area in your Stripe admin dashboard.

The advice from Stripe is to check any payments where the tests are unavailable. They also said that you can block a user from paying for products using Stripe, and any card information in your block list can then used to prevent the same happening to other Stripe users as the data is shared.

Like I say, just a warning to be aware..


REMEMBER BACKUP, BACKUP AND BACKUP

Get the latest Responsive osCommerce CE (community edition) here

It's very easy to over complicate what are simple things in life

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×