Jump to content
asro2004

Stripe v3 module for SCA

Recommended Posts

On 11/25/2020 at 10:34 AM, burt said:

I believe this is down to the Order Status

and whether it is "public" viewable.  That would be where to check.

Admin > Localization > Order Status

Check "public status" on the status that Stripe orders get set to.

I know its was  along time ago, but with a bit of testing I eventually got this how I wanted it. It was indeed down to the public settings.


REMEMBER BACKUP, BACKUP AND BACKUP

Share this post


Link to post
Share on other sites

@kptuning

Yep, sorry, forgot that there is the version for older stores included which should at least run with OsCommerce 2.3.x

Use the version included in "All previous versions" folder. However it has not been tested with 2.3.x stores and PHP 5.x

From the error you show it seems that you tried to use the Phoenix 1.0.7.9. version

Because of this:

Quote

Please provide also always more detailed information.

- exact stripe_sca version you installed

 

Edited by raiwa

Share this post


Link to post
Share on other sites

I have been looking through the Stripe documentation to see if there is a way to email a customer to let them know that a payment has been made through Stripe from Stripe. It would appear that it is a possibility, but I have no idea on how to achieve this.

Has anyone done something similar, or would it be a good idea to add this into the addon so people know they have made a payment. It may also notify them if a payment has been taken twice as happens some times with this module.


REMEMBER BACKUP, BACKUP AND BACKUP

Share this post


Link to post
Share on other sites

@mhsuffolk Many thanks. Feel like a bit of a wally now. That will teach me to have a good look first. Looks like there are lots of other setting to explore now. I have always left things as they were setup originally.


REMEMBER BACKUP, BACKUP AND BACKUP

Share this post


Link to post
Share on other sites
1 hour ago, raiwa said:

@kptuning

Yep, sorry, forgot that there is the version for older stores included which should at least run with OsCommerce 2.3.x

Use the version included in "All previous versions" folder. However it has not been tested with 2.3.x stores and PHP 5.x

From the error you show it seems that you tried to use the Phoenix 1.0.7.9. version

Because of this:

 

Dear raiwa,

Good to know that you offer an official Stripe module for OsCommerce 2.3.X that has never been tested... 

Of course we've installed the version for all other previious versions. stripe_sca installed is version 1.0.17 FOR PREVIOUS VERSIONS as you can see in the screenshot provided.

As official Stripe module we need your support. I have not tested the module as it gets complicated to know how to configure it if the options are unreadable.

Thanks in advance.

Share this post


Link to post
Share on other sites

It seems version 1.0.6 shows correct the config entries with OsCOmmerce 2.3.4. Please try.

Share this post


Link to post
Share on other sites

I checked and the problem is that in version 1.0.7 the author replaced the hardcoded config titles and descriptions by language constants. This seems does only work in Phoenix.

Please replace in your  1.0.17 module  within the install function the params array lines 766-834 with this:


        $params = array('MODULE_PAYMENT_STRIPE_SCA_STATUS' => array('title' => 'Enable Stripe SCA Module',
                'desc' => 'Do you want to accept Stripe v3 payments?',
                'value' => 'True',
                'set_func' => 'tep_cfg_select_option(array(\'True\', \'False\'), '),
            'MODULE_PAYMENT_STRIPE_SCA_TRANSACTION_SERVER' => array('title' => 'Transaction Server',
                'desc' => 'Perform transactions on the production server or on the testing server.',
                'value' => 'Live',
                'set_func' => 'tep_cfg_select_option(array(\'Live\', \'Test\'), '),
            'MODULE_PAYMENT_STRIPE_SCA_LIVE_PUBLISHABLE_KEY' => array('title' => 'Live Publishable API Key',
                'desc' => 'The Stripe account publishable API key to use for production transactions.',
                'value' => ''),
            'MODULE_PAYMENT_STRIPE_SCA_LIVE_SECRET_KEY' => array('title' => 'Live Secret API Key',
                'desc' => 'The Stripe account secret API key to use with the live publishable key.',
                'value' => ''),
            'MODULE_PAYMENT_STRIPE_SCA_LIVE_WEBHOOK_SECRET' => array('title' => 'Live Webhook Signing Secret',
                'desc' => 'The Stripe account live webhook signing secret of the webhook you created to listen for payment_intent.succeeded events.',
                'value' => ''),
            'MODULE_PAYMENT_STRIPE_SCA_TEST_PUBLISHABLE_KEY' => array('title' => 'Test Publishable API Key',
                'desc' => 'The Stripe account publishable API key to use for testing.',
                'value' => ''),
            'MODULE_PAYMENT_STRIPE_SCA_TEST_SECRET_KEY' => array('title' => 'Test Secret API Key',
                'desc' => 'The Stripe account secret API key to use with the test publishable key.',
                'value' => ''),
            'MODULE_PAYMENT_STRIPE_SCA_TEST_WEBHOOK_SECRET' => array('title' => 'Test Webhook Signing Secret',
                'desc' => 'The Stripe account test webhook signing secret of the webhook you created to listen for payment_intent.succeeded events.',
                'value' => ''),
            'MODULE_PAYMENT_STRIPE_SCA_TOKENS' => array('title' => 'Create Tokens',
                'desc' => 'Create and store tokens for card payments customers can use on their next purchase?',
                'value' => 'False',
                'set_func' => 'tep_cfg_select_option(array(\'True\', \'False\'), '),
            'MODULE_PAYMENT_STRIPE_SCA_LOG' => array('title' => 'Log Events',
                'desc' => 'Log calls to Sripe functions?',
                'value' => 'False',
                'set_func' => 'tep_cfg_select_option(array(\'True\', \'False\'), '),
            'MODULE_PAYMENT_STRIPE_SCA_TRANSACTION_METHOD' => array('title' => 'Transaction Method',
                'desc' => 'The processing method to use for each transaction.',
                'value' => 'Authorize',
                'set_func' => 'tep_cfg_select_option(array(\'Authorize\', \'Capture\'), '),
            'MODULE_PAYMENT_STRIPE_SCA_PREPARE_ORDER_STATUS_ID' => array('title' => 'Set New Order Status',
                'desc' => 'Set the status of orders created with this payment module to this value',
                'value' => $prepare_status_id,
                'use_func' => 'tep_get_order_status_name',
                'set_func' => 'tep_cfg_pull_down_order_statuses('),
            'MODULE_PAYMENT_STRIPE_SCA_ORDER_STATUS_ID' => array('title' => 'Set Order Processed Status',
                'desc' => 'Set the status of orders successfully processed with this payment module to this value',
                'value' => '0',
                'use_func' => 'tep_get_order_status_name',
                'set_func' => 'tep_cfg_pull_down_order_statuses('),
            'MODULE_PAYMENT_STRIPE_SCA_TRANSACTION_ORDER_STATUS_ID' => array('title' => 'Transaction Order Status',
                'desc' => 'Include transaction information in this order status level',
                'value' => $status_id,
                'set_func' => 'tep_cfg_pull_down_order_statuses(',
                'use_func' => 'tep_get_order_status_name'),
            'MODULE_PAYMENT_STRIPE_SCA_ZONE' => array('title' => 'Payment Zone',
                'desc' => 'If a zone is selected, only enable this payment method for that zone.',
                'value' => '0',
                'use_func' => 'tep_get_zone_class_title',
                'set_func' => 'tep_cfg_pull_down_zone_classes('),
            'MODULE_PAYMENT_STRIPE_SCA_VERIFY_SSL' => array('title' => 'Verify SSL Certificate',
                'desc' => 'Verify gateway server SSL certificate on connection?',
                'value' => 'True',
                'set_func' => 'tep_cfg_select_option(array(\'True\', \'False\'), '),
            'MODULE_PAYMENT_STRIPE_SCA_PROXY' => array('title' => 'Proxy Server',
                'desc' => 'Send API requests through this proxy server. (host:port, eg: 123.45.67.89:8080 or proxy.example.com:8080)'),
            'MODULE_PAYMENT_STRIPE_SCA_DEBUG_EMAIL' => array('title' => 'Debug E-Mail Address',
                'desc' => 'All parameters of an invalid transaction will be sent to this email address.'),
            'MODULE_PAYMENT_STRIPE_SCA_SORT_ORDER' => array('title' => 'Sort order of display.',
                'desc' => 'Sort order of display. Lowest is displayed first.',
                'value' => '0'));

or use this module:

stripe_sca.php

Edited by raiwa

Share this post


Link to post
Share on other sites

Just to point out:

- It's not an "official" module

- I'm not the author, I'm only maintaining the module and update for Phoenix

- 2.3.x testing and the update which breaks it was done by the original author

Share this post


Link to post
Share on other sites

Uploaded update with the above fix for OsCommerce 2.x.x

Stripe v3 SCA Version 1.1.0r1

includes:

Full version 1.1.0 for Phoenix 1.0.7.9+ONLY!
No changes

Full version 1.0.17 for Phoenix 1.0.5.1+ONLY!
No changes

Full version 1.0.18 for all previous OSC and Phoenix versions
Changes 1.0.18
- Backed hardcoded configuration titles and descriptions for OsCommerce 2.x.x compatibility

Share this post


Link to post
Share on other sites
On 12/24/2020 at 1:37 PM, raiwa said:

Just to point out:

- It's not an "official" module

- I'm not the author, I'm only maintaining the module and update for Phoenix

- 2.3.x testing and the update which breaks it was done by the original author

Thanks a lot raiwa. It's been working fine ;)

Regards

Share this post


Link to post
Share on other sites

Hi @raiwa,

I have not used Strip payment method yet, and recently registered with them.

Can I use this module as stand on module for accepting Stripe processed payments. Also I am looking to install this on Phoenix version 1.0.7.14,, do you think it is compatible with newer version...Thanks

Share this post


Link to post
Share on other sites

I didn’t test it on 1.0.7.14.

Just try, it has a sandbox mode.

Share this post


Link to post
Share on other sites

@raiwa I can confirm it is working without any issue on Phoenix 1.0.7.14.

Wondering if Credit card details entry form can be changed to conventional style instead of one line form.

it is showing like this at a moment.

image.thumb.png.6d0e83e18eb16e30de886156a44d3ad4.png

Also is there a possibility of issue a refund to customer from own admin site, or this need to be done from Stripe website?

Thanks

Edited by zeeshop

Share this post


Link to post
Share on other sites
9 hours ago, zeeshop said:

Wondering if Credit card details entry form can be changed to conventional style instead of one line form.

This is not possible. It is retrieved and the style defined from Skype site.

9 hours ago, zeeshop said:

Also is there a possibility of issue a refund to customer from own admin site, or this need to be done from Stripe website?

Only from Strype site.

9 hours ago, zeeshop said:

@raiwa I can confirm it is working without any issue on Phoenix 1.0.7.14.

Thank you for the confirmation.

Share this post


Link to post
Share on other sites

Hello,

I registered with Stripe and installed the module for Oscommerce Phönix. It also works so far.

Now I've read that you can add additional payment methods to Stripe. I am interested in the Klarna and Sofort payment methods. What do I have to do to get it displayed in Oscommerce? Does that work with the module?

Many Thanks 

Kai

Share this post


Link to post
Share on other sites
16 minutes ago, snetz said:

Hello,

I registered with Stripe and installed the module for Oscommerce Phönix. It also works so far.

Now I've read that you can add additional payment methods to Stripe. I am interested in the Klarna and Sofort payment methods. What do I have to do to get it displayed in Oscommerce? Does that work with the module?

Many Thanks 

Kai

I don't know if these require additional support through the module.

Share this post


Link to post
Share on other sites

Share this post


Link to post
Share on other sites

I am using Phoenix 1.0.7.1 and I am having trouble with Stripe. I have downloaded the latest version for Phoenix 1.0.5.1+. When I send a test Webhook in the Test Modus in the Stripe Dashboard, it returns with a 500 Error. Any ideas what causes the problem? When I try it on the live store, I get the money but it does not update the status. Any help would be appreciated.

Share this post


Link to post
Share on other sites

- make sure you have the correct URL entered for the webhook, including https:// (I believe it must be a secure URL)

- check that it does not get redirected somehow in your .htaccess

- check that the webhook url does not get blocked in your server by some security settings (check with your hosting)

Edited by raiwa

Share this post


Link to post
Share on other sites

@raiwa

My site is now updated to Phoenix V 1.0.7.15 -

But for some reason when using Stripe (live or test), unable to complete checkout as below option is not appearing at all:

image.thumb.png.256fb81b814a46c1ff144ed3823a7800.png

I also installed Discount code recently and thought this may be the issue, but when tested I tested PayPal direct or cash on delivery method, checkout process seems to be working fine.

Kindly advise if it is only me or some code need adjusting.

Thanks

Share this post


Link to post
Share on other sites

I tested with 1.0.7.15 and it works. I also tried wit discount codes and all seems to work correct.

Share this post


Link to post
Share on other sites

Thanks, Dont know the reason, but I had to do full re-install of discount code. 

all seems to be working fine.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×