Jump to content

Recommended Posts

OK I have obviously missed something with my converting of OSC 2.3.4.1 to OSC CE 1.0.2.1

No category product display

I can see the textual  categories - no items
I can see the sub categories - no items

Clicking on whatever item is displayed in the Specials box displays the item description and pic

Add to Cart puts the item into the cart and display the item name and pic

SO - what have I missed?  

0-front page.JPG

Category w subs.JPG

Category wo subs.JPG

item fm specials.JPG

Reviews - WhatsNws.JPG

specials - Reviews.JPG

cart.JPG

Share this post


Link to post
Share on other sites
6 minutes ago, LeeFoster said:

Looks like you've not added any images to your categories as the names are there.

I have not yet gotten that far.

IF I can not see the products in either the categories or the sub categories it does not make sense to add more clutter to the basic installation which this is. 

Simply changing to the DEFAULT database everything displays fine.   It is obviously a toggle or something that I have NOT enabled.

Share this post


Link to post
Share on other sites
25 minutes ago, Chadduck said:

I have not yet gotten that far.

IF I can not see the products in either the categories or the sub categories it does not make sense to add more clutter to the basic installation which this is. 

Simply changing to the DEFAULT database everything displays fine.   It is obviously a toggle or something that I have NOT enabled.

You can see the Category names in your second image - Medals, Other Items & The Pendant.

 

Share this post


Link to post
Share on other sites
Posted (edited)

I also noticed that the SEARCH returns the CORRECT item count but does not display items.

Search ORIG DB is the ORIGINAL Database
Search Converted DB is the CONVERTED batabase

Search ORIG DB.JPG

Search Converted DB.JPG

Edited by Chadduck

Share this post


Link to post
Share on other sites
12 minutes ago, LeeFoster said:

Is the site live or on a local host?

It is LOCAL Thankfully I am not doing this on a LIVE site

I just do not understand WHY the items do not show up.  I even moved one from a category to "top" and still no display. It is fairly obvious (at least to me) that I have missed enabling something somewhere. 

I have pdf'd every basic configuration page of the administration on the ORIG DB.  I am now comparing with the CONVERTED DB settings to see if I can locate my error.

BTW Lee Thank you for your assistance.  

 

Share this post


Link to post
Share on other sites

in the admin under configuration -> product listing can you see this

image.thumb.png.c2c5645536e033f9b900477ccc2dbeff.png

in your converted DB.

Share this post


Link to post
Share on other sites
4 minutes ago, puddlec said:

in the admin under configuration -> product listing can you see this

image.thumb.png.c2c5645536e033f9b900477ccc2dbeff.png

in your converted DB.

I just found that I CAN NOT...

In fact I was just coming to ask what happened...  Here is what the CONVERTED DB has

Product Listing - Converted.JPG

Share this post


Link to post
Share on other sites

SOLVED

Well, I now have images.  The issue was what puddlec pointed out.  WITHOUT that being in the database nothing displayed.

Here is the SQL that I found in the initial barebones OSC 1.0.2.1 oscommerce.sql and inserted into the converted database.


INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, set_function, date_added) VALUES ('Product Card Layout', 'IS_PRODUCT_PRODUCTS_LAYOUT', 'card-deck', 'What Layout suits your shop?  See https://getbootstrap.com/docs/4.3/components/card/#card-layout <div class="secWarning">card-columns is a special use case that will not suit most shops as card-columns is very difficult to layout and sort by...</div>', '8', '100', 'tep_cfg_select_option(array(\'card-group\', \'card-deck\', \'card-columns\'), ', now());
INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, set_function, date_added) VALUES ('Products In Each Row (SM)', 'IS_PRODUCT_PRODUCTS_DISPLAY_ROW_SM', '2', 'How many products should display per Row in SM (Small) viewport?', '8', '110', 'tep_cfg_select_option(array(\'12\', \'11\', \'10\', \'9\', \'8\', \'7\', \'6\', \'5\', \'4\', \'3\', \'2\', \'1\'), ', now());
INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, set_function, date_added) VALUES ('Products In Each Row (MD)', 'IS_PRODUCT_PRODUCTS_DISPLAY_ROW_MD', '3', 'How many products should display per Row in MD (Medium) viewport?', '8', '120', 'tep_cfg_select_option(array(\'12\', \'11\', \'10\', \'9\', \'8\', \'7\', \'6\', \'5\', \'4\', \'3\', \'2\', \'1\'), ', now());
INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, set_function, date_added) VALUES ('Products In Each Row (LG)', 'IS_PRODUCT_PRODUCTS_DISPLAY_ROW_LG', '4', 'How many products should display per Row in LG (Large) viewport?', '8', '130', 'tep_cfg_select_option(array(\'12\', \'11\', \'10\', \'9\', \'8\', \'7\', \'6\', \'5\', \'4\', \'3\', \'2\', \'1\'), ', now());
INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, set_function, date_added) VALUES ('Products In Each Row (XL)', 'IS_PRODUCT_PRODUCTS_DISPLAY_ROW_XL', '4', 'How many products should display per Row in XL (Large) viewport?', '8', '140', 'tep_cfg_select_option(array(\'12\', \'11\', \'10\', \'9\', \'8\', \'7\', \'6\', \'5\', \'4\', \'3\', \'2\', \'1\'), ', now());


INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Sort Option: Manufacturer Name (0=disable; 1=enable)','PRODUCT_LIST_MANUFACTURER', '0', 'Allow sorting by Manufacturer Name?', '8', '200', now());
INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Sort Option: Model (0=disable; 1=enable)', 'PRODUCT_LIST_MODEL', '0', 'Allow sorting by Product Model?', '8', '210', now());
INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Sort Option: Name (0=disable; 1=enable)', 'PRODUCT_LIST_NAME', '1', 'Allow sorting by Product Name?', '8', '220', now());
INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Sort Option: Price (0=disable; 1=enable)', 'PRODUCT_LIST_PRICE', '1', 'Allow sorting by Product Price', '8', '230', now());
INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Sort Option: Stock (0=disable; 1=enable)', 'PRODUCT_LIST_QUANTITY', '0', 'Allow sorting by Product Quantity (Stock)?', '8', '240', now());
INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Sort Option: Weight (0=disable; 1=enable)', 'PRODUCT_LIST_WEIGHT', '0', 'Allow sorting by Product Weight?', '8', '250', now());
INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Sort Option: Latest Added (0=disable; 1=enable)', 'PRODUCT_LIST_ID', '1', 'Allow sorting by Latest Added?', '8', '260', now());
INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Sort Option: Sales (0=disable; 1=enable)', 'PRODUCT_LIST_ORDERED', '1', 'Allow sorting by Number of Sales?', '8', '270', now());
INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Product Image (defunct)', 'PRODUCT_LIST_IMAGE', '0', 'This is a defunct setting.', '8', '280', now());
INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Buy Now column (defunct)', 'PRODUCT_LIST_BUY_NOW', '0', 'This is a defunct setting.', '8', '290', now());
INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Display Category/Manufacturer Filter (0=disable; 1=enable)', 'PRODUCT_LIST_FILTER', '1', 'Do you want to display the Category/Manufacturer Filter?', '8', '300', now());
INSERT INTO configuration (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, date_added) VALUES ('Location of Prev/Next Navigation Bar (1-top, 2-bottom, 3-both)', 'PREV_NEXT_BAR_LOCATION', '2', 'Sets the location of the Prev/Next Navigation Bar (1-top, 2-bottom, 3-both)', '8', '310', now());

When I ran that in phpMyAdmin and the variable were available the front end displayed the items and images.

THANK YOU to Lee Foster and puddlec for your assistance.

Share this post


Link to post
Share on other sites

@Chadduck

did you import your 2.3.4.1 DB into your Phoenix environment.  If so you must of imported the configurations tables too.

Perhaps what you should do is create the Phoenix environment using the install script, and then import tables one by one from the 2.3.4.1 DB to the Phoenix DB, but NOT the configuration tables.  That's the only way I found to work without issues.


osC BS gold live - osC CE in development (awesome)

Share this post


Link to post
Share on other sites
Posted (edited)

@Mikepo

I followed the instructions by Jack_MCS in his post
Upgrading to the latest version
https://forums.oscommerce.com/topic/408979-upgrading-to-the-latest-version/

then did as directed by his post which took me to 

Burt's posting about database conversion here
2.3.4(normal) to 2.3.4(responsive) database conversion script
https://forums.oscommerce.com/topic/399678-234normal-to-234responsive-database-conversion-script/

As of this point - everything seems to be working BUT as with any migration this extensive - what remains is still unknown.
Obviously this is a work in progress.  As all who know me by my postings - I am not afraid to ask for help and then posting HOW I solved the issue.

Edited by Chadduck

Share this post


Link to post
Share on other sites

@Chadduck

Following those postings is ok generally, as those instructions relate to migrating from 2.3.4.1 to the first responsive version.

Phoenix is a bigger change, and the configutation tables are key to the functionality of the code.  So if you have not added any addons to your phoenix working installation, you could try exporting the two configuration tables from a baseline phoenix install and then import them into your working Phoenix installation.  At least the configrations keys will be then correct.


osC BS gold live - osC CE in development (awesome)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×