Jump to content
torinwalker

New UPS XML Shipping Module available

Recommended Posts

Shipping modules are "recognized" by admin/modules/shipping

 

So if you still have the old module you should now see two UPS shipping modules. One of which will be the UPSXML one.

 

 

 

Well I do not know what I did wrong, I do not have a admin/modules/shipping but I have installed upsxml.php in includes/modules/shipping, also in that folder there is a ups.php. I removed the ups.php and there is no ups shipping available to me. I reinstalled the ups.php and there is only ups shipping never has been upsxml.

Share this post


Link to post
Share on other sites

Well I do not know what I did wrong, I do not have a admin/modules/shipping but I have installed upsxml.php in includes/modules/shipping, also in that folder there is a ups.php. I removed the ups.php and there is no ups shipping available to me. I reinstalled the ups.php and there is only ups shipping never has been upsxml.

I meant admin->modules->shipping. You cannot remove just one ups.php file, you also need to remove the corresponding language file. That also goes for installing. Modules need the "shipping" file and the corresponding language file otherwise you will get an error (but depending on how the server is setup you might not see the error).

Share this post


Link to post
Share on other sites

I meant admin->modules->shipping. You cannot remove just one ups.php file, you also need to remove the corresponding language file. That also goes for installing. Modules need the "shipping" file and the corresponding language file otherwise you will get an error (but depending on how the server is setup you might not see the error).

 

Still does not work, I removed ups.php from catalog/includes/modules/shipping and catalog/includes/languages/english/modules/shipping. When I go into admin>modules>shipping the only choices are flat rate, per item, table rate, United States Postal Service, and zone rates (no UPS OR UPSXML)

Share this post


Link to post
Share on other sites

Still does not work, I removed ups.php from catalog/includes/modules/shipping and catalog/includes/languages/english/modules/shipping. When I go into admin>modules>shipping the only choices are flat rate, per item, table rate, United States Postal Service, and zone rates (no UPS OR UPSXML)

There is nothing special about recognition of modules that can be installed. The only thing I can think of is that when you uploaded the upxsml files (to the includes/modules/shipping directory and the corresponding language directory) the files have not sufficient permissions to be read by the webserver.

Share this post


Link to post
Share on other sites

There is nothing special about recognition of modules that can be installed. The only thing I can think of is that when you uploaded the upxsml files (to the includes/modules/shipping directory and the corresponding language directory) the files have not sufficient permissions to be read by the webserver.

 

I really appreciate your help, I checked the permissions on both files and they are the same as the other shipping modules. Could it be the php version I am using?

Share this post


Link to post
Share on other sites

Could it be the php version I am using?

Unlikely if you ask me. Did you also upload the files needed for the XML handling? Needed for both the catalog and the admin side, directory classes?

 

If you view the page source in your browser there is no sudden stop of the page, no error, everything as it should be?

Share this post


Link to post
Share on other sites

Unlikely if you ask me. Did you also upload the files needed for the XML handling? Needed for both the catalog and the admin side, directory classes?

 

If you view the page source in your browser there is no sudden stop of the page, no error, everything as it should be?

 

I assume you are asking if the xml_5.php and xml.php files are installed in admin/includes/classes and includes/classes and if so they are.

I cannot see any errors in the page source My link

Share this post


Link to post
Share on other sites

I cannot see any errors in the page source

I mean the page source (in the browser) of admin/modules.php?set=shipping

Share this post


Link to post
Share on other sites

I mean the page source (in the browser) of admin/modules.php?set=shipping

 

I can see no error, it calls out in the class=dataTableContent Flat Rate, Per Item, Table Rate, United States Postal Service, and Zone Rates nothing with UPSXML.

Share this post


Link to post
Share on other sites

I can see no error, it calls out in the class=dataTableContent Flat Rate, Per Item, Table Rate, United States Postal Service, and Zone Rates nothing with UPSXML.

I have no clue what goes wrong here. If you look at the bottom of the table, does the location of the directory match the place where uploaded the shipping module upsxml.php?

Module Directory: /Library/WebServer/Documents/catalog/includes/modules/shipping/

 

You can check what the webserver reads as files in that directory when you add a bit of code to admin/modules.php around line 122 (showing lines 120 and further):

 

    sort($directory_array);
   $dir->close();
 }
echo '<pre>';
print_r($directory_array);
echo '</pre>';
 $installed_modules = array();
 for ($i=0, $n=sizeof($directory_array); $i<$n; $i++) {

 

In a standard install (like mine) it shows:

 

Array
(
   [0] => flat.php
   [1] => item.php
   [2] => table.php
   [3] => usps.php
   [4] => zones.php
)

In your case upsxml.php should be in there.

Share this post


Link to post
Share on other sites

I have no clue what goes wrong here. If you look at the bottom of the table, does the location of the directory match the place where uploaded the shipping module upsxml.php?

Module Directory: /Library/WebServer/Documents/catalog/includes/modules/shipping/

 

it shows Module Directory: /home/content/50/5607150/html/catalog/includes/modules/shipping/

 

here are the arrays;

 

Array

(

[0] => flat.php

[1] => item.php

[2] => table.php

[3] => upsxml.php

[4] => usps.php

[5] => zones.php

)

Edited by lhuggins

Share this post


Link to post
Share on other sites

here are the arrays;

 

Array

(

[0] => flat.php

[1] => item.php

[2] => table.php

[3] => upsxml.php

[4] => usps.php

[5] => zones.php

)

So far so good. Are you 100% sure you didn't accidently uploaded the language file to the catalog/includes/modules/shipping directory? Otherwise I am out of ideas.

Share this post


Link to post
Share on other sites

So far so good. Are you 100% sure you didn't accidently uploaded the language file to the catalog/includes/modules/shipping directory? Otherwise I am out of ideas.

 

 

Thank you so much, that was the problem.

Share this post


Link to post
Share on other sites

If you have mods to the original get_products function (like SPPC) be aware that these are not in the function get_products_for_packaging !!

 

 

Maybe i missed it, but how can i get split products to work in SPPC? It looks like it works but according to your statement it wont. Any help would be appreciated.

Share this post


Link to post
Share on other sites

Help! Under Configuration > Shipping/Packing > Enter the Maximum Package Weight you will ship, I entered 75. Yet when I'm checking out with a product that weighs a lot more than 75lbs I still get a quote back from UPS. I want it to show the error message about it being too heavy for a quote. What have I done wrong?

Share this post


Link to post
Share on other sites

Help! Under Configuration > Shipping/Packing > Enter the Maximum Package Weight you will ship, I entered 75. Yet when I'm checking out with a product that weighs a lot more than 75lbs I still get a quote back from UPS. I want it to show the error message about it being too heavy for a quote. What have I done wrong?

Nothing wrong here. This setting is for the maximum weight of one box. I don't think UPS will like 75 pounds though.

Standard osC doesn't care about an item being 75 pounds. It will happily split the weight over two ore more boxes.

 

You could disable UPS to appear when the weight is too high. See for example this webpage:

 

http://www.clubosc.com/interactive-modules-in-oscommerce.html

Share this post


Link to post
Share on other sites

Maybe i missed it, but how can i get split products to work in SPPC? It looks like it works but according to your statement it wont.

SPPC is mostly about prices of course, so if you use insurance and haven't changed that function you will insure the value using the prices of the retail customer.

Share this post


Link to post
Share on other sites

SPPC is mostly about prices of course, so if you use insurance and haven't changed that function you will insure the value using the prices of the retail customer.

 

 

Thanks! Great! Thats probably the quickest and clearest response I have gotten on here.

Share this post


Link to post
Share on other sites

What are our options when dealing with oversized products. Right now i have a warning that comes up that says " This item is oversized. Please contact to receive freight shipping quote". However it wont let me proceed to the next page without having a shipper selected. I havent seen any mods that handle UPS freight.

Share this post


Link to post
Share on other sites

What are our options when dealing with oversized products. Right now i have a warning that comes up that says " This item is oversized. Please contact to receive freight shipping quote". However it wont let me proceed to the next page without having a shipper selected. I havent seen any mods that handle UPS freight.

 

 

Nevermind, found a mod to add option for Request a Quote.

Share this post


Link to post
Share on other sites

Is there a way to display days in transit instead of EDD? On some items I ship the same day as order is entered but some items it will not ship for up to 5 weeks so if days in transit were displayed then it would work for these long lead time items. It appears to me I only have a choice between, not displayed, raw and detailed all of which show a delivery date not days in transit.

Share this post


Link to post
Share on other sites

Is there a way to display days in transit instead of EDD? On some items I ship the same day as order is entered but some items it will not ship for up to 5 weeks so if days in transit were displayed then it would work for these long lead time items. It appears to me I only have a choice between, not displayed, raw and detailed all of which show a delivery date not days in transit.

UPS returns a delivery date using the date you will ship (using shipping delay - admin option - and not shipping on weekends). You would need to hack the code to calculate the days in transit using your own "ship date" and the delivery date UPS returns.

Share this post


Link to post
Share on other sites

UPS returns a delivery date using the date you will ship (using shipping delay - admin option - and not shipping on weekends). You would need to hack the code to calculate the days in transit using your own "ship date" and the delivery date UPS returns.

 

As always thank you for the help.

Share this post


Link to post
Share on other sites

We installed the UPSXML module on a site back in November then got redirected to another project for the same client. Now, well actually for the past month, we're back to developing the original project and keep getting a "Fatal error" when trying to check out (checkout_confirmation.php) when conducting a test order. I'm wondering if this might be related to the installation of the UPSXML module and if we should reinstall? It specifically states that it cannot redeclare class shipping and references includes/classes/shipping.php. Does this sound like it could be related to this module?

Share this post


Link to post
Share on other sites

It specifically states that it cannot redeclare class shipping and references includes/classes/shipping.php. Does this sound like it could be related to this module?

Sounds like you uploaded the shippping module to the language directory.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×