Jump to content
torinwalker

New UPS XML Shipping Module available

Recommended Posts

Not more than what is mentioned in the various files in the package.

In tools->packaging you enter the dimensions of the boxes you use for shipping.

When an item is shipped in its own box (for example an appliance) and so doesn't need to go through "packaging". In standard osC the total weight of all items is taken, a formula for tare is applied and then it is divided by the maximum weight per box, rounded up to get to the number of boxes. With the ready-to-ship option for dimensions support, items shipped in their own box will be excluded from that formula. For some people that is handy.

 

Our store will probably only be using around 10 different size boxes. Gift Baskets. I saw there was a contribution "Packaging_data". Are you familiar with this contribution? I'm not sure if it's worth installing if were only using a few different size boxes.

 

Thanks

Share this post


Link to post
Share on other sites

Helter,

 

Your admin pages are unprotected and by posting the url here you are putting yourself at great risk IMHO. Anyone can go to your admin panel, access your data, and do great damage. Some website panels have a "web protect" section that will do the following for you. The following is a reprint from a section on osmax.

 

"Your admin section should be password protected. The easiest way to do this is to use .htpasswd and .htaccess to secure the directory. If you are not sure how to do this, please follow the procedure outlined below:

 

* Add this code to your .htaccess file

 

AuthType Basic

AuthName "Locked Area"

AuthUserFile /home/youraccount/.htpasswds/admin/passwd

require valid-user

 

* Next, create your .htpasswd file. There are several ways to do this, but here is a non-linux users way: go to this web site http://www.kelv.net/programming/htaccess/ and follow the instructions! "

 

You should consider changing your access key and all important info since it's been exposed. Sorry for going off topic here, but it seemed like a critical point.


John Wisdom

Share this post


Link to post
Share on other sites
Our store will probably only be using around 10 different size boxes. Gift Baskets.
Use the dimensions of those boxes, since they are the ones that will be used for packaging.

Share this post


Link to post
Share on other sites
I just finished installing UPS XML Rates v1.2.4 along with Dimensional Support. These are really great contributions. The installation went fine for both. Does anyone know if there is any user documentation for these contributions? What is the difference between entering the length-width-height directly from the Categories / Products page for each item verses the packaging table in Admin ->Tools -> Packaging? Where does Ready to Ship come into play? Maybe I missed it in the install doc’s or I’m just burnt out after doing the installation. Any help would be greatly appreciated!!!

 

I also installed the UPS XML Rates v1.2.4 module and everything seems to be working property except I'm getting 'Next Day Air Saver' and 'Next Day Air' listed as options even tho I deleted them from \catalog\includes\modules\shipping\upsxml.php (line 424) as per Step 5 of readme.txt instructions. They're not listed as options in the shipping configuration so apparently they're coming from somewhere else. Anyone have any ideas?

Share this post


Link to post
Share on other sites
I just finished installing UPS XML Rates v1.2.4 along with Dimensional Support. These are really great contributions. The installation went fine for both. Does anyone know if there is any user documentation for these contributions? What is the difference between entering the length-width-height directly from the Categories / Products page for each item verses the packaging table in Admin ->Tools -> Packaging? Where does Ready to Ship come into play? Maybe I missed it in the install doc’s or I’m just burnt out after doing the installation. Any help would be greatly appreciated!!!
Edited by lkwood

Share this post


Link to post
Share on other sites
I also installed the UPS XML Rates v1.2.4 module and everything seems to be working property except I'm getting 'Next Day Air Saver' and 'Next Day Air' listed as options even tho I deleted them from \catalog\includes\modules\shipping\upsxml.php (line 424) as per Step 5 of readme.txt instructions. They're not listed as options in the shipping configuration so apparently they're coming from somewhere else.
Ah, well that should have been changed in the readme.txt. The behaviour was changed starting with the 1.2 series:
Changed the excluding of shipping options from having the allowed options stored in the database to having the disallowed options stored (this makes installation less sensitive to operator error, the module does not depend on correct installation of the things needed for that).
Otherwise, the people who don't understand what they are doing and skip the things they don't understand wouldn't have a module loading (HELP, HELP, HELP you get the picture). Now it only doesn't do the excluding when they do that.

 

What you need to do is to go back to that file and get out the ones you do want to offer and put back in the ones you don't want to offer (than you can choose them in the admin).

Share this post


Link to post
Share on other sites

I am getting ready to install this module and we do have a UPS online account.

 

My question is what would be the "Access Key, Username and Password"

Is the access key my UPS account and i presume username would be my online username?

 

Correct me if i am wrong or direct me to the right area to get this information.

Share this post


Link to post
Share on other sites

I went to UPS logged in and was able to get keys.

 

Which one do I USE with this UPSXML Contrib:

Developer's Key -or- Access Key

Share this post


Link to post
Share on other sites

i installed the UPS module that was ok no errors but when i go to do a test and click on checkout it justs does not do anything it says wating for avengermxboard.net (thats my website)

Share this post


Link to post
Share on other sites
i installed the UPS module that was ok no errors but when i go to do a test and click on checkout it justs does not do anything it says wating for avengermxboard.net (thats my website)
Their seems to be a lot more wrong because when I go that site it says:

Warning: mysql_connect(): Access denied for user: '***@***' (Using password: YES) in /home/content/******/****/******/html/includes/functions/database.php on line 19
Unable to connect to database server!

Share this post


Link to post
Share on other sites

I INSTALLED THE ups XML module it went ok no errors but after i setup the details in the backend and go through a test run when i go to checkout to go to the shipping options the page just says waiting for avengermxboard.net (this is my website) and thats it keepds waiting and waiting no screen appears

 

YES i add a little problem with the database fixed now

Edited by avengermx

Share this post


Link to post
Share on other sites
I INSTALLED THE ups XML module it went ok no errors but after i setup the details in the backend and go through a test run when i go to checkout to go to the shipping options the page just says waiting for avengermxboard.net (this is my website) and thats it keepds waiting and waiting no screen appears

 

YES i add a little problem with the database fixed now

 

sorry i also gets this error code sent to my email (see below)

 

Error from cURL: Error [7]: socket error: 110

Share this post


Link to post
Share on other sites

Thanks alot of all the work on this contrib. I have lowerd rates from UPS but before i manual edited the code to ($this->handling_fee + $cost* .42)); and the so that would devide the rate by a discount.

I tryed the new Negotiated rates But it came up with next day was cheaper then ground.

Share this post


Link to post
Share on other sites

Great contribution.

 

I searched in the board, seems no one has the same problem as mine.

Sorry if someone already solved the problem.

 

let me explain.

 

My shipping option;

UPS Ground $13.83

UPS 3 Day Select $27.67

UPS 2nd Day Air $35.01

UPS Next Day Air Saver $51.39

UPS Next Day Air Early A.M. $93.31

UPS Next Day Air

 

How to remove

UPS Next Day Air Early A.M

UPS Next Day Air Saver

 

I went to shipping module and within

Disallowed Shipping Methods

Select the UPS services not to be offered

I checked everything, except.

2nd Day Air

Ground

 

But still come up with

UPS Next Day Air Early A.M

UPS Next Day Air Saver

 

 

The readme on step 5, I tried both option.

 

 

Any idea why it didnt take the changes.

Share this post


Link to post
Share on other sites

Enable UPS Shipping

True

 

UPS Rates Access Key

*******************

 

UPS Rates Username

*******************

 

UPS Rates Password

*******************

 

Pickup Method

Daily Pickup

 

Packaging Type

Package

 

Customer Classification Code

03

 

Shipping Origin

US Origin

 

Origin City

Santa Clara

 

Origin State/Province

CA

 

Origin Country

US

 

Origin Zip/Postal Code

95051

 

Test or Production Mode

Test

 

Unit Weight

LBS

 

Unit Length

IN

 

Dimensions Support

No

 

Quote Type

Commercial

 

Negotiated rates

False

 

UPS Account Number

 

 

Handling Type

Percentage

 

Handling Fee

10

 

Enable Insurance

True

 

UPS Currency Code

USD

 

Tax Class

--none--

 

Shipping Zone

--none--

 

Sort order of display.

0

 

Disallowed Shipping Methods

Array

 

Shipping Delay

3

 

Email UPS errors

Yes

 

Time in Transit View Type

Raw

Share this post


Link to post
Share on other sites

Here is the code i used to use to manual use my rates.

 

if ( $type == 'UPS Ground') { 
							$methods[] = array('id' => $type, 'title' => $_type, 'cost' => 
($this->handling_fee + $cost* .962)); 
			} else {

 

Will this code still work? im not sure if the Negotiated rates will work or not. Do i need to sing up for a speshal ups service for Negotiated rates?

Share this post


Link to post
Share on other sites

Afternoon everyone,

 

I've installed UPSXML onto a shopping cart for a client.

 

Whenever I test the UPS shipping module I get the following error:

 

Rating and Service 1.0001 0 An unknown error occured while attempting to contact the UPS gateway : Rating and Service 1.0001 0 An unknown error occured while attempting to contact the UPS gateway

 

I have gotten from UPS the following pieces of information:

 

Developer's Key

XML Access Key

 

Already have a username/pw for the UPS account.

 

In the XML module I have the XML Access Key in the slot it is supposed to go into. Here are the current settings:

 

United Parcel Service (XML)

 

Enable UPS Shipping

False

 

UPS Rates Access Key

XML Access Key

 

UPS Rates Username

user name

 

UPS Rates Password

password

 

Pickup Method

Customer Counter

 

Packaging Type

Package

 

Customer Classification Code

03

 

Shipping Origin

US Origin

 

Origin City

Lafayette

 

Origin State/Province

IN

 

Origin Country

US

 

Origin Zip/Postal Code

47904

 

Test or Production Mode

Production

 

Unit Weight

LBS

 

Unit Length

IN

 

Dimensions Support

No

 

Quote Type

Residential

 

Negotiated rates

False

 

UPS Account Number

XXXXXX

 

Handling Type

Flat Fee

 

Handling Fee

0.00

 

Enable Insurance

True

 

UPS Currency Code

USD

 

Tax Class

Taxable Goods

 

Shipping Zone

--none--

 

Sort order of display.

0

 

Disallowed Shipping Methods

Array

 

Shipping Delay

1

 

Email UPS errors

Yes

 

Time in Transit View Type

Detailed

Any help would be appreciated.

Share this post


Link to post
Share on other sites
Afternoon everyone,

 

I've installed UPSXML onto a shopping cart for a client.

 

Whenever I test the UPS shipping module I get the following error:

 

Rating and Service 1.0001 0 An unknown error occured while attempting to contact the UPS gateway : Rating and Service 1.0001 0 An unknown error occured while attempting to contact the UPS gateway

 

I have gotten from UPS the following pieces of information:

 

Developer's Key

XML Access Key

 

Already have a username/pw for the UPS account.

 

In the XML module I have the XML Access Key in the slot it is supposed to go into. Here are the current settings:

 

Any help would be appreciated.

 

I would remove the Module and reinstall it in the admin control panel.

And make sure you are using the correct user name and password. I had to uses a different user name. im not sure why, i used the user name i use for Quantum View Manage online login

Share this post


Link to post
Share on other sites
Here is the code i used to use to manual use my rates.

 

if ( $type == 'UPS Ground') { 
							$methods[] = array('id' => $type, 'title' => $_type, 'cost' => 
($this->handling_fee + $cost* .962)); 
			} else {

 

Will this code still work? im not sure if the Negotiated rates will work or not. Do i need to sing up for a speshal ups service for Negotiated rates?

 

I ended up getting this code to work.

 

 if ( $type == 'UPS Saver') { 
							$methods[] = array('id' => $type, 'title' => $_type, 'cost' => 
($this->handling_fee + $cost* .43)); 
			} else { 
			 if ( $type == 'UPS Worldwide Express') { 
							$methods[] = array('id' => $type, 'title' => $_type, 'cost' => 
($this->handling_fee + $cost* .43)); 
			} else { 
							 if ( $type == 'UPS Worldwide Expedited') { 
							$methods[] = array('id' => $type, 'title' => $_type, 'cost' => 
($this->handling_fee + $cost* .43)); 
			} else { 
							 if ( $type == 'UPS Worldwide Express Plus') { 
							$methods[] = array('id' => $type, 'title' => $_type, 'cost' => 
($this->handling_fee + $cost)); 
			} else { 

							if ( $type == 'UPS Ground') { 
							$methods[] = array('id' => $type, 'title' => $_type, 'cost' => 
($this->handling_fee + $cost* .962)); 
			} else { 

							if ( $type == 'UPS 3 Day Select') { 
							$methods[] = array('id' => $type, 'title' => $_type, 'cost' => 
($this->handling_fee + $cost* .879)); 
			} else { 

							if ( $type == 'UPS 2nd Day Air') { 
							$methods[] = array('id' => $type, 'title' => $_type, 'cost' => 
($this->handling_fee + $cost* .62)); 
			} else { 

							if ( $type == 'UPS Next Day Air Saver') { 
							$methods[] = array('id' => $type, 'title' => $_type, 'cost' => 
($this->handling_fee + $cost* .756)); 
			} else { 

								if ( $type == 'UPS Next Day Air') { 
							$methods[] = array('id' => $type, 'title' => $_type, 'cost' => 
($this->handling_fee + $cost* .726)); 
			} else { 
					$methods[] = array('id' => $type, 'title' => $_type, 'cost' => ($this->handling_fee + $cost));
				}
			}}}}}}}}}}

Share this post


Link to post
Share on other sites

The mod is working great, but there is a side effect of having the extra fields: There is an error when I try to duplicate a product (which I do quite frequently). Has anyone else run into this (and fixed it?)? I'm trying to figure out the PHP to fix the error, but if it's already been done, it would be nice to update the mod with that information.

 

Thanks!

 

Annie o:)


It's not a learning curve, it's a cliff!

Share this post


Link to post
Share on other sites

Hi Annie,

 

When you say duplicate, are you talking about the copy function in admin/categories/products? IF you use the link instead of copy it's not a problem and then you also only have one product to make changes on such as stock. You could edit the file though to include products_height, products_width, and products_length.


John Wisdom

Share this post


Link to post
Share on other sites

Jan,

 

The packaging routine is defintely is more effecient and it doesn't put items that don't fit into a box now. However, I still have problem with the packaging routine not selecting an alternate box. I list a 48x8x6 box but it will not select it until I change it to 48x10x10, which I just realized makes it the largest box available and then it wants to use it all the time.

 

Here's my example:

 

2 items that are 30x3x3

3 times that 33x1.5x1.5

 

box choices 34x8x5, 31x15x10 and 48x8x6

 

It won't use the 48x8x6 but instead sends the othe two items as Ready to Ship items. Is this problem unique to me and possibly being caused by something else on my site?

 

Anyone else run into this?

Edited by John Wisdom

John Wisdom

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×