Jump to content
torinwalker

New UPS XML Shipping Module available

Recommended Posts

I have a USA store. Is it possible to use this module to only show up for 33 States (the other States will have a flat rate shipping fee and I don't want this UPS module to show up for them)?

I can see you can do this with 1 zone (State) but not more then that.

Share this post


Link to post
Share on other sites

Hi...

 

Getting this error...

 

Rating and Service 1.0001 0 An unknown error occured while attempting to contact the UPS gateway : Rating and Service 1.0001 0 An unknown error occured while attempting to contact the UPS gateway

 

So I logged the errors and came up with this...

 

Error from cURL: Error [60]: error setting certificate verify locations:

CAfile: /usr/local/share/curl/curl-ca-bundle.crt

CApath: none

experienced by customer with id 2 on 2006-06-26 19:01:57

 

and..

 

UPSXML TimeInTransit Error: : experienced by customer with id 2 on 2006-06-26 19:01:57

 

and..

 

UPSXML Rates Error:

 

Rating and Service

1.0001

 

0

An unknown error occured while attempting to contact the UPS gateway

:

 

Rating and Service

1.0001

 

0

An unknown error occured while attempting to contact the UPS gateway

experienced by customer with id 2 on 2006-06-26 19:01:57

 

 

So I found this in the upsxml.php module...

 

// add option -k to the statement: $command = "".$curl_path." -k -d \"". etcetera if you get

// curl error 60: error setting certificate verify locations

// using addslashes was the only way to avoid UPS returning the 1001 error: The XML document is not well formed

$command = "".$curl_path." -k -d \"".addslashes($xmlRequest)."\" ".$url."";

I did it and it still give me the same error messages!

 

HELP ME!!!!!!! :(

Share this post


Link to post
Share on other sites
So I found this in the upsxml.php module...

 

// add option -k to the statement: $command = "".$curl_path." -k -d \"". etcetera if you get

// curl error 60: error setting certificate verify locations

// using addslashes was the only way to avoid UPS returning the 1001 error: The XML document is not well formed

$command = "".$curl_path." -k -d \"".addslashes($xmlRequest)."\" ".$url."";

I did it and it still give me the same error messages!

Yes, because you are not using cURL through exec and therefore have to look 20 lines or so further:

		} else { // default behavior: cURL is assumed to be compiled in PHP
		$ch = curl_init();
		curl_setopt($ch, CURLOPT_URL, $url);
		// uncomment the next line if you get curl error 60: error setting certificate verify locations
		//curl_setopt($ch, CURLOPT_SSL_VERIFYPEER, 0);
		// uncommenting the next line is most likely not necessary in case of error 60
		// curl_setopt($ch, CURLOPT_SSL_VERIFYHOST, 0);

Share this post


Link to post
Share on other sites
Is it possible to use this module to only show up for 33 States (the other States will have a flat rate shipping fee and I don't want this UPS module to show up for them)?

I can see you can do this with 1 zone (State) but not more then that.

I've looked around a bit and in the contribution area I cannot really find anything that mentions that. I know SPPC can load shipping modules based on a group or customer setting, but I don't know if you can do the same trick based on the delivery zone. This is the relevant part from SPPC (in includes/classes/shipping.php):

   if ($customer_shipment = tep_db_fetch_array($customer_shipment_query)  ) { 
   if (tep_not_null($customer_shipment['shipment_allowed']) ) {
  $temp_shipment_array = explode(';', $customer_shipment['shipment_allowed']);
  $installed_modules = explode(';', MODULE_SHIPPING_INSTALLED);
  for ($n = 0; $n < sizeof($installed_modules); $n++) {
	  // check to see if a shipping module is not de-installed
	  if ( in_array($installed_modules[$n], $temp_shipment_array ) ) {
		  $shipment_array[] = $installed_modules[$n];
	  }
  } // end for loop
  $this->modules = $shipment_array;
  } else {  
   $this->modules = explode(';', MODULE_SHIPPING_INSTALLED);
  }
  } else { // default
   $this->modules = explode(';', MODULE_SHIPPING_INSTALLED);
  }
 // EOF Separate Pricing Per Customer

What is does is look at the shippping options that are open for this particular customer (based on a general group setting or as an individual) and if it is not in, the module is not included in the modules that are installed. Maybe you can do something with that. I suppose you did a thorough search of the forum already? I would imagine something like this would have been asked before.

Share this post


Link to post
Share on other sites
I have installed this module and everything has gone smoothly. I have run into one problem. I only accept paypal for right now. When the user checksout, all the totals are correct(subtotal, tax, and shipping). However when they are redirected to paypal to pay, the shipping charges only display $1 and not the actual shipping charges. Is there a option in the admin panel that I forgot?
I cannot imagine that this module has anything to do with, since it only gives the shipping quotes that are then used to proceed with the checkout. If you got quotes, it is up to osC to do its thing. I have no clue about paypal, but I have understood not all PayPal modules work well.
I tried to do a search, but this forum doesn't let you search a specific thread, so the results were useless.
It does, supposedly, but I found it sometimes only works when you are logged-in.

Share this post


Link to post
Share on other sites

I've just installed the ups xml mod and everything went fine in Admin - I have a UPS account and provided all of that info. Went to the catalog and ordered several products, went to checkout where there's a default message under Shipping Method that says

 

"This is currently the only shipping method available to use on this order.

United Parcel Service (XML) (1 pkg x 24 lbs total) "

 

my shipping information was correct (with me as customer), but when I click on "Continue" button at the bottom, the page just refreshes, doesn't advance to the next page (Payment Information).

 

I've set up the UPS XML rates on another site using the UPS documentation, so I'm fairly familiar with the system and code, but since I just installed this one in osC, it makes sense to ask if anyone else has run into this problem...maybe I missed something in the install?

 

any/all help appreciated.

thanks.

mc

Share this post


Link to post
Share on other sites

I'm selling several types of products and all have different weights - Can I give each product a specific "weight" (they're all different) somewhere so that the total weight is calculated for the UPS calculation?

 

thanks in advance.

mc

Share this post


Link to post
Share on other sites
I'm selling several types of products and all have different weights - Can I give each product a specific "weight" (they're all different) somewhere so that the total weight is calculated for the UPS calculation?

 

Yes, you can give each product a specific weight and you can set limits on how much weight can go into your boxes too.


John Wisdom

Share this post


Link to post
Share on other sites
I've looked around a bit and in the contribution area I cannot really find anything that mentions that. I know SPPC can load shipping modules based on a group or customer setting, but I don't know if you can do the same trick based on the delivery zone. This is the relevant part from SPPC (in includes/classes/shipping.php):

   if ($customer_shipment = tep_db_fetch_array($customer_shipment_query)  ) { 
   if (tep_not_null($customer_shipment['shipment_allowed']) ) {
  $temp_shipment_array = explode(';', $customer_shipment['shipment_allowed']);
  $installed_modules = explode(';', MODULE_SHIPPING_INSTALLED);
  for ($n = 0; $n < sizeof($installed_modules); $n++) {
	  // check to see if a shipping module is not de-installed
	  if ( in_array($installed_modules[$n], $temp_shipment_array ) ) {
		  $shipment_array[] = $installed_modules[$n];
	  }
  } // end for loop
  $this->modules = $shipment_array;
  } else {  
   $this->modules = explode(';', MODULE_SHIPPING_INSTALLED);
  }
  } else { // default
   $this->modules = explode(';', MODULE_SHIPPING_INSTALLED);
  }
 // EOF Separate Pricing Per Customer

What is does is look at the shippping options that are open for this particular customer (based on a general group setting or as an individual) and if it is not in, the module is not included in the modules that are installed. Maybe you can do something with that. I suppose you did a thorough search of the forum already? I would imagine something like this would have been asked before.

Thanks so much, JanZ. You're right I did do a search on the forum for this issue and I did find something that works prior to your help with the shipping.php file.

I found that you set up a Tax Zone folder and insert into that zone folder, all your zones and call your shipping module to apply to that zone folder. (I also found out that you need to give that Tax Zone Folder a State abbreviation name in order for this to work. Like I called one Tax Zone Folder AL for Alabama and inside that folder listed all the states I want to use this UPS module. In the UPS module I apply this AL folder to the Shipping Zone option. And only this shipping option shows up on the checkout_shipping page for these States.

 

My other states I did the same thing. Created a Tax Zone Folder and listed all the states in that folder I want to use Flat Rate Shipping and in the Flat Rate Shipping module I apply that folder to the Shipping Zone option and only this shipping option shows up on the checkout_shipping page for these States.

In case anyone needs to do the same, there it is!

Share this post


Link to post
Share on other sites
On another broader note, I have no idea if some of the comments here about people unwilling to read and learn are possibly directed at my questions posted above? I sense that they might be somewhat.

 

Ted,

I felt exactly the same way you did when I read the posts. I was less direct in my response, but you responded wonderfully! Good job!

*******************************

 

Hey All!

I spoke to my boss and its a go! I will be installing this module and also USPS Methods (for our international shipping). I have 19 modules already installed, so this could get really tricky if any of the code changes overlap. Wish me luck!

 

Corinne

Share this post


Link to post
Share on other sites

Corinne,

 

I use one of the pre modded versions of OSC now and it has around 30 or so contributions as well as UPS XML and there are no conflicts.

 

Another contribution that I found made updating product info much easier is "quick updates" which I modified to include weight, height, width, and length. I used the version for SPPC.

 

Good luck with this module Corinne, and I think you'll be very happy with it.


John Wisdom

Share this post


Link to post
Share on other sites
Yes, you can give each product a specific weight and you can set limits on how much weight can go into your boxes too.

 

thanks, John.

now...how do I set the weight for each product? haven't found it yet..

thanks.mc

Share this post


Link to post
Share on other sites

Calc weight vs real weight -

I'm looking for a way to change the default package weight - it seems to be adding 3lbs to every order...

if the product weighs 2lbs, UPS comes back with a combined package weight of 5lbs, etc.

 

anyone know how I can change this?

 

thanks in advance.

mc

Share this post


Link to post
Share on other sites
I'm looking for a way to change the default package weight - it seems to be adding 3lbs to every order...

if the product weighs 2lbs, UPS comes back with a combined package weight of 5lbs, etc.

 

anyone know how I can change this?

See the Knowledge Base to see how this works in osC.

Share this post


Link to post
Share on other sites
Corinne,

 

I use one of the pre modded versions of OSC now and it has around 30 or so contributions as well as UPS XML and there are no conflicts.

 

Another contribution that I found made updating product info much easier is "quick updates" which I modified to include weight, height, width, and length. I used the version for SPPC.

 

Good luck with this module Corinne, and I think you'll be very happy with it.

 

Thanks for the module suggestion, John!

I wrote it down on my module wish list for the future. On to coding.

 

Corinne

Share this post


Link to post
Share on other sites

Well, speaking as a very impatient "help vampire" let me apologize to anyone I may have offended by asking a few simple questions.

 

I know you have not seen my name very often in these forums. I mostly try to spend my time do my own research. But after 5 days (and nights) of searching for the answers I ran across post that asked a few of the same questions I had. The post was 4 days old and no one else had responded to it so I figured in responding I could help another person in need of the same information.

 

I did not realize it would cause such a great ruckous and let me apologize once again for that. Had I not been under a great deadline and completly unable to focus my eyes or brain any longer I would have tried to continue my search on my own for at least a few more days before posting.

 

Did I mention that I DID try to read the posts - Maybe not all of them but I started somewhere around the Jan 05.

 

Did I also mention that I DID read the manual before I posted... If you look back at the original questions the person mentions getting UPS order numbers..... Yes, the manual states that is gets prices and you are correct nothing more, nothing less. But if you had a bit of insight to share into next possible steps that would be appreciated.

 

The information for the log was very useful and thank you for that information. I was trying to over think a very simple process.

 

And just for the record I DID go back through the previous posts to correct the 4 different error messages I received after I installed the module.

 

I know the folks that post here are doing this out of the kindness of their hearts and are not paid to do this. I also know we are not talking about 2 or 3 questions a day either. I respect that very much!!! Not everyone can do that. I do not mean to make light of it in any way. You guys do a great deal to help everyone get through their problems but also help to give us more options for this software. PRICELESS!!

 

Maybe my posting that I needed the information yesterday ruffled some feathers. Again I apologize for that. That was actually a true statement and concidering the guy who posted the questions first looked like he had been waiting for 4 days - I was just hoping to get the information before I needed to catch a flight.

 

But you also have to concider that the person on the other end of the question may have just spend the last 5 days searching for their specific question instead of sleeping or spending time with their kids or something else that might have actually paid them. You really don't know.

 

I have seen the same general question asked at least 3 different ways and answered in at least 3 different ways. Not everyone asks the question the same or reads (understands) the answer the same. Sometimes the answers may be simple to a very common questions but not all of us have the "insider" knowledge - i.e - the removal of the UPS Module from basic cart. That information may have also been in a small post way back in Nov of 2005 that when I was scanning through for information somewhere my eyes may have glazed over for a second and I missed it because I was concentrating on a certain question at the time and that wasn't my answer. Yes, it might have been there and Yes, I might have missed it. Doesn't mean I didn't try!! Ever have one of those days??

 

There are a lot of answers out there to find and believe me I have found a lot of answers. I have also created a few new questions as well.

 

I do try to find my answers on my own but sometimes I have to ask for directions. I am a Chick - I can do that!!

 

Thank you for your (tried) patience and (forced) understanding!! Please believe it is greatly appreciated!!

 

TB Mak

Share this post


Link to post
Share on other sites

I am having a problem with dimensions support.

 

first of all im using the following:

oscommerce 2.2

ups_xml 1.2.3

added_weights with fix

dimensions support

 

heres what happening when i go to checkout it shows 1 box no matter how much it weighs or how many products you add to checkout. i need the boxes to be split up per product along with if there are addons selected

for instance its a printing website(business cards etc)

if a customer adds 5000 cards by default it shows 1 box at 16 pounds and the shipping price is correct but if a customer selects 10000 as quantity it says 1 box at 32 pounds. it should read 2 boxes at 16 pounds ..

 

 

next error i get is when i click tools in my admin panel i get a 500 error.

 

thanks for all the help

Luis

Share this post


Link to post
Share on other sites
heres what happening when i go to checkout it shows 1 box no matter how much it weighs or how many products you add to checkout. i need the boxes to be split up per product along with if there are addons selected

for instance its a printing website(business cards etc)

if a customer adds 5000 cards by default it shows 1 box at 16 pounds and the shipping price is correct but if a customer selects 10000 as quantity it says 1 box at 32 pounds. it should read 2 boxes at 16 pounds ..

next error i get is when i click tools in my admin panel i get a 500 error.

How can you use the dimensions support if you cannot add info about boxes (with maximum weight) in the new packaging.php page? That page is found under tools... I have no clue about what would cause an internal server error (error 500) with the dimensions support though. You could use phpMyAdmin to fill in that info though (table packaging).

Share this post


Link to post
Share on other sites
How can you use the dimensions support if you cannot add info about boxes (with maximum weight) in the new packaging.php page? That page is found under tools... I have no clue about what would cause an internal server error (error 500) with the dimensions support though. You could use phpMyAdmin to fill in that info though (table packaging).

 

because when i go to mysite.com/admin/packaging.php it works and allows me to post the dimensions its the database backup that makes the 500 error not sure why but i can get to the packaging

Share this post


Link to post
Share on other sites

Luis,

 

If you look at your error logs for your website it should show you what file is causing the 500 server error. I had this happen when one of my .htaccess pages was changed with a bad character in it.


John Wisdom

Share this post


Link to post
Share on other sites

Environment:

osCommerce 2.2-MS2

Apache/1.3.33 (Unix) PHP/4.3.9

libcurl/7.12.2 OpenSSL/0.9.7e zlib/1.1.4

 

My plan is to use UPS shipping. Reading http://oscommerce.info/kb/osCommerce/Admin...ing_Modules/230 does not help me to decide which modules should be installed to augment the UPS module :unsure:

 

After trolling around for a couple of hours, stumbled across this package. A quick look at the files showed no install.txt; but, the readme did point me to this forum. The good news is that the package seems to be popular and well supported as shown by the activity here. The bad news is that the amount of activity here makes me leery about installing.

 

Started to read through this forum assuming that it had the answers to my questions as a newbie; but, 48 pages makes it too daunting of an effort and although my boolean syntax is up to par, the inability to search only on this forum makes it an exercise in futility.

 

This is forcing me to ask my questions which may already be answered :'(

 

1- UPS XML has a readme.txt; but, no install.txt. Where can this be found ?

2- Someone mentioned that there was a manual. Is this a PDF ? Where can this be found ?

3- Will it work in my environment and if not, what has to be installed or upgraded ?

4- My client already uses UPS on another eCommerce site. Does this simplify the acquisition of the

Access key ?

5- What are the recommended add-ons for UPS ?

6- Is UPS Worldship a recommended add-on ?

7- Are UPS and UPS XML mutually exclusive or complementary ?

8- If they are mutually exclusive, what are the pros and cons of using one vs. the other ?

9- Where is the FAQ file for UPS XML ?

10- Can this forum be pruned ?

11- Is there a way to only search this forum ?

Share this post


Link to post
Share on other sites

I am new to this community, to php, and to oscommerce please dont flame me, ive been searching this forum for 8 hours to find answers.

 

I have recently instlled oscommerce which did not come with a UPS shipping module, I did install the most recent UPS XMl file that seemed sufficent. I did all the recommended instructions, and it seems as though the install went ok. I have 2 issues.

 

1st if I try to place and order though my site, as you proceed to checkout the first item is shipping information. It shows this error to the customer on this page in the shipping info.

 

Rating and Service 1.0001 0 An unknown error occured while attempting to contact the UPS gateway : Rating and Service 1.0001 0 An unknown error occured while attempting to contact the UPS gateway

 

i also receive an email notification with this error,

 

Error from cURL: Error [60]: error setting certificate verify

locations:

CAfile: /usr/share/ssl/certs/ca-bundle.crt

CApath: none

experienced by customer with id 2

 

I dont know if this an error on my part during install, or if i have entered my account information incorrectly in the admin/modules, or since i recently about 3 hours ago set up my UPS account, if it isnt estableshed yet so the modules is not connecting to ups.

 

My second question is, I don't actually ship anything I do all drop shipments through my supplier, I only installed the mod so the cust pays the shipping cost, I am wondering since the module is linked to my UPS shipping account, once the item is purchased is any billing information or shipping information directed to UPS that my cause charges to occur on my account.

 

Please please help

You can email me if necessary

i need a friend in oscommerce. gpmail@signature-series.net

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×