Jump to content
torinwalker

New UPS XML Shipping Module available

Recommended Posts

Hi, just tried running your mod on a MS2 shop, seems to run fine except I get a couple of warnings on the admin page. in packaging I see:

 

 

Warning: Failed opening 'includes/classes/htaccess.php' for inclusion (include_path='.:/php/includes:/usr/share/php') in /var/www/html/oscommerce/catalog/admin/packaging.php on line 59

 

at the top of the page,

 

and then when creating a new package, I see:

 

Warning: Missing argument 1 for shownewpackageform() in /var/www/html/oscommerce/catalog/admin/packaging.php on line 201

 

also at the top of the box. I know there is no htaccess.php anymore, but as far as I can tell the mod works fine. Will these warnings cause any serious problems? Thanks

Share this post


Link to post
Share on other sites

Stephan,

 

Geez... Yes, Stephan, it's a mistake. The last two lines should have the same numbers, 64, 65. The same goes for the upsxml.php in the english directory.

 

Hey Torin,

 

found this in upsxml.php module /catalog/includes/modules/shipping/

 

<code snippet removed>

 

Are the last two lines correct?

Share this post


Link to post
Share on other sites

Fatal error: Call to undefined function: curl_init() in /home/xan2/public_html/includes/modules/shipping/upsxml.php on line 590

 

I checked with my host and curl is installed

---------------------------------------------------------------

root@secure6 [~]# rpm -q curl

curl-7.9.8-1

root@secure6 [~]#

---------------------------------------------------------------

 

Any ideas why this would happen?

Share this post


Link to post
Share on other sites

kyliedog,

 

I got the same problem, but don't know if my host has it installed or not. Did you check that directly with your host?

 

If you find a solution please post it here, hopefully the author can jump-in with a soultion.

 

:roll:

Share this post


Link to post
Share on other sites

Guys and/or Gals,

 

We've had the same question posed here before. An unreferenced curl_init method on your end is not something I can solve from my end. Although rpm -q returns an installed curl option, is it possible the server itself was not started with the --with-curl flag? Perhaps instead, the server was started before the rpm package was added?

 

kyliedog,

 

I got the same problem, but don't know if my host has it installed or not. Did you check that directly with your host?

 

If you find a solution please post it here, hopefully the author can jump-in with a soultion.

 

:roll:

 

 

Torin...

Share this post


Link to post
Share on other sites

Torin,

 

still getting the same error - have you had any insights as to the cause?

 

Rating and Service 1.0001 0 MODULE_SHIPPING_UPSXML_RATES_TEXT_COMM_UNKNOWN_ERROR : Rating and Service 1.0001 0 MODULE_SHIPPING_UPSXML_RATES_TEXT_COMM_UNKNOWN_ERROR


Reading is beneficial - Searching is enlightening

find answers at wiki.oscommerce.com/top

Share this post


Link to post
Share on other sites

You're going to have to debug your net connection.

 

- Do you know for certain whether your ISP permits client connections?

- Is your account key/login/password correct?

- Is the correct (latest) version of curl installed?

- Is the server timing out while returning the response?

- Is traffic back to your ISP really slow?

- Is the outgoing XML message complete and valid? (Turn debugging on - see readme.txt that came with UPSXML)

 

You're receiving that response because the UPS gateway returned null. The trouble is, there are many, many reasons why your module could fail to receive a response.

 

Torin,

 

still getting the same error - have you had any insights as to the cause?

 

Rating and Service 1.0001 0 MODULE_SHIPPING_UPSXML_RATES_TEXT_COMM_UNKNOWN_ERROR : Rating and Service 1.0001 0 MODULE_SHIPPING_UPSXML_RATES_TEXT_COMM_UNKNOWN_ERROR

 

 

Torin...

Share this post


Link to post
Share on other sites

ok.. the error that everyone seems to be experiencing...

 

Rating and Service 1.0001 0 MODULE_SHIPPING_UPSXML_RATES_TEXT_COMM_UNKNOWN_ERROR : Rating and Service 1.0001 0 MODULE_SHIPPING_UPSXML_RATES_TEXT_COMM_UNKNOWN_ERROR

 

 

On my FreeBSD 4.7 system, I had to install Curl from ports and re-configure PHP. Restarted apache and error is gone.

 

But.. I get an error "invalid customer classification code" In the admin area there is a blank text box and I'm wondering if that is for the customer classification code (there is no description.. just a blank text box above Handling Fee. I tried putting in 03 and I still get the classifcation code error.. but at least I can connect now.

Share this post


Link to post
Share on other sites

I posted my message a little too soon...

 

for the invalid customer classification.. it didn't matter what type of pickup option I chose, UPS returned an invalid code. In the admin/includes/modules/shipping/upsxml.php, I had to hard code the classification code to 03 and everything is peachy keen now.

 

I doubt my troubleshooting will help anyone, but if anyone needs help and they are running freebsd with Plesk, just let me know.

 

Gisele

Share this post


Link to post
Share on other sites
Fatal error: Call to undefined function: curl_init() in /home/xan2/public_html/includes/modules/shipping/upsxml.php on line 590

 

I checked with my host and curl is installed

---------------------------------------------------------------

root@secure6 [~]# rpm -q curl

curl-7.9.8-1

root@secure6 [~]#

---------------------------------------------------------------

 

Any ideas why this would happen?

 

i had to recompile PHP on my server to make it work (--with-curl).. Installing cURL is not enough..

 

Regards,

Stephan Gebbers


 

 

Share this post


Link to post
Share on other sites

Hey Torin,

 

Do you have some thoughts about this problem (i think it was described earlier already..)?

 

When i checkout the rates appear as they should, but i can't select and continue with checkout when i choose a rate different from "ups ground" ("ups standard").

instead of getting to the payment page, i get the checkout shipping page again (the rates values are different now, compared to the first display of checkout shipping).

 

in case you need a live example from my test shop (no orders will be processed yet):

www.mbeat.de/catalog/ (user:jondoe@mbeat.de / password: password)

 

Later,

Stephan Gebbers


 

 

Share this post


Link to post
Share on other sites

Hi,

I'm hoping this thread is addressing something similar to my problem. If not, I apologize, but hopefully you can refer me to the correct source.

 

I installed the latest UPS XML. In Admin, I get these errors:

 

Warning: Call-time pass-by-reference has been deprecated - argument passed by value; If you would like to pass it by reference, modify the declaration of xml_set_object(). If you would like to enable call-time pass-by-reference, you can set allow_call_time_pass_reference to true in your INI file. However, future versions may not support this any longer. in /home/sites/site9/web/catalog/includes/classes/xmldocument.php on line 282

 

Fatal error: Call to undefined function: curl_init() in /home/sites/site9/web/catalog/includes/modules/shipping/upsxml.php on line 590

 

Not being a programmer, I'm frustrated. Can someone tell me what I can do?

 

Thanks!

Share this post


Link to post
Share on other sites

Stephan,

 

I see what you're talking about now. It is acting very peculiar. I went over all the displayed shipping options, and it also appears to work on both Worldwide Express options.

 

I believe the problem may be with encircled R (registered symbol). Can you please try removing the special character from the service description and try it again?

 

 

Torin...

 

Hey Torin,

When i checkout the rates appear as they should, but i can't select and continue with checkout when i choose a rate different from "ups ground" ("ups standard").

instead of getting to the payment page, i get the checkout shipping page again (the rates values are different now, compared to the first display of checkout shipping).

 

Later,

Stephan Gebbers

Share this post


Link to post
Share on other sites
I believe the problem may be with encircled R (registered symbol). Can you please try removing the special character from the service description and try it again?

 

I believe that has solved the problem for me!

Millie

Share this post


Link to post
Share on other sites
Stephan,

I believe the problem may be with encircled R (registered symbol). Can you please try removing the special character from the service description and try it again?

Torin...

 

Working now :)

 

I still had Problems using Ship in Cart Contrib, but i simply removed the 'select' buttons and total+ shipping costs display.

If some1 knows of a better solution for Ship-in-cart contrib, i'm here :)

 

Thx alot for your Help Torin.

 

Later,

Stephan


 

 

Share this post


Link to post
Share on other sites

Gisele,

 

That's interesting. I wonder if it has anything to do with PHP trying to treat the value as an integer. 03 would of course be reduced to '3'. Do you have your old upsxml.log file (from before/during the error occurance)? I would like to see exactly what value, if any, was being sent to UPS.

 

 

Torin...

 

for the invalid customer classification.. it didn't matter what type of pickup option I chose, UPS returned an invalid code..<snip>..I had to hard code the classification code to 03 and everything is peachy keen now.

...

Gisele

Share this post


Link to post
Share on other sites

Thanks for the advice :)

I removed the registered symbol as stated earlier in the post. That seemed to clear up some of the the issues I've bee having. I hope that little buggy is cleared up too.

 

For my knowledge, what happens if UPS's server doesn't respond?

Thanks,

Brad


~~~~~~~~~~~~~~~

Brad Bierman

Share this post


Link to post
Share on other sites

Hi guys!

I appologie from being gone from this thread for a while. I got a new computer and it has taken me a lot of work to transfer/clean and backup stuff...But now I'm rocking again! Yipee! :D :D :D It's so nice to work on a fast computer. Yeah!

 

But back to the UPS stuff. Yes, I concur with the previously mentioned bug regarding the registered marks. I removed them as Torin pointed out and it now is possible to check-out! Great, Thanks very much!

 

I'm thinking about doing the following with utilizing the great quotation of this UPS shipping module. Since using this UPS module only quotes rates (and not charges, even though you put: Customer Classification Code as: 01-Billing to a customer UPS account.)

 

What if I changed the name and had something more generic. Shipping options in languages English...I would change to say something like. Ground, Second Day, and Next Day. Nowhere in the Shipping options at the checkout_shipping.php page would the customer see a specific UPS logo. Therefore it would give the liberty for the store owner to ship also with other shipping companies. (whichever is the most suitable at that time). The UPS real time quotes would very closely quote a cost most likely similar to say Fedex, and USPS. Of course with minor adjustments...

 

What do you think about this? I would like the store not to limit themselves to just one shipping company. yet I'm not sure on installing any other modules. It's can be a hassle and none of them seem to be as advanced as Torin's UPS XML module. :wink:

 

Torin, Have you by the way had a chance to look at the dimesnions algorithm? I would for sure like to be able to use it. Maybe now with my new computer I can get into this and see if I can figure out the mathematics.

 

Thanks!

Share this post


Link to post
Share on other sites

by the way,

Since this is the only shipping option I am currently using I went ahead and changed what I previously talked about in this thread. I hated how all the lines were turned yellow by default if I only had one shipping module in use.

 

this is what I changed in checkout_shipping.php

 

When I changed this: 



(tep_count_shipping_modules() == (int)1) 



to this 



(tep_count_shipping_modules() == (int)0)

 

I don't know about the implications but it seems to work...Dunno why? but it does.

 

I wish everyone a happy weekend!

 

Thomas

Share this post


Link to post
Share on other sites
What if I changed the name and had something more generic. Shipping options in languages English...I would change to say something like. Ground, Second Day, and Next Day. Nowhere in the Shipping options at the checkout_shipping.php page would the customer see a specific UPS logo. Therefore it would give the liberty for the store owner to ship also with other shipping companies. (whichever is the most suitable at that time). The UPS real time quotes would very closely quote a cost most likely similar to say Fedex, and USPS. Of course with minor adjustments...

Be very careful if you choose to explore this. I suspect that it would violate the terms of service required by UPS to utilize their interface.

 

The issue with having to remove the ® symbols to enable checkout may also violate the TOS (although I personally would do this to achieve a working solution until such time the bug is squashed).

:bomb:


... if you want to REALLY see something that doesn't set up right out of the box without some tweaking,

try being a Foster Parent!

Share this post


Link to post
Share on other sites

Hi,

My question is...

Has anybody tested this module on 2.2 CVS versions of osCommerce?

 

I have a October 2002 snapshot and am a little hesitant to use this module.

 

Any help is greatly appreciated.

 

Thanks


Dan

Share this post


Link to post
Share on other sites
Has anybody tested this module on 2.2 CVS versions of osCommerce

 

First: my gushing, warm, heartfelt, you are my hero thanks to Torin for this contribution! :D

 

I have finally gotten around to installing this on our site which is running a heavily modified 2.2 snapshot from 12-17-02

 

The feeling of joy was real warm and fuzzy when I tested an oversized package in the catalog versus a direct entry into the UPS website's shipping calculator and came up with identical entries to the penny for every shipping method!

 

Some observations, questions and comments:

 

1) It seems that to get the oversize calculations, you must enable the dimensional support, but once you do this, then you must have packaging sizes dictated? With only a very limited number of items that require dimensional support because of their oversize characteristics, it seems rather daunting to contemplate having to do something specific for every item in the catalog - does anyone have a solution for this? (for instance, could I just create 1 package that fell just shy of going oversized to accomodate everything else?)

 

2) The packaging "delete" function in Admin does not seem to work. It would also be nice to have a sort order function for this if someone is creating a lot of packages - seems now to just order by sequence of creation.

 

3) This mod with the packaging weights seems to dispense with the osC '% increase' packaging function. This isn't necessarily bad, as I'm sure it will work just fine once one is accustomed to it, but would it be possible to create a switch to choose which method was to be used?

 

4) I'm not up to this, but some thoughts for future enhancements:

  • a) Add in the Address Validation and Time In Transit XML functions available from UPS

B) Create the same sort of mod for USPS (Generally, USPS for International shipments up to a certain size and weight are less expensive than UPS by a substantial amount

c) Tie in the multi-vendor shipping mod so that you can choose shipping method by item and be able to select UPS and USPS as one of the options


... if you want to REALLY see something that doesn't set up right out of the box without some tweaking,

try being a Foster Parent!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×