Jump to content
Sign in to follow this  
Denkster

WAMP - Curl is not working

Recommended Posts

Dear friends,

Tonight I did a fresh install of 1.0.1.1 an d then 1.0.1.2 on my WAMP64 local server with PHP 7.3.7 and started checking for errors.

When selecting in admin the tools -> security checks, I got these errors:

( ! ) Fatal error: Uncaught Error: Call to undefined function curl_init() in C:\wamp64\www\htdoc3\winkel\admin\includes\modules\security_check\extended\admin_backup_directory_listing.php on line 46
( ! ) Error: Call to undefined function curl_init() in C:\wamp64\www\htdoc3\winkel\admin\includes\modules\security_check\extended\admin_backup_directory_listing.php on line 46
Call Stack
# Time Memory Function Location
1 0.0000 410504 {main}( ) ...\security_checks.php:0
2 0.0200 783064 securityCheckExtended_admin_backup_directory_listing->pass( ) ...\security_checks.php:87
3 0.0200 783144 securityCheckExtended_admin_backup_directory_listing->getHttpRequest( ) ...\admin_backup_directory_listing.php:26

Is this due to something I missed, or did wrong, or is it the Windows environment, or ..?

Best regards

Eveline

Share this post


Link to post
Share on other sites
12 hours ago, ArtcoInc said:

@Denkster

Can you do a Admin -> Tools -> Server Info ? 

Of course. Does this help, or do you need more?

Server Information

Server Host:192.xxx.xxx.xxx (192.xxx.xxx.xxx)     Database Host:192.xxx.xxx.xxx (192.xxx.xxx.xxx)

Server OS:WINNT     Database:MySQL 5.7.14

Server Date:2019-08-03 17:40:59 +0000 UTC     Database Date:2019-08-03 19:40:59

Server Up Time:

HTTP Server:Apache/2.4.23 (Win64) PHP/7.3.7

PHP Version:7.3.7 (Zend: 3.3.7)

Best regards

Eveline

Share this post


Link to post
Share on other sites

Hi Artcolnc, thanks for your answer!

3 hours ago, ArtcoInc said:

Scroll down about 1/4 of the way. What does it say about cURL ? 

it says:

cURL	Sterling Hughes 

Is that not correct?

 

Share this post


Link to post
Share on other sites
8 minutes ago, ArtcoInc said:

Just checking to see if cURL is enabled in your WAMP setup ... 

Aha! I see. Thank you!!

No that section is missing in my setup... 😕

No idea how to get it in.. 😯

Share this post


Link to post
Share on other sites
Posted (edited)

Actually, the WAMP tray menu tells me that the cURL extension for php is installed!

But it is not reported active in the server settings overview. How is that possible..?

Edited by Denkster
Typo

Share this post


Link to post
Share on other sites
Posted (edited)

To enable Curl in WAMP (From phpmind.com)

1) Close WAMP (if running)
2) Navigate to WAMP\bin\php\(your version of php)\
3) edit php.ini
4) Search for curl, uncomment extension=php_curl.dll
5) Navigate to WAMP\bin\Apache\(your version of apache)\bin\
6) edit php.ini
7) Search for curl, uncomment extension=php_curl.dll
8 ) Save both
9) Restart WAMP

Edited by mhsuffolk

OsC 2.3.4.1 CE Frozen   PHP 7.2   MySQL 10.1.36-MariaDB-cll-lve. Phoenix in development

Is your version of osC up to date? You'll find the latest osC community version (CE Phoenix 1.0.4.0) here.

Share this post


Link to post
Share on other sites
On 8/4/2019 at 9:08 AM, mhsuffolk said:

To enable Curl in WAMP (From phpmind.com)

1) Close WAMP (if running)
2) Navigate to WAMP\bin\php\(your version of php)\
3) edit php.ini
4) Search for curl, uncomment extension=php_curl.dll
5) Navigate to WAMP\bin\Apache\(your version of apache)\bin\
6) edit php.ini
7) Search for curl, uncomment extension=php_curl.dll
8 ) Save both
9) Restart WAMP

I tried that several Times.

All php.ini all apache.ini files that I could find have the 

extension=php_curl.dll

It did not resolve the problems.

I even tried extension=curl, (new convention in WAMP). Did not work either. I am stuck.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×