Jump to content

Recommended Posts

Update to an old add-on, all credit to original author: Gergely V1.0 18/07/2015

A simple add-on that allows you to display what's in the cart as the customer adds it. It is a Modal with cart. Customer can either checkout, continue without leaving his page or he can edit cart.

This is a bootstrap Modal with no Ajax used.

It’s a simple no core change add-on so just copy files over go to admin and install and setup. Script is loaded using site wide hooks so will not work with any version that’s not using these.

Adjustments background opacity and color can be made in admin.

That’s it enjoy.

Has been tested on Phoenix V1.0.0.3 only.

Can be seen working on my custom test site

Can be see working in this video

NOTE: This is NOT the official test site

With Opacity set to 0

image.thumb.png.23537285663658d8d55f7a0fb51831fe.png

 

With Opacity set to 0.75 and color pink

image.thumb.png.366731ba08076d3e5fa7b570a3e96722.png


 

Share this post


Link to post
Share on other sites
Posted (edited)

Hi,

Thanks for this add-on, but it is not working for me.  Could you elaborate on the steps " copy files over go to admin and install and setup. ".

Edited by MsWealth
error

Share this post


Link to post
Share on other sites
17 hours ago, MsWealth said:

Could you elaborate on the steps " copy files over go to admin and install and setup. ".

It’s a simple no core change add-on so just copy files over go to admin and install and setup. Script is loaded using site wide hooks so will not work with any version that’s not using these.


 

Share this post


Link to post
Share on other sites
2 hours ago, JcMagpie said:

It’s a simple no core change add-on so just copy files over go to admin and install and setup. Script is loaded using site wide hooks so will not work with any version that’s not using these.

Hi,

I managed to get it working.  I just needed to take a break. 

Solution: Download- upload files to correct place, go to admin, search and install module, edit settings, make sure Display Cart After Adding Product = false

Share this post


Link to post
Share on other sites
6 hours ago, freakystreak said:

would this work on Frozen or is it able to be adapted?

Yes I dont see why not, if it's frozen with BS4 then soud just work, if it's Frozen BS3 then will need some small tweeks.


 

Share this post


Link to post
Share on other sites
46 minutes ago, stefan1959 said:

I just had a look at the demo site, it seem to be loading slow, mainly the images.

Don't have a demo site, the test sites can at times be slow depending on if I'm testing a new add-on or as in many cases brake the site during testing a new add-on. Looks ok at the moment.


 

Share this post


Link to post
Share on other sites
48 minutes ago, JcMagpie said:

Don't have a demo site, the test sites can at times be slow depending on if I'm testing a new add-on or as in many cases brake the site during testing a new add-on. Looks ok at the moment.

 

I meant. Just images where slow to load. Loads fine once they cached.

Edited by ArtcoInc
delete link

Share this post


Link to post
Share on other sites
7 hours ago, freakystreak said:

or is it able to be adapted?

did a quick check and it work on Frozen BS3 you can see it on this site

It's will need  few tweeks. The main one is to replace the site wide hook by adding the scripts in it into the template file. Then it's just css fixes to get display as you need it.

image.thumb.png.9680091963bf24e775f1e3ed972305fe.png

Edited by JcMagpie

 

Share this post


Link to post
Share on other sites
21 minutes ago, JcMagpie said:

Would remove the link as it's not liked on the forum.

I can't edit, its gone past the edit time, maybe a admin can remove.

Share this post


Link to post
Share on other sites
10 hours ago, JcMagpie said:

did a quick check and it work on Frozen BS3 you can see it on this site

It's will need  few tweeks. The main one is to replace the site wide hook by adding the scripts in it into the template file. Then it's just css fixes to get display as you need it.

image.thumb.png.9680091963bf24e775f1e3ed972305fe.png

@JcMagpie, brilliant!! I will definately add this. Thanks for taking the time to check things


Ah, the world wide web. What a wonderful place.

Share this post


Link to post
Share on other sites

Anyone else wanting to use this on Frozen, just download and install as normal but just don't use the site wide hook and use this template file insted of the one in the download for

includes/modules/content/footer/templates/

tpl_cm_footer_modal_cart.php


 

Share this post


Link to post
Share on other sites

Hmmm... @JcMagpie done as you instructed but I don't get any model cart pop-up. I just get the default cart as normal. I have even tried it on a default install of Frozen in case there was a conflict.. Maybe it's me. Will try re-installing it. Just to clarify copy the files minus the 'Hooks' section then use the supplied template file? 


Ah, the world wide web. What a wonderful place.

Share this post


Link to post
Share on other sites
4 minutes ago, freakystreak said:

I don't get any model cart pop-up. I just get the default cart as normal

You have to set the default cart to false first.

image.png.f9dea9dd6d16875fa3c9017d2a32b79c.png

Edited by JcMagpie

 

Share this post


Link to post
Share on other sites

Nope, must be something conflicting. It's working on my default frozen site but not on my main site. This site is quite heavily modded too so I guess I will be busy searching through it. Great add-on.Thanks for your help.


Ah, the world wide web. What a wonderful place.

Share this post


Link to post
Share on other sites

@JcMagpie - I installed this today - looks great!  Just one issue....

Is there any way to stop the item-has-been-added-to-your-cart message from appearing? 

It's normally something I would only see on shopping_cart.php.  Using the modal results in this message popping anywhere there's a Buy Now or Add To Cart button.

The below is after using Buy Now browsing a category.

message.JPG.2c38891852b0dee5bb08c04fb63fd8f3.JPG

Any way to get rid of it?

- Andrea

Share this post


Link to post
Share on other sites

That's part of osC not my add-on, not sure if you can turn that off as it's hardcoded into the code. Others may know of a better way but it can be done by just adding a bit of css to the product-info.php file. This way other alerts in the site will still show.

<style>
.alert {
    display:none;
}
</style>

 


 

Share this post


Link to post
Share on other sites

@JcMagpie - Thanks!  That works when adding to the cart while viewing the actual product.

Additionally, I had to put that code snippet in index.php and product_listing.php...and that kills the message there, as well.  Not sure if there's more places to check, still looking around.

Now I'm trying to figure out why the colors are changing on my Buy Now buttons after adding to the cart from a category.  You have this in the template file:

#btn3 {
    Background-color:blue!important;
    color:#fff;
} 

#btn3:hover {
    Background-color:lightblue!important;
    color:red;
} 

#btn4 {
    Background-color:green!important;
    color:#fff;
}
#btn4:hover {
    Background-color:lightgreen!important;
    color:red;
}

It's supposed to be applying those colors to the buttons in the Modal, but instead...it's applying them to my Buy Now buttons after adding something to the cart when viewing a category.  The modal buttons are white.  They only get those assigned colors when adding to the cart directly from the product_info page itself.

- Andrea

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×