Jump to content

Recommended Posts

Posted (edited)

CE Phoenix

Phoenix is the Master Community Version of osCommerce

ce-phoenix.png.3fa6579340470f2532f0ccacf7456108.png

https://github.com/gburton/Responsive-osCommerce/releases

https://www.oscommerce.com/Products

Demo Site

https://template.me.uk/phoenix/index.php

External Libraries

https://github.com/gburton/Responsive-osCommerce/wiki/External-Libraries

PHP Version

Minimum Maximum
7.0 7.1.x

Image Credits

Images in the default installation are copyright their respective owners;

Image Owner
osCommerce Logo osCommerce
Phoenix Logo G Burton
Oranges Eelffica from Pixabay
Lemons Eelffica from Pixabay
Pears Eelffica from Pixabay
Apples Eelffica from Pixabay
Tomatoes Rocky_H from Pixabay
Heart Gerhard Gellinger from Pixabay

Thank You

To all shopowners, developers, consultants and business owners who have supported the project over the years.

Beer Tokens

"Beer Tokens" are not used to purchase beer - they are used to give time into the Project. I am hopeful that enough shopowners, developers, consultants and businesses ... will join the Phoenix Club to allow two professional developers to work on the code on an ad-hoc basis.

Join the Phoenix Club

If you wish to sponsor ongoing and future development, please consider joining the club https://forums.oscommerce.com/clubs/1-phoenix/

Edited by burt
added link to https://www.oscommerce.com/Products

This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites
2 minutes ago, puddlec said:

how do you send a "Beer Token"? 

Vast majority of club members are those who supported Feb 2019 28d project. 
I'll come up with some other way to get club access for anyone who didn't feel able to support 28d.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites
Posted (edited)

I introduced a dumb copy/paste error, d'oh.

Please update to 1.0.0.1 by performing;

  1. https://github.com/gburton/Responsive-osCommerce/commit/05b4d809ff2e87a9f46d76cd8699740c3d2c5389
  2. https://github.com/gburton/Responsive-osCommerce/commit/13756ebb536d80f348bf1a7adcdbe4fb3c19377b

Or in plain english:

  1. replace /admin/modules_content.php
  2. replace /includes/version.php

I am going to try to keep on top of versioning going forwards so everyone knows exactly where they are.

1.0.0.1.zip

 

Edited by burt
added zip

This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

will the version checker work with any future updates, as at the moment

Version Checker pixel_trans.gif
Installed Version: osCommerce Online Merchant v1.0.0.0 CE Phoenix
pixel_trans.gif

You are running the latest version of osCommerce Online Merchant.

 

 

Share this post


Link to post
Share on other sites
Just now, puddlec said:

will the version checker work with any future updates, as at the moment

Version Checker pixel_trans.gif
Installed Version: osCommerce Online Merchant v1.0.0.0 CE Phoenix

Yes.  And I am going to try to keep on top of versioning.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

Your post reminded me that I had completely forgot to implement the CE version checker 😕 
I'll push that to 1.0.0.2 tomorrow.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

Please update to 1.0.0.2 by performing these changes;

https://github.com/gburton/Responsive-osCommerce/pull/741/commits/38a40dc116f7f514caca1c2e70cc22e3d8fb6c34

Alternatively just download the zip file attached and overwrite the files...

1.0.0.2.zip

This update reconfigures the version checker so that when I make a release you can see available downloads in admin > tools > version checker
The following image is a MOCKUP, but shows how it works each time I make a full release.  Hotfixes are not releases.

Noname.jpg.b91971e45b05ea0273e7fbd6600d7e53.jpg


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

Will it work on php5.4? At the moment there are problems with the transition to the new version.

Share this post


Link to post
Share on other sites
Just now, Yurius said:

Will it work on php5.4? At the moment there are problems with the transition to the new version.

Taken from the first post in this thread :) 

PHP Version

Minimum Maximum
7.0 7.1.x

I suggest finding a host that is able to give you 7 for your new site(s) and 5 for your old sites.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites
2 minutes ago, burt said:

Taken from the first post in this thread :) 

Thanks, I noticed. :) Also, thanks for the suggestion, but as I said above - at the moment there are problems.

Share this post


Link to post
Share on other sites

Hello, this is your competitor. 
Bootstrap 4. Good job, good to know someone else still working on oscommerce :)

Share this post


Link to post
Share on other sites

@burtI have it installed and running under php 7.2 without any errors. Is there a reason why the maximum php version is 7.1?

Share this post


Link to post
Share on other sites
4 minutes ago, Jack_mcs said:

@burtI have it installed and running under php 7.2 without any errors. Is there a reason why the maximum php version is 7.1?

There isn't other than I forget to change the max version 😕 

I've also had a few reports of success on php7.3 

BUt there is quite a lot of outdated code, that could do with an update, I did start but got sidetracked, eg 
https://github.com/gburton/Responsive-osCommerce/blob/master/includes/modules/product_listing.php#L110-L113


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites
Posted (edited)

I can confirm PHP7.3 works well. I'm doing my spanish language update under PHP7.3 with error reporting set to ALL and going through all pages and actions. All modules installed. No errors appeared.

Can't confirm for all payment modules and header tags, because they are not all configured

Edited by raiwa

Share this post


Link to post
Share on other sites

Gary, just wondering: will all 28d19 work on Phoenix? Or haven't you tested this yet?

Cheers, Rene


  • Gold is EOL
  • Frozen is Sunset
  • Edge is defunct and no longer exists
  • Phoenix is the default recommended download

Share this post


Link to post
Share on other sites
1 minute ago, Heatherbell said:

@René H4 Now loading up a new Phoenix with 28d2019 and no problems yet, only a few modifications needed with 28d2018 but easy fixed.

Good News! I will wait a few weeks until the vast amount of bugs have been detected, and then build a test environment myself....

I could not figure out if Phoenis is running BS3 or BS4? I guess BS4?

 


  • Gold is EOL
  • Frozen is Sunset
  • Edge is defunct and no longer exists
  • Phoenix is the default recommended download

Share this post


Link to post
Share on other sites
1 minute ago, Heatherbell said:

@René H4 Phoenix is on BS4

OK thanks!


  • Gold is EOL
  • Frozen is Sunset
  • Edge is defunct and no longer exists
  • Phoenix is the default recommended download

Share this post


Link to post
Share on other sites

As @heatherbell mentions, the 28d2019 should work pretty smoothly. 

Older years may need looking at on a case by case basis as they were made before Frozen let alone Phoenix.  


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

If on v1.0.0.0 please update to 1.0.0.2 by downloading the following two zips and overwriting relevant files.

Pretty simple.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites
23 hours ago, Jack_mcs said:

@burtI have it installed and running under php 7.2 without any errors. Is there a reason why the maximum php version is 7.1?

Note that some hosts are refusing to offer anything earlier than PHP 7.2, so listing it as 7.1 could scare off some potential users. That said, it should not be listed as 7.2 or 7.3 compatible until someone has gone over it with some sort of checker (or checking process) to methodically confirm that there is nothing obsolete or deprecated still in the code. The base code should not require suppression of deprecated warnings, although various add-ons still might. Logging warnings to a file only the admin can see, and not the customers, is a good idea.

Share this post


Link to post
Share on other sites
1 hour ago, burt said:

If on v1.0.0.0 please update to 1.0.0.2 by downloading the following two zips and overwriting relevant files.

Pretty simple.

Probably far outside this CE version, however I'll ask the question... has there been any thought to connect the 2.4 joli API for upgrades (I kinda presume it's not even possible)?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×