Jump to content
Sign in to follow this  
JACUK

Sendmail - no emails from checkout

Recommended Posts

Hi,

Throwing myself on the forum's mercy again after some great help on other issues.

Finally have processed a test order right through including test card transaction with Worldpay.

Seller email account and buyer email account both receive confirmation emails from Worldpay but OSCommerce does not generate any confirmation to seller or buyer.

When setting customer account up the customer email account received confirmation of the account creation and i have a form running on a non OSCommerce page on the site that also works using sendmail.

The email options are set to Transport=sendmail and Linefeeds to LF

Any suggestions or ideas would be appreciated.

Thanks,

Julian

osCommerce Online Merchant v2.3.4.1 CE Responsive

Share this post


Link to post
Share on other sites

one thing you can try is.

https://www.mail-tester.com

it will have a look at your email, to see if anything can be done to improve it, could be something in the email triggering a blacklist.

also make sure you got at least one email address added to Send Extra Order Emails To

Share this post


Link to post
Share on other sites

In configuration>my Store settings as follows:-

E-Mail Address - sales@clientsdomain.co.uk

Send Extra Order E-Mails To - address@oneofmydomains.co.uk

In Configuration>E-Mail Options settings as follows:-

E-Mail Transport Method - sendmail

E-Mail Linefeeds - LF

Unless I have mis-understood there is nothing else to configure?

Also just setup another customer account and the Welcome Email was received inn the customer email inbox.

Haven't tried mail-tester yet - will be trying later - but not sure at this stage that emails are actually being generated.

Have I missed a configuration setting?

Thanks,

Julian

Share this post


Link to post
Share on other sites
Posted (edited)
Hi Julian, ask your provider whether mails can be sent free or only with smtp username and password.
that was also the problem for me
Edited by YePix

Share this post


Link to post
Share on other sites

Hi,

Have been talking to hosting provider; they have checked the mail logs and can see the account setup email on the log for the sending mailbox but when an order is processed nothing is appearing. That tends to say to me that the emails are not being generated in the first place.

When in the checkout process is the email actually generated. As i mentioned before the Worldpay confirmation is being generated but the sysyem leaves me on the Worldpay confirmation page and doesnt go back to the shop, could this be the issue that the shop is not getting confirmation nfrom Worldpay and therefore is not generating the confirmation?

Any thoughts would be appreciated.

regards,

Julian

Share this post


Link to post
Share on other sites

Cracked it!

A spurious space in one of the Worldpay fields was stopping the transaction being flagged back to the website as authorised!

At least i know exactly where the email is generated in the order process!

Thanks for all your suggestions - much appreciated.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×