Jump to content
Psytanium

PHP and MySQL upgrade for 2.3.4

Recommended Posts

Hi,

I have 2.3.4 (8 years old, since 2.3.1) with lots of addons and modifications running fine, and i have to upgrade MySQL to 5.7 and PHP to 7.2.

I'm not looking to upgrade to 2.3.4BS soon, especially that i implemented Bootstrap manually (Front-end).

  1. Can someone tell me what are the problems i may encounter and how i should fix it ?
  2. Is OSC2.3.4.1 compatible with MySQL 5.7 and PHP 7.2 ?
  3. Is there a documentation how to upgrade from 2.3.4 to 2.3.4.1 ?

Thanks :)

Share this post


Link to post
Share on other sites

1. Jumping code from PHP 5.4 to PHP 7.2 compatibility is a huge task. Even the bleeding edge Frozen and Edge work has barely started on it. They're both currently up to PHP 7.1, if you can roll back to that. If you want to do it yourself, I suggest you read https://www.php.net/manual/en/migration70.deprecated.php and for 71 and 72 as well. You might even have to take a look at 56, 55, and 54 migrations.

2. Not really. The official 2.3.4.1 is merely 2.3.4 with the PHP 7 deprecated warnings turned off. Don't use it.

3. No. The "upgrade" hits only a couple or so files, and is easy enough to do in-place. Just compare 2.3.4 and 2.3.4.1 files and you'll see. At best, turning off PHP 7 deprecated warnings will buy you a little time for a more permanent fix -- there's no telling what's not working right behind the curtain.

One thing I hope you'll learn from all this is to keep your store on the current code base! This means carefully logging every single change you make to the files, what add-ons you installed, and very importantly, why you made a group of changes. There's no point in trying to replicate a bunch of code changes, only to realize half way through that Bootstrap responsive is already built in to the product! Whenever the pain of maintaining your current store's code base becomes too much, it's then easy to migrate to the latest and greatest, replicating all your new features without too much strain.


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get (stable) Frozenpatches or (unstable) Edge. See also the naming convention and the latest community-supported responsive "Edge" release

Share this post


Link to post
Share on other sites

@MrPhil Well understood, probably I will wait a year  or 2 then upgrade to PHP 7.x

1 more question, do you think I can update MySQL to 5.7 ? What problems I may encounter ? is there a documentation for this ?

Thanks

Share this post


Link to post
Share on other sites

I don't recall any database changes needed in recent years, but recently I have heard of databases (possibly MariaDB) complaining about fields missing default values.If you're at 2.3.4, you're probably OK with MySQL 5.7, but be prepared to have to add some default values if errors show up.


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get (stable) Frozenpatches or (unstable) Edge. See also the naming convention and the latest community-supported responsive "Edge" release

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×