Jump to content

Access to Admin area /backstage

Recommended Posts

Hi! I have been unable to access the admin part of my shop since mid-morning on Monday (now 2 days ago) - earlier that day I was able to log in to Admin, but the connection became progressively tenuous later in the morning and since then, despite using the correct login name/password, I haven't been able to get any further than entering those initial login details - the login seems to proceed, but it never gets further than a blank tab/"waiting for www.prolaxshop.com...", whereas I would normally then proceed to a second login page where I have to input the same details again - we use a 2-stage login, before accessing my Admin area.

The online site itself seems to be functioning correctly - orders can be placed, payments processed and the databases that represent the site's collective wisdom are also fully accessible - the domain is hosted by 1&1 and the SQL databases are billeted with them too. 1&1 Hosting technical support can see no apparent cause for my problems.

Stop press! The second stage of login page has now (all of a sudden) started to reappear and I have also managed to log in, so the problem seems to have "gone away" for the moment, at least.

That being said, does anyone know if there has been a general OSCommerce problem hanging around, or can anyone advise me where I could check to see if there is a problem with my site? We used to have a technical support partner, but he has moved on to other things, and as we will be putting our OSC shop 2out to pasture" in the next few months, my Directors can see no need for us to enter into  any sort of regular support agreement with anyone... 😞 so if there is anyone who can offer ad hoc assistance, I, for one, would be very grateful!  


Share this post

Link to post
Share on other sites

Hi David,

Sounds a little odd.  Might be worth trying this before you attempt to log in.

With the login form on screen press F12 on your keyboard which will open the Developer Tools window.  Once open click on the Network tab, whilst you're here tick the "Disable Cache" checkbox (this maybe located elsewhere depending on what browser you use, my advice is based on Chrome).

Then enter your login details and attempt to login.

The network tab will show you everything it's attempting to download to display the next page.  Check to see if there's anything hanging which is causing the page to not display whilst it waits for the download to finish.

The other thing is that it could be a redirect loop, if you see the network tab keep displaying the same URL over and over again this would indicate a loop.

It could also be stale cache, if it all of a sudden works then it may have been related to the "Disable Cache" which I said about earlier.  

If it still doesn't work try another browser.

With regards to ad-hoc support, I may be interested.  I'm a full time senior PHP developer for a digital marketing company (although offering this direct from myself and not via the company I work for) with over 18 years experience.

If it still don't work, hit it again!

Senior PHP Dev with 18+ years of commercial experience for hire, all requirements considered, see profile for more information.

Is your version of osC up to date? You'll find the latest osC version (the community-supported responsive version) here.

Share this post

Link to post
Share on other sites

Hi! The temporary respite that I experienced yesterday has ended.

At the moment, I can't even get to the post-authentication step to attempt to log in "properly", so I haven't been able to try out your investigation to its fullest extent - I tried the F12 at the first request stage and have taken a screen shot of that process in case it helps.

I have disabled the Cache function and had previously cleared my Firefox cache too, and I also tried to log in with my Kaspersky Total Security disabled too - all to no avail.

I have previously tried to login using Chrome, but that experience wasn't any different to this current Firefox one. 

Did I forget anything/have you any other thoughts?

Thanks for helping, by the way!

Might the screen shot be of any use?

If so, where should I send it and/or how?

I am relatively new to posting and being active in the Forum, despite my 10+ years of membership....

Share this post

Link to post
Share on other sites

When a host upgrades the PHP version, it's often the admin section where problems are noticed first. Have you asked your host if they just changed the PHP version? Any other changes? Exactly what version of osCommerce are you using?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now