Jump to content
Harald Ponce de Leon

Marketplace Category/Version Cleanup

Recommended Posts

2 hours ago, raiwa said:

Phoenix is on the official download site:

My point is that Phoenix is not the official osC release, and thus will never be picked up by one-button installers (Softaculous, etc.). It would be great for Phoenix (or even, Frozen) to be on such installers, but my experience has been that they go with what is labeled the "official" release. Thus, newbies will continue to install the obsolete 2.3.4.1 and have to be told that they should have installed something else. Frankly, this makes everyone associated with osC look stupid.

Share this post


Link to post
Share on other sites

Oh and for anyone downloading Official osC if you do wish to use only an Official version tthen talk to one of the osc partners or an independent developer for best advice.

Most osC shops still run on Official software.

Just for a bit of fun I download Official again and had a go at making it responsive, only spent about 30 min on it so it's not perfect but will show what is posiable, I'm sure a profesional developer could do a better job and make it PHP7.2 at the same time.

It's plain old osC site no fancy template. Was done using the Unsemantic CSS framework.  https://unsemantic.com/about

You can check it out on the test site here https://jcmagpie.co.uk/

image.thumb.png.e4c38b86f179813c7962036925c5d840.png


 

Share this post


Link to post
Share on other sites
36 minutes ago, Hotclutch said:

Although BS4 is still the best option IMO.

Sure I agree with you, this was just a bit of fun to see what was required as I personaly have never used official 2.3.4.1, my last version was 2.2a  😊.

It's just that a lot of people are running official osC and have heavily modified shops, for some it may be a better option to just make the existing shop reponsive and php7.2 compliant than start all over again.

w3css look good may take a look at that as well.

The only issue I have with BS is it keeps dropping classes, would be fine if they kept backward compatability but they just don't , xs has been droped in 4 why? would have done no harm to keep it. I just dont see the need for this constant churn of versions, BS5 will be along soon and I bet it will do the same!

 


 

Share this post


Link to post
Share on other sites
57 minutes ago, Hotclutch said:

W3CSS is another framework i like working with:

Work's fine on official , but need work as it messes up the product info page, image no longer show but looks to be a bit smoother.

image.thumb.png.e4123ab0c6dd9a731719bda216383811.png


 

Share this post


Link to post
Share on other sites
5 hours ago, JcMagpie said:

Official is still Official and still listed in the latest version of softaculous

What's your point? The official osC 2.3.4.1 (found on every one-button installer) is not really PHP 7 ready (it starts having problems above 5.4 or so) and is non-responsive. The CE stream (Frozen/Edge/Phoenix) work with up to PHP 7.1, and are responsive. Plus, you get a lot of functional enhancements (such as improved modularity) along with the other things. I fail to see why it's better to put in all the work to upgrade an official site to PHP 7.x and responsive, when you could simply install something from CE and customize that with add-ons and CSS tweaking. If you made tremendous changes to your official osC store, and neglected to keep any record of what you did, well, you deserve the extra work. Even then, in the long run, it will be less work to start over from CE (looking at future upgrades).

Share this post


Link to post
Share on other sites

@MrPhil

I think his point is the same as yours, that by not listing the CE as official, it won't be offered by the installers. I am a shopowner, and i don't want this "Phoenix" for my shop. So i make the effort of taking official osC and build it up to how i want it.

Share this post


Link to post
Share on other sites
2 minutes ago, Hotclutch said:

@MrPhil

I think his point is the same as yours, that by not listing the CE as official, it won't be offered by the installers. I am a shopowner, and i don't want this "Phoenix" for my shop. So i make the effort of taking official osC and build it up to how i want it.

But would you use it if it was released as official or for your sake of your pride would you still not use it.


REMEMBER BACKUP, BACKUP AND BACKUP

Get the latest Responsive osCommerce CE (community edition) here

It's very easy to over complicate what are simple things in life

Share this post


Link to post
Share on other sites
Just now, 14steve14 said:

But would you use it if it was released as official or for your sake of your pride would you still not use it.

I said it before that i find it hard to believe that that version could be released as official.

Share this post


Link to post
Share on other sites

Happy to have used the CE (ie, totally unofficial oscommerce) on your opel spares website...what changed? (honest question)


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites
Posted (edited)
15 hours ago, Hotclutch said:

Not bad for 30mins.

Ok   @Hotclutch  how's this for another 60 mins 😊 a quick update to the W3.css to get images working. W3css is good and as you said easy to use.

https://jcmagpie.co.uk/

This probably explains why most users have just stuck with the official software for their sites. I've just done this for fun I'm sure some one spending a day or two on it would get a much better result.

image.thumb.png.5cb0000326e77a7b15b5fa30e8e31ca9.png

 

Edited by JcMagpie

 

Share this post


Link to post
Share on other sites
Posted (edited)

@JcMagpie

Hi Zahid

includes/modules/boxes/bm_card_acceptance.php

replace:

    function execute() {
      global $PHP_SELF, $oscTemplate;

      if ( (substr(basename($PHP_SELF), 0, 8) != 'checkout') && tep_not_null(MODULE_BOXES_CARD_ACCEPTANCE_LOGOS) ) {
        $output = '<div class="ui-widget infoBoxContainer">' .
                  '  <div class="ui-widget-header infoBoxHeading">' . MODULE_BOXES_CARD_ACCEPTANCE_BOX_TITLE . '</div>' .
                  '  <div class="ui-widget-content infoBoxContents" style="text-align: center;">';

        foreach ( explode(';', MODULE_BOXES_CARD_ACCEPTANCE_LOGOS) as $logo ) {
          $output .= tep_image(DIR_WS_IMAGES . 'card_acceptance/' . basename($logo));
        }

        $output .= '  </div>' .
                   '</div>';

        $oscTemplate->addBlock($output, $this->group);
      }
    }

with:

    function execute() {
      global $PHP_SELF, $oscTemplate;

      if ( (substr(basename($PHP_SELF), 0, 8) != 'checkout') && tep_not_null(MODULE_BOXES_CARD_ACCEPTANCE_LOGOS) ) {
        $output = '<div class="w3-card w3-margin-bottom">' .
                  '  <header class="w3-container w3-blue"><h6>' . MODULE_BOXES_CARD_ACCEPTANCE_BOX_TITLE . '</h6></header>' .
                  '  <div class="w3-container w3-center">';

        foreach ( explode(';', MODULE_BOXES_CARD_ACCEPTANCE_LOGOS) as $logo ) {
          $output .= tep_image(DIR_WS_IMAGES . 'card_acceptance/' . basename($logo));
        }

        $output .= '  </div>' .
                   '</div>';

        $oscTemplate->addBlock($output, $this->group);
      }
    }

maybe you can start a new thread to take this further, i will give you some tips if you want to produce something for the community.

Edited by Hotclutch
typos

Share this post


Link to post
Share on other sites

Thanks but sorry Ashley  not for me, this was just a bit of fun to see what was involved and could be done. I'm sure the developers working with osC can do a much better job than this. I'm going to keep the site up and running so anyone intested can take a look.

Your right probably not the right thread to have this in but hey it's done now. I'll post in the main section then anyone intrested can take a look and add comments in that.

Sorry @Harald Ponce de Leon for hogging your thread feel free to remove.


 

Share this post


Link to post
Share on other sites

Hi @Harald Ponce de Leon,  I hope you are very well!!!

When are you going to put a special label for Phoenix addons on the market? I understand that it is not very complicated and would be great for the development of Phoenix.

Currently there is almost no addon for Phoenix and the old addon none works ... that does not motivate new and old users to migrate to this magnificent new Phoenix version.

That is very necessary to get Phoenix to get off the ground and fly.

Best regards.

Valqui

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×