Jump to content
blackrayne09

Where is The Orders

Recommended Posts

Hello, We have installed the OSCommerce system with a custom OSCommerce template. We also installed the CCBill module but our issue is when an order is made, the payment is processed successfully but the orders do not show up in the admin or the user account nor does it clear the shopping cart. Is there anyone out there who knows how to connect the databases correctly? Please advise. 

Share this post


Link to post
Share on other sites

If the site is working (showing products, allowing account creation and signon, etc.) the database is correctly connected. The usual cause of trouble like you're seeing is that the user does not proceed correctly after going offsite to make a payment (is that what CCBill does?), but exits at that point (after payment) without returning to the store. Have you tried carefully going through a purchase, returning to the store after completing the payment? It's also possible that you did not configure CCBill correctly to return to the store. I'm not familiar with CCBill, so I can't offer any more information on it. Maybe they have a log of what happened and where it tried to go (URL).

Before going any further, what osCommerce release have you installed? I suspect you installed the "official" 2.3.4.1 version off this site, but unfortunately it is totally obsolete. The one you should be running is "Frozen" + patches (see links below), or "Edge" if you're adventurous. These are sometimes generically referred to as 2.3.4.1BS or 2.3.4.1 CE. Did some consultant select this for you, who also provided the custom template? Who knows what you're running on. Templates can range anything from some CSS settings in user.css to a complete replacement for much of the store. A template built for the official version is usually not going to work with Frozen or Edge, so that's money down the drain.

Share this post


Link to post
Share on other sites

This problem is the customer. He don't finish the purchased correct. Than the order is still in the basket and don't appear in the order list. I get this problem of the customers with a lot payment systems like PayPal, CCBill, Moneybroker and so on. I can fix this. Pm me if you still needs help.


  • The clever one learn from everything and from everybody
  • The normal one learn from his experience
  • The silly one knows everything better

[socrates, 412 before Christ]

Computers help us with the problems we wouldn't have without them!
99.9% of the bugs sit in front of the computer!
My programmed add-ons: WDW EasyTabs 1.0.3, WDW Facebook Like 1.0.0

if(isset($this) || !isset($this)){ // that's the question...

 

Share this post


Link to post
Share on other sites
On 4/22/2019 at 5:04 AM, MrPhil said:

If the site is working (showing products, allowing account creation and signon, etc.) the database is correctly connected. The usual cause of trouble like you're seeing is that the user does not proceed correctly after going offsite to make a payment (is that what CCBill does?), but exits at that point (after payment) without returning to the store. Have you tried carefully going through a purchase, returning to the store after completing the payment? It's also possible that you did not configure CCBill correctly to return to the store. I'm not familiar with CCBill, so I can't offer any more information on it. Maybe they have a log of what happened and where it tried to go (URL).

Before going any further, what osCommerce release have you installed? I suspect you installed the "official" 2.3.4.1 version off this site, but unfortunately it is totally obsolete. The one you should be running is "Frozen" + patches (see links below), or "Edge" if you're adventurous. These are sometimes generically referred to as 2.3.4.1BS or 2.3.4.1 CE. Did some consultant select this for you, who also provided the custom template? Who knows what you're running on. Templates can range anything from some CSS settings in user.css to a complete replacement for much of the store. A template built for the official version is usually not going to work with Frozen or Edge, so that's money down the drain.

I use https://github.com/gburton/Responsive-osCommerce/archive/2341-Frozen.zip

I did coded a complett new ccbill add-on. This add-on will be verified by ccbill, soon. If this happen, can PM me for to get the add-on.


  • The clever one learn from everything and from everybody
  • The normal one learn from his experience
  • The silly one knows everything better

[socrates, 412 before Christ]

Computers help us with the problems we wouldn't have without them!
99.9% of the bugs sit in front of the computer!
My programmed add-ons: WDW EasyTabs 1.0.3, WDW Facebook Like 1.0.0

if(isset($this) || !isset($this)){ // that's the question...

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×