Jump to content
edfaught

adminAppMenu Missing

Recommended Posts

After installation the admin page's entire adminAppMenu div contains no source HTML. There are no rendering errors  and the source does contain links to the javascripts in the header. This is almost certainly some sort of error in my admin/includes/configure.php but I cannot figure it out. osCommerce v2.3.4.1 CE FROZEN

Share this post


Link to post
Share on other sites

So why not post the details of your configure.php file (minus your db login information of course) so someone can have a look and offer suggestions.

Dan

Share this post


Link to post
Share on other sites

Of course:

<?php
  define('HTTP_SERVER', 'https://mystore.com');
  define('HTTPS_SERVER', 'https://mystore.com');
  define('ENABLE_SSL', false);
  define('HTTP_COOKIE_DOMAIN', '');
  define('HTTPS_COOKIE_DOMAIN', '');
  define('HTTP_COOKIE_PATH', '/admin');
  define('HTTPS_COOKIE_PATH', '/admin');
  define('HTTP_CATALOG_SERVER', 'https://mystore.com/');
  define('HTTPS_CATALOG_SERVER', 'https://mystore.com/');
  define('ENABLE_SSL_CATALOG', 'true');
  define('DIR_FS_DOCUMENT_ROOT', '/home/myaccount/public_html/mystore.com');
  define('DIR_WS_ADMIN', '/admin/');
  define('DIR_WS_HTTPS_ADMIN', '/admin/');
  define('DIR_FS_ADMIN', '/home/myaccount/public_html/mystore.com/admin');
  define('DIR_WS_CATALOG', '');
  define('DIR_WS_HTTPS_CATALOG', '');
  define('DIR_FS_CATALOG', '/home/myaccount/public_html/mystore.com/');
  define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');
  define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');
  define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');
  define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');
  define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');
  define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');
  define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');
  define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

?>

Share this post


Link to post
Share on other sites
Posted (edited)

change to

  define('HTTP_SERVER', 'https://mystore.com');
  define('HTTPS_SERVER', 'https://mystore.com');
  define('ENABLE_SSL', true);
  define('HTTP_COOKIE_DOMAIN', 'mystore.com');
  define('HTTPS_COOKIE_DOMAIN', 'mystore.com');
  define('HTTP_COOKIE_PATH', '/admin');
  define('HTTPS_COOKIE_PATH', '/admin');
  define('HTTP_CATALOG_SERVER', 'https://mystore.com');
  define('HTTPS_CATALOG_SERVER', 'https://mystore.com');
  define('ENABLE_SSL_CATALOG', 'true');
  define('DIR_FS_DOCUMENT_ROOT', '/home/myaccount/public_html/mystore.com');
  define('DIR_WS_ADMIN', '/admin/');
  define('DIR_WS_HTTPS_ADMIN', '/admin/');
  define('DIR_FS_ADMIN', '/home/myaccount/public_html/mystore.com/admin/');
  define('DIR_WS_CATALOG', '/');
  define('DIR_WS_HTTPS_CATALOG', '/');
  define('DIR_FS_CATALOG', '/home/myaccount/public_html/mystore.com/');
  define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');
  define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');
  define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');
  define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');
  define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');
  define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');
  define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');
  define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

I would advise you change the name of the admin directory

 

Edited by 241
simplify

No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P


Support The Project
Documentation/Knowledgebase/Discussions
 

Share this post


Link to post
Share on other sites
On 4/4/2019 at 11:51 AM, edfaught said:

After installation the admin page's entire adminAppMenu div contains no source HTML. There are no rendering errors  and the source does contain links to the javascripts in the header. This is almost certainly some sort of error in my admin/includes/configure.php but I cannot figure it out. osCommerce v2.3.4.1 CE FROZEN

 

On 4/5/2019 at 11:32 AM, edfaught said:

Of course:

<?php
  define('HTTP_SERVER', 'https://mystore.com');
  define('HTTPS_SERVER', 'https://mystore.com');
  define('ENABLE_SSL', false);
  define('HTTP_COOKIE_DOMAIN', '');
  define('HTTPS_COOKIE_DOMAIN', '');
  define('HTTP_COOKIE_PATH', '/admin');
  define('HTTPS_COOKIE_PATH', '/admin');
  define('HTTP_CATALOG_SERVER', 'https://mystore.com/');
  define('HTTPS_CATALOG_SERVER', 'https://mystore.com/');
  define('ENABLE_SSL_CATALOG', 'true');
  define('DIR_FS_DOCUMENT_ROOT', '/home/myaccount/public_html/mystore.com');
  define('DIR_WS_ADMIN', '/admin/');
  define('DIR_WS_HTTPS_ADMIN', '/admin/');
  define('DIR_FS_ADMIN', '/home/myaccount/public_html/mystore.com/admin');
  define('DIR_WS_CATALOG', '');
  define('DIR_WS_HTTPS_CATALOG', '');
  define('DIR_FS_CATALOG', '/home/myaccount/public_html/mystore.com/');
  define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');
  define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');
  define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');
  define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');
  define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');
  define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');
  define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');
  define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

?>

I found the problem. The definition for DIR_FS_ADMIN requires a trailing slash.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×