Jump to content
shetch

Support thread for Bootstrap V4 Oscommerce Administration v2.3.4.1 CE

Recommended Posts

19 minutes ago, shetch said:

This is caused by the jquery reference, to fix simply move the jquery script link (assets/js/jquery.min.js) in admin/includes/template_bottom.php to admin/includes/template_top.php (below the css links).  Please find attached ht_grid_list_view.php with adjusted bootstrap checkbox fix. (so to avoid the css hack)

Any other module using jquery should also now be ok but keep me informed :)

ht_grid_list_view.zip

Here's the other 2 jquery modules too

ht_jquery.zip

Share this post


Link to post
Share on other sites

Hi,

How can I add a second language to Admin dashboard?

Thank you,

Luiz

Share this post


Link to post
Share on other sites

had a quick look, at it and it looks good.

as i use a few addon's which have there own page which i would want to convert to make it look right with this admin, i decided to have a quick play, with one of the existing files, to see what sort of thing has been changed.

one of the things i wanted to achieve was to use the font awesome icons on the buttons, (which only requires a small change to do), as well as putting which font awesome icon i wanted to use on the button (with only one small hiccup, as i tried using font awesome 5 icons when the admin uses v4.

but anyway below is what i achieved (on the backup.php page)

image.thumb.png.10874d43657baac51206c9642bfa342a.png

so after doing that, i can now go back and make the changes to the extra admin pages i got.

Share this post


Link to post
Share on other sites

Need to take a look at product copy as it's not working for me. Selecting copy provides no controls to make copy,

image.png.f7e40671ae1724c0cd635663c3da4e4a.png 

Error given is,

Too few arguments to function tep_draw_bs_radio_field(), 5 passed in /home/chilleddisplaysc/public_html/admin8262/categories.php on line 907 and exactly 6 expected in /home/chilleddisplaysc/public_html/*******/includes/functions/html_output.php:331
Stack trace:
#0 /home/chilleddisplaysc/public_html/********/categories.php(907): tep_draw_bs_radio_field('copy_as', 'duplicate', NULL, NULL, 'Duplicate produ...')
#1 {main}
  thrown in /home/chilleddisplaysc/public_html/********/includes/functions/html_output.php on line 331

Fixed for now by replacing line 907 with original line. Layout need looking at. Radio buttons again over lapping text.

image.thumb.png.9b80b633561b09cc0b2dcf9203f5048f.png


 

Share this post


Link to post
Share on other sites

Thank's Craig but my fix above did not work! :( got the edit menu to show but clearly must be more to it as it's not saving the copied product properly.


 

Share this post


Link to post
Share on other sites
11 minutes ago, JcMagpie said:

Thank's Craig but my fix above did not work! :( got the edit menu to show but clearly must be more to it as it's not saving the copied product properly.

Can't replicate the editor button issue but here's the fixed categories.php file for the copy product radio buttons on line 907.

categories.zip

Share this post


Link to post
Share on other sites

Thank's Simon that worked. The edit issue I'm sure is new as i remember editing a product before we had the first issue when we changed 3 files? I'll try and see if I can roll back and get it to work.


 

Share this post


Link to post
Share on other sites

It looks to be a display issue as on inspection the menu display is in the html output! Just looks like I have lost the link to all the buttons,

image.thumb.png.c5ea0348b97a419f1c26db668c649d59.png


 

Share this post


Link to post
Share on other sites

Ok so tracked down a bug report of the same problem

https://github.com/Alex-D/Trumbowyg/issues/318

Says to check path to icons!

$.trumbowyg.svgPath = 'css/icons.svg';

😊 have checked and icons are definetly in the assets path! so back to square one. But I have checked the menu works so it is just missing icons.


 

Share this post


Link to post
Share on other sites
9 minutes ago, JcMagpie said:

Ok so tracked down a bug report of the same problem

https://github.com/Alex-D/Trumbowyg/issues/318

Says to check path to icons!


$.trumbowyg.svgPath = 'css/icons.svg';

😊 have checked and icons are definetly in the assets path! so back to square one. But I have checked the menu works so it is just missing icons.

Did you replace the categories.php file with the version I attached earlier or simply change line 907 manually?

Share this post


Link to post
Share on other sites
Posted (edited)

Replaced it with your new one. It works  just icons not showing, so not a big issue can carry on testing it for now as is.

Edited by JcMagpie

 

Share this post


Link to post
Share on other sites

Re installed original files from original first down load and menu is back as in original video posted. 😊 Will do for now, I'll do changes step by step to see which one brakes menu in the morning.

image.thumb.png.ffda1891548d7b0573a19949f4c19aab.png


 

Share this post


Link to post
Share on other sites

Nothing wrong with your files or updates. It looks like when the original problem existed with the datepicker not diplaying properly, opeining and closing the module must have caused problems!

This time I installed and then did updates before doing anything with admin, and it all installs and works. So best bet is to install the latest and do any updates berfore trying to use the admin.


 

Share this post


Link to post
Share on other sites

on the left hand menu.

if you add a new menu item by dropping a file in the boxes folder (like i just did with the information pages add on) the icons start going in the wrong place

image.png.034927dcff0ed4835bcc460bee65b696.png

 

due you using css nth ( and due to them being sorted by the title you can't guarantee where each one would be.

 

the way i sorted it was to in each file within the boxes folder add (based on catalog.php)

'fa' => '<i class="fa fa-barcode" aria-hidden="true"></i>',

just after

'heading' =>  BOX_HEADING_CATALOG,

then in column_left.php  i changed line 60 to

      <a class="menu-icon" href="#">' . $groups['fa'] . ' <span>' . $groups['heading'] . '</span> <span class="menu-arrow"></span></a>

 

 

 

image.png

Share this post


Link to post
Share on other sites
3 hours ago, puddlec said:

on the left hand menu.

if you add a new menu item by dropping a file in the boxes folder (like i just did with the information pages add on) the icons start going in the wrong place

image.png.034927dcff0ed4835bcc460bee65b696.png

 

due you using css nth ( and due to them being sorted by the title you can't guarantee where each one would be.

 

the way i sorted it was to in each file within the boxes folder add (based on catalog.php)


'fa' => '<i class="fa fa-barcode" aria-hidden="true"></i>',

just after


'heading' =>  BOX_HEADING_CATALOG,

then in column_left.php  i changed line 60 to


      <a class="menu-icon" href="#">' . $groups['fa'] . ' <span>' . $groups['heading'] . '</span> <span class="menu-arrow"></span></a>

 

 

 

image.png

That's a better approach, have updated files so next release will include.  If you also add the class fa-fw they will line up better too :)

Share this post


Link to post
Share on other sites

@shetch  Nice work, thanks for sharing.

Do you plan to expand it to new functionalities? If yes please consider adding something like these addon for organizing modules:

https://apps.oscommerce.com/3DQyi&amp;improved-content-modules-admin-for-2-3-4

https://apps.oscommerce.com/sJbv1&amp;improved-modules-admin-for-2-3-4

Getting rid of the right menu boxes would be nice. This allows more space on mobile devices and quicker workflow.

BTW I found an align issue in dashbboard with big resolutions:

Clipboard02.thumb.jpg.2e88d65f56978a32356124450b934522.jpg

 

Share this post


Link to post
Share on other sites
On 4/6/2019 at 12:49 AM, shetch said:

I agree there should be focus on only one version of front and backend, but I'm afraid oscommerce cannot move forward until the official release becomes one of the same, and the oscommerce site itself is modernised.  It has to compete with opencart, prestashop & magento to name but a few and to be frank, it has no chance in it's current form.  For example, cpanel quick installers install the outdated official release, so why would people use it in preference to the competitors? 

Our community is probably the first on the Internet, which in the open format has begun to support the development of this software in free access with open source. From the very beginning, a real concept of e-commerce on the Internet was developed and created, and many people united around it. For many, this was the only real way to start selling on the Internet.
I am very grateful to Harald and his comrades who wrote the source code and gave it to the community.
The development of e-commerce is largely due to this software. Most of the modern and popular online stores today were written on the basis of OsCommerce and became commercial projects.
But our forum lives. And the community works. Version 2.3.4.1 was created. Frozen, but in spite of the frost, it really develops!
I want to invite the community to discuss the future of the software and jointly develop a concept for its future development.
I invite to discuss the founding father - Harald. Let's discuss and decide how we can further develop our project, which for many of us has become a part of life and family!
I see those people who do business, spend their time and effort, correct the code, write new features and actively support the community.
My thanks to all.


Support forum for osCommerce in russian language - from Ashkelon. Support since 2002.

Best regards,

Fredi

Share this post


Link to post
Share on other sites
On 4/12/2019 at 6:07 PM, piernas said:

@shetch  Nice work, thanks for sharing.

Do you plan to expand it to new functionalities? If yes please consider adding something like these addon for organizing modules:

https://apps.oscommerce.com/3DQyi&amp;improved-content-modules-admin-for-2-3-4

https://apps.oscommerce.com/sJbv1&amp;improved-modules-admin-for-2-3-4

Getting rid of the right menu boxes would be nice. This allows more space on mobile devices and quicker workflow.

BTW I found an align issue in dashbboard with big resolutions:

Clipboard02.thumb.jpg.2e88d65f56978a32356124450b934522.jpg

 

Yes, I'm working on it, here's the fix for the widescreen view (admin/includes/modules/dashboard/d_quick_links.php

 

d_quick_links.zip

1.png

2.png

Share this post


Link to post
Share on other sites

Hi! Shetch, just installed this, its just beautiful. And works.

But is there another BS theme that could be used that does not fetch the external font from googlefonts Api. I like to host all the scripts etc, locally.

I know you would have other priorities than this request.

Thank-you.

Mark.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×