Jump to content
kiranpoolla

App is not working in php 7

Recommended Posts

Hello sir,

I basically familier wiith Laravel,Codigniter,megento and open cart but newbie for os commerce, I got a requirement from the client that the application is not working in php v7.X I just checked in application_top.php and its v 1.2 I just checked the forum its way older version so i want to upgrade it to latest one which supports in php v7. Please do needful

Share this post


Link to post
Share on other sites

None of the official versions of oscommerce will run in php7 as far as I know. The community BS version does. It can be found at https://forums.oscommerce.com/topic/396152-bootstrap-3-in-234-responsive-from-the-get-go/

 


REMEMBER BACKUP, BACKUP AND BACKUP

Get the latest Responsive osCommerce CE (community edition) here

It's very easy to over complicate what are simple things in life

Share this post


Link to post
Share on other sites

Yeah, the "official" version downloaded from this site (osC 2.3.4.1) may install, but does not properly support PHP 7 (my understanding is that it merely turns off the "deprecated" warnings). You should migrate to the community version osC 2.3.4.1BS "Frozen", which runs on PHP 7.1 and is responsive (mobile-friendly), as well as having many new features and bug fixes. Unfortunately, it's a manual install and conversion of the old database to the new schema (not all that difficult, just meticulous detail work). Any add-ons or custom modifications of your client's store will have to be researched and re-done. This is not an upgrade, but a complete new install.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×