Jump to content
Adam_Maynard

Please help me with login problem

Recommended Posts

Hello, On our site: bibbtool.com

Many customers cannot log in to site, even brand new ones.

I think it may be a cookies issue in Configure.php but I do not know right off how to fix it.

If someone could help me, I would be very appreciative.

 

Share this post


Link to post
Share on other sites

Please post your includes/configure.php file here (without the database credentials at the bottom of it) so someone can take a look. Also, is this a new site or was it working before? If it was working before, has anything changed, like moving hosts or installing addons?

Share this post


Link to post
Share on other sites

Also useful would be exactly what version of osCommerce (and whether "official" or "community edition"), exactly what PHP version (and whether your host just upgraded PHP), and any other information that might be useful in diagnosing the problem.


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get (stable) Frozenpatches or (unstable) Edge. See also the naming convention and the latest community-supported responsive "Edge" release

Share this post


Link to post
Share on other sites

Ok, here is our configure.php

Thank You!

configure.php

Edited by bonbec
configure.php removed for security reason. If you post your file, do it without the database credentials at the bottom of it

Share this post


Link to post
Share on other sites

You are going to have to change your database password now.


The water in a vessel is sparkling; the water in the sea is dark. The small truth has words which are clear; the great truth has great silence.

- Rabindranath Tagore

Share this post


Link to post
Share on other sites

Here is his config file without the database credentials.

<?php
/*
  osCommerce, Open Source E-Commerce Solutions
  http://www.oscommerce.com

  Copyright (c) 2003 osCommerce

  Released under the GNU General Public License
*/

// Define the webserver and path parameters
// * DIR_FS_* = Filesystem directories (local/physical)
// * DIR_WS_* = Webserver directories (virtual/URL)
  define('HTTP_SERVER', 'https://www.bibbtool.com/'); // eg, http://localhost - should not be empty for productive servers
  define('HTTPS_SERVER', 'https://www.bibbtool.com/'); // eg, https://localhost - should not be empty for productive servers
  define('ENABLE_SSL', true); // secure webserver for checkout procedure?
  define('HTTP_COOKIE_DOMAIN', 'bibbtool.com');
  define('HTTPS_COOKIE_DOMAIN', 'bibbtool.com');
  define('HTTP_COOKIE_PATH', '');
  //define('HTTP_COOKIE_PATH', '/shar');
  define('HTTPS_COOKIE_PATH', '/');
  define('DIR_WS_HTTP_CATALOG', '');
  define('DIR_WS_HTTPS_CATALOG', '');
  define('DIR_WS_IMAGES', 'images/');
  define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
  define('DIR_WS_INCLUDES', 'includes/');
  define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
  define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
  define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
  define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
  define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

  define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');
  define('DIR_FS_CATALOG', '/var/www/vhosts/bibbtool.com/httpdocs/');
  define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');
  define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

  define('USE_PCONNECT', 'false'); // use persistent connections?
  define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'
?>

 


The water in a vessel is sparkling; the water in the sea is dark. The small truth has words which are clear; the great truth has great silence.

- Rabindranath Tagore

Share this post


Link to post
Share on other sites

@Adam_MaynardTry changing these

  define('HTTP_COOKIE_PATH', '');
  define('HTTPS_COOKIE_PATH', '/');
  define('DIR_WS_HTTP_CATALOG', '');
  define('DIR_WS_HTTPS_CATALOG', '');

to these

  define('HTTP_COOKIE_PATH', '/');
  define('HTTPS_COOKIE_PATH', '/');
  define('DIR_WS_HTTP_CATALOG', '/');
  define('DIR_WS_HTTPS_CATALOG', '/');

If that doesn't help, please answer all of the other questions asked.

Share this post


Link to post
Share on other sites

Hello, I tried that and still have the issue.

As far as the other questions, It was working before. This site is old.

The only changes I have made was getting the site fully HTTPS secure.

One of you showed me it was an issue with cookies,

When I go to login to site I get this link:

https://www.bibbtool.com//login.php?osCsid=cuf79e3jsjvhqntb3d2e8etcd0

That link does not work

But if I enter this:

https://www.bibbtool.com//login.php

I am able to login properly.

Again, I thank you very much for your help.

Share this post


Link to post
Share on other sites

First, why do you double the slash after the domain? It should be a single slash: https://www.bibbtool.com/login.php

When the osCsid is given, and you click on that link, it doesn't work? You're not saving that link for later and typing it back in (or cut and pasting)?


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get (stable) Frozenpatches or (unstable) Edge. See also the naming convention and the latest community-supported responsive "Edge" release

Share this post


Link to post
Share on other sites

I do not know about the double slash

And yes, if it says okCsid it will not log you in. This is the link the site puts there.

If I manually take out everything in the link after login.php, I am able to log into site just fine.

Share this post


Link to post
Share on other sites

The session ID (osCsid) should go away after you click the first link but it isn't doing that. That is probably due to an old version of the url rewriter that is installed. The problem you describe can usually be traced to the session ID and since it works for you if you remove it from the url, that addon seems most likely to be the problem. Try turning it off in admin->Configuration and see if the problem goes away. Note that older versions of Ultimate SEO and most versions, if not all, of SEO 5 won't turn off completely so this test may not be conclusive.

Share this post


Link to post
Share on other sites

No, I meant turn off the url rewriter. I don't know which you have installed so I wasn't specific. But in admin->Configuration there should be a link for SEO URLs or SEO 5, or something similar. Click on that and you will see the option to turn it off.

Share this post


Link to post
Share on other sites

To be clear, did you make the changes to the includes/configure file?  I see the double slash still there that Phil mentioned. That should be fixed.

I successfully created an account on your site. I then used a different browser and was able to login. So if this is an intermittent problem, which it seems to be, it will be difficult to troubleshoot in a support thread like this. All I can suggest is to try various things. For example, see if it only fails in certain browsers. If you have the master password addon installed and if you know of a customer account that can't login, try logging into that account with the master password and see if you can get it to fail. Other than that, I can't think of anything else to try at this time. 

Share this post


Link to post
Share on other sites

Check your configure.php files for an entry which is normally something like "/catalog", but you may have changed it to "/" instead of "" when you installed in the root (a bad idea, but that may be water under the bridge).

If you're sure your host didn't sneak in a PHP upgrade, your HTTPS/SSL work must be to blame. Can you show us what you changed? There would be changes in the configure.php files and in .htaccess URL redirects/rewrites.


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get (stable) Frozenpatches or (unstable) Edge. See also the naming convention and the latest community-supported responsive "Edge" release

Share this post


Link to post
Share on other sites

the double slash is being caused by

  define('HTTP_SERVER', 'https://www.bibbtool.com/'); // eg, http://localhost - should not be empty for productive servers
  define('HTTPS_SERVER', 'https://www.bibbtool.com/'); // eg, https://localhost - should not be empty for productive servers

remove the slash from the end so as to be this

  define('HTTP_SERVER', 'https://www.bibbtool.com'); // eg, http://localhost - should not be empty for productive servers
  define('HTTPS_SERVER', 'https://www.bibbtool.com'); // eg, https://localhost - should not be empty for productive servers

 


No longer giving free advice. Please place deposit in meter slot provided.  Individual: [=] SME: [==] Corporation: [===]
If deposit does not fit one of the slots provided then you are asking too much! :P


Support The Project
Documentation/Knowledgebase/Discussions
 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×