Jump to content
Latest News: (loading..)
Uyghurmen

store logo not change

Recommended Posts

Hi Buddies,

     I change store logo from admin panel, in directory shown on. But on my site still shown osCommerce and it's change size by my logo size (my logo shorter "osCommerce" shorter, if mine long all the way "osCommerce" all the way) didn't change my image. what is the problem?

  Secondly: I changed CSS file to my fonts, but it's not effect to my site. 

Share this post


Link to post
Share on other sites

Make sure you have loaded image file as required.

image.png.d7f8ff2542980254ac68e7485778e228.png

 

Changing font depends on which software you are using use css in user.css or edit stylesheet.css


 

Share this post


Link to post
Share on other sites

Have you cleared the cache on the server and on your device you are using?

Is the new logo saved in the folder where it says it should be?


REMEMBER BACKUP, BACKUP AND BACKUP

Before installing the official version of oscommerce first look at a responsive version here

It's very easy to over complicate what are simple things in life

Share this post


Link to post
Share on other sites
On 1/5/2019 at 2:50 PM, JcMagpie said:

OsC dose not change image layout. If your image is portrait it will display portrait. If it is landscape it will display landscape.

Check your original images. or post link to site.

 

On 1/6/2019 at 1:21 AM, ecartz said:

That's in the language file (the main one).  For example, from includes/languages/english.php, it says: 


define('HTML_PARAMS', '');

From admin/includes/languages/english.php , it has


define('HTML_PARAMS','dir="ltr" lang="en"');

That's left to right.  To change to right to left, replace ltr with rtl.  Also change the lang to the two letter code for your language.  I.e. replace the en with whatever is appropriate. 

You can read more about the dir parameter to the html tag at https://www.w3.org/International/questions/qa-html-dir

There should be a .css file in your catalog directory.  Change your fonts in that.   It used to be called stylesheet.css but may have been renamed, e.g. to user.css. 

 

7 hours ago, JcMagpie said:

Make sure you have loaded image file as required.

image.png.d7f8ff2542980254ac68e7485778e228.png

 

Changing font depends on which software you are using use css in user.css or edit stylesheet.css

Salam Zahid,

    I did everything like that: in my admin logo only PNG format, so did PNG, after choosing, made save. In cPanel directory shown my logo, but in front of the store not.

Share this post


Link to post
Share on other sites
7 hours ago, JcMagpie said:

Make sure you have loaded image file as required.

image.png.d7f8ff2542980254ac68e7485778e228.png

 

Changing font depends on which software you are using use css in user.css or edit stylesheet.css

Hi Zahid,

 By the way ask you one more question: I translate to my language front page most shown words. but didn't find home page that: Welcome to... word in any language file. And "manufacturer" too. you have any experience about that? My site: http://eynek.biz/eshop/index.php

Thanks.

Share this post


Link to post
Share on other sites

@Uyghurmen

As @JcMagpie posted above, your logo must be in either a .png, .jpg, .gif, or .svg format. Your original logo image may be called anything (as long as it is in one of these formats) and stored anywhere (either on your server or your local workstation).

In Admin -> Configuration -> Store Logo, browse to your original logo image, then click on the Save button. Your logo image will now be saved on your server in the /images/ folder, and called /images/store_logo.xxx. Do NOT try to copy the file yourself, or put it in a different location. Let the program do it for you.

Now, at your workstation, launch your shop. Clear your cache (press <Ctrl><F5>).

Let us know what happens.

M

PS: Posting that you are annoyed that you aren't getting help is NOT going to build you any friends. And, when someone DOES help you, it's polite to 'Like' their post.


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get the latest community-supported responsive "Frozen" release here

Share this post


Link to post
Share on other sites
On 1/9/2019 at 1:21 AM, Uyghurmen said:

    I did everything like that: in my admin logo only PNG format, so did PNG, after choosing, made save.

If it is still not showing then you must have a problem with your software setup. It may be that the admin upload is not working.

Simply make a copy of you logo file and rename it store_logo.png  then copy it to images/

it will overwrite the osc logo and you should see yours. If this works then you need to look at reinstalling the software as something is broken in your admin.

As to the words yes there are a few that are need changing manually simply use something like grep and find the file using the code and change. If I remember in CE the welcome is in,

includes/languages/english/modules/content/index/cm_i_title.php

const MODULE_CONTENT_I_TITLE_PUBLIC_TITLE = 'Welcome on %s';

The manufactrer will depend on which one you need to change ie box or else where!

includes/languages/english/modules/boxes/bm_manufacturers.php

in official version look in,

includes/languages/english/index.php

define('HEADING_TITLE', 'Welcome to ' . STORE_NAME);

The manufacture is in the same file for official


 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×