Jump to content
Big Bear

JQuery/Javascript conflict? 2.3.4BS Gold

Recommended Posts

Some where along the way, I no doubt butchered something in my shop. Today I installed MegaMenu and was not able to get more than 1 column (full width for each sub category) and I noticed that my new products carousel module, jQuery Owl Carousel v1.3.3, also did the same (1 column right down the page).

After removing MegaMenu I had to remove and re-install jQuery Owl Carousel v1.3.3 to get NPC working again.

I had tried installing something else recently that made my product info tabs open and run down the page.

I have jQuery being called before all js in template top. What should I look for?

Thanks!

 

 

 

Share this post


Link to post
Share on other sites

I'm not sure that jquery is your problem sounds like you have a stray <div> flotting around somewhere in product_info or in one of your index_products. Best thing is to look at the html output using chrome inspect and see if you coan spot the stray div.


 

Share this post


Link to post
Share on other sites

@JcMagpie I inspected in chrome and I' m not seeing anything but the mess I made of the code. I also did a <div </div> match count on many files in editpad and that's all good. 

Thank you.

Share this post


Link to post
Share on other sites
On ‎12‎/‎16‎/‎2018 at 3:48 AM, Big Bear said:

not able to get more than 1 column

That can happen if you are missing a jquery file. Maybe you deleted a line with the code changes? If you have backups of the changed files you could compare them to see if that is the problem. You can also use the debugging tool in one of the browsers to see if shows a jquery error.

Share this post


Link to post
Share on other sites
44 minutes ago, Big Bear said:

I' m not seeing anything but the mess I made of the code.

Yeah I know the feeling I have done it to! Just keep looking check error codes use chrome inspect to see why the layout is messed up. Use the inspect tool to add a <div> or two in an area you suspect and if the layout is fixed your on the right track. You can edit the html with inspect to make layout changes.

If your totaly stuck pm the site link you never know a fresh pair of eyes may help even doggy old ones!

Oh and any missing script if it's still beeing used will get flaged up in chrome console as an error or warning.

Edited by JcMagpie

 

Share this post


Link to post
Share on other sites

@Jack_mcs SyntaxError: '*,:x' is not a valid selector. That shows with or without the megamenu. No core code changes for the plug & play menu module

@JcMagpie I will continue my quest for the perfect shopping experience. BS4 you say? then BS5 next month, then BS... the joys of mobile devices

Share this post


Link to post
Share on other sites

😂 “BS” quite an appropriate abbreviation me thinks! Funny how I managed with 2.2a for over 15 years without losing any sleep and now every little peep out of goolge and others and people fly into a panic!

It’s a bandwagon and you either get on it and ride the ride or use what you need and just step off. I stepped of at CE Frozen as far as my live sites are concerned.

The rest is just for amusement keeps the grey matter turning.


 

Share this post


Link to post
Share on other sites
5 hours ago, Big Bear said:

SyntaxError: '*,:x' is not a valid selector.

The jquery won't work if that error is in the code needed to run. But maybe it is an error in one of the addons that won't affect normal operation. You'll need to determine where that code is located and troubleshoot from there. In FF's developer browser, the line the failure is on is displayed, which makes it easier to locate.

Share this post


Link to post
Share on other sites
On 12/17/2018 at 9:51 PM, JcMagpie said:

😂 “BS” quite an appropriate abbreviation me thinks! Funny how I managed with 2.2a for over 15 years without losing any sleep and now every little peep out of goolge and others and people fly into a panic!

It’s a bandwagon and you either get on it and ride the ride or use what you need and just step off. I stepped of at CE Frozen as far as my live sites are concerned.

The rest is just for amusement keeps the grey matter turning.

For now you only made crap addons.
Yet i have to say, it is only you who makes any addon.
But seriously.
What you do is not outstanding and should be rejected to the uploads.
On the other hand, at least you try.

You would do much better if there would be some theme supported to osc.

But at least you doing something for the community.
(not take it to personal, as it is exactly YOU, who i encourage to do more)
That osc code not allow that, is something that needs to be changed.
And you know i am the right person for that (+ a few more who appear to be afraid to get kicked out by the leader).
 

Share this post


Link to post
Share on other sites

We're allowed to have two accounts now?


The water in a vessel is sparkling; the water in the sea is dark. The small truth has words which are clear; the great truth has great silence.

- Rabindranath Tagore

Share this post


Link to post
Share on other sites
17 hours ago, osComMarket said:

For now you only made crap addons.

What you do is not outstanding and should be rejected to the uploads.

I agree with that.


:heart: osCommerce

I am using osCommerce version 2.3.4.1 CE  Frozen

Get the latest Responsive osCommerce CE (community edition) here

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×