Jump to content
Latest News: (loading..)
TheDukeOfHurl

Redirect Error When Attempting To Access Admin Log In...

Recommended Posts

Hello!

I am unable to access Admin Log In of my osCommerce shop after a re-install. I keep receiving an error stating 'www.bigmusicgeek.com redirected you too many times'.  any idea why this is happening?

Thanks!

Share this post


Link to post
Share on other sites

When you say "re-install", do you mean you had a working shop and replaced its file from a backup, installed a new version or something else? The problem you are seeing is usually due to the admins configure file. But if you just reloaded files from backup, there wouldn't be any reason for the configure file to be bad. Although, if you did a re-install on a new server, then the paths would probably be different and that would cause it. But regardless what change you made, the best thing to do is to post your admins configure file here, minus the database details, so someone can take a look.

Share this post


Link to post
Share on other sites

Here is the admin/includes/configure.php file:

<?php

  define('HTTP_SERVER', 'http://www.bigmusicgeek.com');

  define('HTTPS_SERVER', 'https://www.bigmusicgeek.com');

  define('ENABLE_SSL', false);

  define('HTTP_COOKIE_DOMAIN', 'http://www.bigmusicgeek.com');

  define('HTTPS_COOKIE_DOMAIN', 'https://www.bigmusicgeek.com');

  define('HTTP_COOKIE_PATH', '/catalog/admin');

  define('HTTPS_COOKIE_PATH', '/catalog/admin');

  define('HTTP_CATALOG_SERVER', 'http://www.bigmusicgeek.com');

  define('HTTPS_CATALOG_SERVER', 'https://www.bigmusicgeek.com');

  define('ENABLE_SSL_CATALOG', 'true');

  define('DIR_FS_DOCUMENT_ROOT', '/home/bigmus5/public_html/shop/');

  define('DIR_WS_ADMIN', '/shop/admin/');

  define('DIR_WS_HTTPS_ADMIN', '/shop/admin/');

  define('DIR_FS_ADMIN', '/home/bigmus5/public_html/shop/admin/');

  define('DIR_WS_CATALOG', '/shop/');

  define('DIR_WS_HTTPS_CATALOG', '/shop/');

  define('DIR_FS_CATALOG', '/home/bigmus5/public_html/shop/');

  define('DIR_WS_IMAGES', 'images/');

  define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

  define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');

  define('DIR_WS_INCLUDES', 'includes/');

  define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

  define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

  define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

  define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

  define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

  define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');

  define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');

  define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');

  define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');

  define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

  define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

  define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

  define('DB_SERVER', 'localhost');

  define('DB_SERVER_USERNAME', 'XXXXXXXXXX');

  define('DB_SERVER_PASSWORD', ''XXXXXXXXXX');');

  define('DB_DATABASE', ''XXXXXXXXXX');');

  define('USE_PCONNECT', 'false');

  define('STORE_SESSIONS', 'mysql');

  define('CFG_TIME_ZONE', 'UTC');

?>

Share this post


Link to post
Share on other sites

So what is your real path to your shop and it's admin? you look to have defined several diferent paths in this config file!! your redirects are failing.

Point to correct path for shop in all sections of confing. and fix your redirects.

"The page isn't redirecting properly"

oh and change your admin folder to somthing other than admin unless you want to be hacked!!


 

Share this post


Link to post
Share on other sites

Lots of things could have gone wrong. Did you move to a different server and not update your .htaccess file's redirections and rewrites, especially if file paths (directories) changed? Did someone update .htaccess and botch the job ?


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get (stable) Frozen or (unstable) Edge. See also the naming convention and the latest community-supported responsive "Edge" release

Share this post


Link to post
Share on other sites
10 hours ago, TheDukeOfHurl said:

define('HTTP_COOKIE_PATH', '/catalog/admin');

The catalog directory doesn't exist in your shop so this is wrong. I suggest making the following changes:

define('HTTP_COOKIE_PATH', ''); 
define('HTTPS_COOKIE_PATH', ''); 


define('DIR_FS_DOCUMENT_ROOT', '/home/bigmus5/public_html/shop');

Also, as Zahid mentioned, it is a mistake to have your admin named admin.

And if you visit the shop itself you will see it doesn't display properly so there are problems there too.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×