Jump to content
Latest News: (loading..)
Sign in to follow this  
JcMagpie

Support thread for JcM Gallery with popover CE

Recommended Posts

A simple add-on to let you replace stock gallery with on that dynamically adds information popover on hover on your product info page.

Again totally standalone with no core code change. Simply copy all files of the into relevant sections and go to admin modules /content and install.

Has been tested on CE BS4 and CE BS3

image.png.b571ff051ec75b2123eb358f1f41e241.png


 

Share this post


Link to post
Share on other sites

Hello Zahid @JcMagpie,

I try this great addon, but it turns out that I have a version of OSC before Frozen and therefore the gallery appears twice and the images are duplicated.

It will be that this addon is only for Frozen?

regards

Valqui


I'm using oscommerce Edge v2.3.4.1

Get here the latest osCommerce Online Merchant Community Bootstrap Edition v2.3.4.1 CE

Share this post


Link to post
Share on other sites

😊 Gallery is not modular in any version, it is the modular product_info page that is required. Simply turn off the stock gallery and install this and turn on. Un less you are working on a new site your site is already using modular product_info or you would not have been able to install the other add-on's .


 

Share this post


Link to post
Share on other sites

What I'm trying to do is put the "Gallery with Popover" in the upper right corner like this in your image.

I have no way to turn off that gallery in the upper right corner.

 

Maybe I'm misunderstanding the purpose of this addon ??? I expected the Popover to appear in the gallery in the upper right corner, as in the image you upload.

 

image.thumb.jpg.2f1451b1c883acb60b1453785e6ff09f.jpg 


I'm using oscommerce Edge v2.3.4.1

Get here the latest osCommerce Online Merchant Community Bootstrap Edition v2.3.4.1 CE

Share this post


Link to post
Share on other sites

My version of EDGE is older than frozen.

In frozen in the product_info the galaria, price, name ... are modular. In my version I can add modules but only below that information.

Apparently for this addon to work I will need to make changes in the code or update to Frozen (what I do not plan to do for now, after the effort that took me to create this site haha)

Likewise, it is an excellent addon!

Edited by valquiria23

I'm using oscommerce Edge v2.3.4.1

Get here the latest osCommerce Online Merchant Community Bootstrap Edition v2.3.4.1 CE

Share this post


Link to post
Share on other sites

I'm not sure as it's been sometime since I worked on the old EDGE but I think it's a simple change. Rename your old catalog/product_info.php and add the new CE product_info.php and you will have modular product info page. Then simply add the new modules like the add-ons and turn on.

Edited by JcMagpie

 

Share this post


Link to post
Share on other sites
On 11/7/2018 at 1:26 PM, JcMagpie said:

Rename your old catalog/product_info.php and add the new CE product_info.php and you will have modular product info page. Then simply add the new modules like the add-ons and turn on.

Hi @JcMagpie Zahid, I'm going to try changing the catalog/product_info.php to Frozen. I hope it does not be complicate ..... 

Later I tell you, as it turned out. Thank you very much for your support

Best regards

Valqui

Edited by valquiria23

I'm using oscommerce Edge v2.3.4.1

Get here the latest osCommerce Online Merchant Community Bootstrap Edition v2.3.4.1 CE

Share this post


Link to post
Share on other sites

Hello Zahid, @JcMagpie,how are you?

The addon works perfectly, but the only thing that does not show is the price.
Could you check it please?

Best regards.

 

Valqui

Edited by valquiria23

I'm using oscommerce Edge v2.3.4.1

Get here the latest osCommerce Online Merchant Community Bootstrap Edition v2.3.4.1 CE

Share this post


Link to post
Share on other sites

Have checked and it's working fine on test site, check which version you are using and download and instal latest version.

image.png.f730f30b73504ebecc4826ce849e8939.png

 

Even old version is working fine on BS3 test site

image.png.e5673fbe980e5d11b70020c6d4c8f00d.png


 

Share this post


Link to post
Share on other sites

You code for price is missing or messed up,

<div class="col-sm-4 cm-pi-gallery-popover">
    <a class="popup" onmouseover="myFunction2()"><span class="popuptext" id="myPopup3" >
    
    Nombre:&nbsp;Sierra Cortadora Ceramica Gladiator Pro CC708/1 790x390mm<br>
      Modelo:&nbsp;CC708/1<br>
      En Stock:&nbsp;1&nbsp;unidades<br>
      Precio:&nbsp;      <span class="productPrice"></span>          
      </span>

 

 


 

Share this post


Link to post
Share on other sites

@JcMagpie

these are the first 10 lines of the module:

<div class="col-sm-<?php echo $content_width; ?> cm-pi-gallery-popover">
    <a class="popup" onmouseover="myFunction2()"><span class="popuptext" id="myPopup3" >
    
    <?php echo 'Nombre:&nbsp;'.$products_name; ?><br>
      <?php echo 'Modelo:&nbsp;'.$products_model; ?><br>
      <?php echo 'En Stock:&nbsp;'. $products_quantity . '&nbsp;unidades'; ?><br>
      <?php echo 'Precio:&nbsp;'; ?>
      <?php echo (tep_not_null($specials_price)) ? sprintf(MODULE_CONTENT_PI_PRICE_DISPLAY_SPECIAL, $specials_price, $products_price) : sprintf(MODULE_CONTENT_PI_PRICE_DISPLAY, $products_price); ?>
          
      </span>


I'm using oscommerce Edge v2.3.4.1

Get here the latest osCommerce Online Merchant Community Bootstrap Edition v2.3.4.1 CE

Share this post


Link to post
Share on other sites

Ok look's like last update was corrupted some how! Have uploaded again as V1.2 uninstall and remove all old files down load new files and install again.


 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×