Jump to content
Latest News: (loading..)

Recommended Posts

Posted (edited)

When I change language on the tabs to swedish language then it also changes to swedish on the tabs on the english page.
I want the swedish language on the tabs  for swedish pages and english language on the tabs for english pages.
How may I solve this issue?

Edited by fantomen

Share this post


Link to post
Share on other sites
Posted (edited)
10 hours ago, fantomen said:

How may I change the language to swedish language on all the tabs?

Not posiable with current tabs. It's on a long list of thngs to do. You will have noticed I have been updating the ones people have asked for so this will join that list and when I have time it will be updated. Or you can do it your self, its not hard it's simple case of adding a language file and moving the defines from the class to the language file. This will mean that you then have to edit a language file in order make changes rather than simplely in the admin module edit. This should only be affecting new content such as tab names and such. All stock content is still mulitlingual!

Or you can support the CE software and buy Burt's 28days as I belive it has tabs in it.

Edited by JcMagpie

 

Share this post


Link to post
Share on other sites
10 hours ago, fantomen said:

How may I change the language to swedish language on all the tabs?

lso I think you are a bit confused! osC is not magic! it will not auto create language files 😊 Yes the tabs at the moment are single language only as I made them for my site but all stock data used is stock osC and it's up to you to add the alternative text.

This is you english page showing Swedish stock text

image.png.68a7e7c5de40276952d043a6b0f53328.png

This is your Swedish page again showing Sweedish stock text. Ig noring the tabs ( thats all down to me :)I can only assume yo have not added english text in you products in admin? To use osC as muliligual you have to add text in admin for every language you use. Also every time you change a product info you must make that change to all languages. which is a real pain in the butt!

Hence I recommend using the Google Translate add-on.  https://apps.oscommerce.com/mYuUD&info-box-with-google-translate-bs4

image.png.abfa36f61aeba874bcc779aba8c43a05.png


 

Share this post


Link to post
Share on other sites

My site is still under development. I have not added product descriptions in english language yet
I have already understood that your module was not multilanguage module.
I hope that you or some other developer can make this module multilanguage compatibel because I belive I am not alone using your module with tabs and would like to translate the text in the tabs to other languages than english language?
It is a great module and for my need even better if it gets multilanguage compatible.

Share this post


Link to post
Share on other sites

Normally I always copy the english language folder and then rename it to swedish but in this module you have made this is not that easy.

I have installed JcM Product info description_tabs CE version from 9th January 2019
So how do I add my language to this module you have made?

In catalog-includes-languages-english-modules-content-product_info
I can see this file in the folder product_info:
cm_pi_description_tabs

And this is how it looks like when I open this file:
----------------------------------------------------------------------------------------------

<?php
/*
  Copyright (c) 2018, Z Iqbal based on code Copyright (c) 2018, G Burton
  All rights reserved.

  Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.

  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

  3. Neither the name of the copyright holder nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
*/

  const MODULE_CONTENT_PI_DESCRIPTION_TABS_TITLE       = 'Description with Tabs';
  const MODULE_CONTENT_PI_DESCRIPTION_TABS_DESCRIPTION = 'Shows the Products Description with Tabs on the product_info Page.';

--------------------------------------------------------------------------------------------

Just changing this text in this file to swedish language does not help me because I need the TABS in swedish language on the swedish page.
 I belive every person who lives in a country that english is not the main language would like to have the tabs in their own countrys language?
So if you guide me how I can change the tabs text to swedish language on the swedish page and so that the tabs in english language remain on the english page I am very interested to try to do this.

Share this post


Link to post
Share on other sites

Have been updated to version 1.3 to make them multilingual.

I am not going to update any other version of this so if you need multilingual then turn off curent version and uninstall module and the deleat files. Then simply copy over new files , install in admin and setup.

For those who are using these but have mofified the code! well it's up to you to compare the changes and update if needed.


 

Share this post


Link to post
Share on other sites
Posted (edited)

I have now succeded to uninstall this module.

Now I will try to install your new multilanguage module.

Edited by fantomen
just updating

Share this post


Link to post
Share on other sites

I am using this module but stripped out the tabs I didn't want. Which included the video tab

Wondering if the videos are tied to the Product Model the same as the manuals and limited to only one video or is it possible to add multiple videos in one tab.

Being able to add multiple videos in a tab would eliminate a lot of dead space in product info if adding them inline with the product description with a <div> tag.

Would be nice to have one tab and use say:

1_VVID_1
1_VVID_2
1_VVID_3
1_VVID_4

Where 1 is the product and being able to add multiple videos for that product.

 

 

Share this post


Link to post
Share on other sites
Posted (edited)

They are linked to Model number to help link them to the product beeing displayed as they are not in the db , but you can have as many as you like just edit the existing code to add more. I belive I limited it to 2 for all pdf and videos but that was just to keep it simple.

This add-on has been updated since you downloaded it. The example below shows the latest. The tabs videos or manuals will only show on products that have one.

https://chilleddisplays.co.uk/product_info.php/products_id/43

Edited by JcMagpie

 

Share this post


Link to post
Share on other sites

Thanks had a look at your demo/play site.

Like the changes, looks like the example had no manual so no tab shown.

Going to strip the code out that I need and upgrade so unused tabs won't show.

Also like the Product Social just below the carousel, was looking for an add-on but the only one I saw was the AddThis add-on where you needed create an account.

Thanks, that is an awesome upgrade to an already great addon!

 

 

 

Share this post


Link to post
Share on other sites
8 hours ago, Dnj1964 said:

I saw was the AddThis add-on where you needed create an account

https://apps.oscommerce.com/ZxuJW&amp;jcm-product-info-share-or-contact-v1-0&amp;p=2

I take it you are refering to these, They are like any other social link, you and the user need to have a relavent account. The lower 3 are simply your contact links.

image.png.8b877f2654774f91a598d3099109227c.png

Again you can set it up for any you wish in admin show none or as many of the 9 you like, They can be any you choose it's totaly flexable.

image.png.e320f52dbfa506a62c5b2ee950b61b13.png


 

Share this post


Link to post
Share on other sites
Posted (edited)

Updated to V1.4 to allow 2 additional videos from you-tube or other video servers to be displayed, again will only show if the files exist.

These are not in database but file driven. A sample file has been included.

image.png.bd7daeb310e47eed9d5a51045982f94d.png

 

Edited by JcMagpie

 

Share this post


Link to post
Share on other sites
Posted (edited)

Broken plugin at this date 10-04-2019 for (BS4 edge) as Burt did Remove TABLE_ DB definitions on GitHub

Also {Two bugs on Github, "Welcome on " instead of Welcome to

And at above date Bootstrap files in "ext" directory are not BS4(current) }

Jc is this a stand alone or does it require any other module?

 

Edited by MyBookShop

Share this post


Link to post
Share on other sites

Hi Mark,

It's stand alone.

I have no control over chnages to BS4 so BS4 code is good as of first issues of BS4, which should be the same as BS3 Frozen but with BS4 applied 😊 if that makes sence.

I have no plans to keep updating BS4 code as it coud change everyday! So if you decide to use BS4 edge then it's up to you to make any updates required.

Oh and one final issue all my product_info add-ons are for moduler product info pages. I know a few people have installed on pre frozen without moduler product info and then complain that it's not displaying corectly so just be aware of this.


 

Share this post


Link to post
Share on other sites

Anyone using BS4 versions of my add-on will need to have the original first version of the CE BS4 software. In making the BS4 veriants of the add-on's I have only used this initial version for testing and have taken it as CE BS4 Frozen. If you dont have a copy then you can download one from the test site.

https://chilleddisplays.co.uk/product_info.php/cPath/26/products_id/57

The BS4 add-on's will NOT work with BS4 EDGE from github or any other version.

Please dont ask for these to be updated to edge as it's imposaible to keep updating add-on's as edge is constantly changing.


 

Share this post


Link to post
Share on other sites
On 4/10/2019 at 11:27 AM, MyBookShop said:

Broken plugin at this date 10-04-2019 for (BS4 edge) as Burt did Remove TABLE_ DB definitions on GitHub

It's more than just the tables, you will have to check and fix all changes that affect the add-on, With tabs as well as tables the review code was borken, with these to parts fixed tabs work as they should even on edge! Well that is untill the next change is made 😊.

you can see them working on the Edge test site.

https://www.jcmagpie.com/product_info.php?cPath=3_12&amp;products_id=19

image.thumb.png.1b4a19f668f0aa3a775d9cdce12f4f8c.png


 

Share this post


Link to post
Share on other sites
Posted (edited)

I downloaded the site from yours as above, If there is no manufacturer input for the Item offered for sale the tabs don't appear. You should definitely put that in the (Installation Help File) I scratched my head forever on that.

Yes its in the forums. :)

Also small typo in manual :-  To modify your own product_infp.php file there is a small change to can make.

Installed and working :) thankyou.

Edited by MyBookShop

Share this post


Link to post
Share on other sites

Gidday! again. Ok after much frustration I have finally narrowed down my issue.

I use this Zone SQL for my site: https://apps.oscommerce.com/wqBh5&amp;australian-zones&amp;c=zones

The moment I run the SQL, the Product Description dis-appears. Leaving the coloured Tabs still working. Just no Product description.

This is a completely fresh install using only this module and then Australian Zones. Oscommerce Downloaded from Chiilled Displays link you gave me.

:) ??

 

I did notice that a fresh install  without this module and after running the zone SQL with the stock Product Info, if i deleted the USD in localization - currencies and just left AUD then the description also disappeared on the  Product info page. But if I added back USD it re-appeared. (if that helps).

(I know its probably the zone SQL but I'm lost, I want the features but I need localization.)

Edited by MyBookShop

Share this post


Link to post
Share on other sites


[proxy_fcgi:error] [pid 17316] [client ..........] AH01071: Got error 'PHP message: PHP Warning:  Use of undefined constant MODULE_CONTENT_PRODUCT_INFO_REVIEWS_CONTENT_LIMIT - assum$
 


I have these errors in log

Share this post


Link to post
Share on other sites
2 hours ago, MyBookShop said:

(I know its probably the zone SQL but I'm lost,

Sorry no idea as I have never used that add-on, All I can say is looking at the app store it's not BS version.


 

Share this post


Link to post
Share on other sites
1 hour ago, MyBookShop said:

I have these errors in log

Nothing to do with add-on, check which php version your running. Also it's not a error just a warning, you will get lot's of these depending on which php version you run.

This is the add-on in a clean BS4 Edge install running php 7.2 and as you can see no errors are reported.

Feel free to go check it out, https://www.jcmagpie.com/product_info.php?cPath=3_12&products_id=19

image.thumb.png.2a1c23cc06c2c2ec61d06eead40fbd22.png


 

Share this post


Link to post
Share on other sites
2 hours ago, MyBookShop said:


[proxy_fcgi:error] [pid 17316] [client ..........] AH01071: Got error 'PHP message: PHP Warning:  Use of undefined constant MODULE_CONTENT_PRODUCT_INFO_REVIEWS_CONTENT_LIMIT - assum$
 


I have these errors in log

To fix this,

In file public_html/includes/modules/content/product_info/cm_pi_description_tabs_select.php
find line 44, and add   '   around  MODULE_CONTENT_PRODUCT_INFO_REVIEWS_CONTENT_LIMIT
as shown below.

$review_query = tep_db_query("select SUBSTRING_INDEX(rd.reviews_text, ' ', 20) as reviews_text, r.reviews_rating, r.reviews_id, r.customers_name, r.date_added, r.reviews_read, p.products_id, p.products_price, p.products_tax_class_id, p.products_image, p.products_model, pd.products_name from reviews r, reviews_description rd, products p, products_description pd where r.products_id = '" . (int)$_GET['products_id'] . "' and r.reviews_id = rd.reviews_id and rd.languages_id = '" . (int)$languages_id . "' and r.products_id = p.products_id and p.products_status = '1' and r.reviews_status = '1' and p.products_id = pd.products_id and pd.language_id = '". (int)$languages_id . "' order by r.reviews_rating DESC limit " . (int)'MODULE_CONTENT_PRODUCT_INFO_REVIEWS_CONTENT_LIMIT');
 

 


 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×