Jump to content

Recommended Posts

@René H4

If you search through the forum, you will find a lot of threads pertaining to PHP v7.2 support. PHP v7.2 is *much* more strict that prior versions, and many people are seeing warnings flag up all over the place. Do note that these are warnings, and not errors.

AFAIK, 'Frozen' is not 100% compatible with PHP v7.2, and many (if not most) of the add-ons out there are also not 100% compatible. 'Edge' *may* be, but since 'Edge' is constantly changing, it may not be the best choice for a live shop.

If you wish to deploy 'Frozen', I would suggest that you either roll back to PHP v7.1, or prepare to address any warnings or errors that arise using PHP v7.2. If the latter, you could also contribute back to the community with a list of the errors you find, and your solutions to them.

HTH

M


Get the latest Responsive osCommerce CE (community edition) here .

Share this post


Link to post
Share on other sites

I cannot give you the technical details, but my shop has been running 7.2 for a year now.

I have seen no warnings or errormessages, but they may be filtered somewhere ( I did not setup the bas myself).

 

Share this post


Link to post
Share on other sites

Bootstrap 3 will be around for years - no point overthinking that, so forget it. 

The main "problem" will be upgrade php. Some people say php7.2 is working fine, others report it is not working fine.

At the end of the 28d, dependant on support thereof, I hope to have gotten enough time in hand to get the following done and complete;

  • make sure shop and admin are ready for 7.2 (at the very least, possibly 7.3 if I can swing it)
    -> no warnings and no errors
  • product class
    -> rework relevant modules to use it

But as with all things, one step at a time, and right now that step is trying to get some time in hand to actually do "stuff".


Help shape the future of Phoenix; join the Phoenix Club

Share this post


Link to post
Share on other sites
On 12/15/2018 at 12:58 PM, burt said:

I made that for the Demo.  It will be available shortly in my next 28d package.

Hi there.

where can we get that package?

Best regards

Share this post


Link to post
Share on other sites

shopping_cart.php

line 117: btn-xs is deprecated BS3, and has no effect, so can just be removed.

line 138/144/186: add role="alert"

fa is deprecated in font-awesome 5. fa needs to be replaced with either fas (for solid icons) or far (for regular icons). 

Share this post


Link to post
Share on other sites

Using github (even just the "issues" reporter), makes it a lot easier for me to not miss stuff.


Help shape the future of Phoenix; join the Phoenix Club

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×