Jump to content

Recommended Posts

Code

https://github.com/gburton/Responsive-osCommerce

Demo

https://template.me.uk/frozen2bs4/index.php

Reminders

  1. Frozen is still frozen (at bootstrap v3)
  2. Admin is still not bootstrapped

This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites
59 minutes ago, Stephan Gebbers said:

How about compatibility of Modules that work with 2.3.4.1 BS Frozen (Bootstrap 3) ?

Modules and custom code etc would need to be changed from BSv3 to BSv4.

It's not difficult (though some parts are more "interesting" to code than others).

Edited by burt

This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

I personally would;

  • BSv4 is much leaner than BSv3 - means site will load quicker
  • BSv4 also has other changes to better accommodate more devices

However, for anyone who has no idea about code it might not be worthwhile as;

  • at this point, there are no modules for it (other than the ones I have built)
  • I do not know if anyone on this forum has much knowledge of BSv4 ((eg) for answering support questions)

All that said;

  • it is broadly similar to Frozen, and anyone who wants to get into the codebase will see that.

This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

Yes there are people with knowledge of BS4.

The main advantage of BS4 over BS3 is the incorporation of flexbox. I don't see a lot of that being used in the template on the demo site. Plus overall, BS4 is a much refined framework compared to BS3.

 

Share this post


Link to post
Share on other sites

Main class chnages between BS3 and BS4 😊 Plenty of people have already applied BS4 to osC.

Main question is if you have already built your site and its up and running with the add-on's working fine, do you really want to go through all that again just for BS4?

But if you are just starting out and don't need any add-ons then why not you might as well.

 

Bootstrap 3.x Bootstrap 4
.col-*-offset-* .offset-*
.col-*-push-* .order-*-2
.col-*-pull-* .order-*-1
.panel .card
.panel-heading .card-header
.panel-title .card-title
.panel-body .card-body
.panel-footer .card-footer
.panel-primary .card.bg-primary.text-white
.panel-success .card.bg-success.text-white
.panel-info .card.text-white.bg-info
.panel-warning .card.bg-warning
.panel-danger .card.bg-danger.text-white
.well .card.card-body
.thumbnail .card.card-body
.list-inline > li .list-inline-item
.dropdown-menu > li .dropdown-item
.nav navbar > li .nav-item
.nav navbar > li > a .nav-link
.navbar-right .ml-auto
.navbar-btn .nav-item
.navbar-fixed-top .fixed-top
.nav-stacked .flex-column
.btn-default .btn-secondary
.img-responsive .img-fluid
.img-circle .rounded-circle
.img-rounded .rounded
.form-horizontal (removed)
.radio .form-check
.checkbox .form-check
.input-lg .form-control-lg
.input-sm .form-control-sm
.control-label .col-form-label
.table-condensed .table-sm
.pagination > li .page-item
.pagination > li > a .page-link
.item .carousel-item
.help-block .form-text
.pull-right .float-right
.pull-left .float-left
.center-block .mx-auto.d-block
.hidden-xs .d-none
.hidden-sm .d-sm-none
.hidden-md .d-md-none
.hidden-lg .d-lg-none
.visible-xs .d-block.d-sm-none
.visible-sm .d-none.d-sm-block.d-md-none
.visible-md .d-none.d-md-block.d-lg-none
.visible-lg .d-none.d-lg-block.d-xl-none
.label .badge
.badge .badge.badge-pill

 

Share this post


Link to post
Share on other sites

In addition to the multiple changes made to accommodate BSv4, I have also changed a few other bits;

  • Content Module - Footer - Links
    Now easier to add in links
  • Box Module - Information
    Ditto
  • Breadcrumb
    Separate logic and display

How are we finding the new osCommerce?


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites
14 minutes ago, burt said:

How are we finding the new osCommerce?

I can only find it on GitHub.😇


I am not a professional webmaster or PHP coder by background or training but I will try to help as best I can.

I remember what it was like when I first started with osC. It can be overwhelming.

However, I strongly recommend considering hiring a professional for extensive site modifications, site cleaning, etc.

There are several good pros here on osCommerce. Look around, you'll figure out who they are.

Share this post


Link to post
Share on other sites
1 hour ago, burt said:

I have also changed a few other bits

I noticed that the header navbar has changed too. More options for background and screensize

Categoriebox can set level of subcategories to show, inside the code,  nice.

A few of my addon modules need to be updated for bs4  Needs some work but until now not difficult to do.

its fast and adapts better to smaller screensizes ig tablet size.

Thanks @burt

 

 

 

 


:heart: osCommerce

I am using osCommerce CE Phoenix.

Get the latest Responsive osCommerce CE (community edition) here

 

Share this post


Link to post
Share on other sites

Anyone notice the all new shopping_cart layout ?

Old:

old.jpg.d1270b791c4273e23864f51ed688eb40.jpg

New:

new.jpg.932570422d71c5ee42bb973340865de4.jpg

Clearer and Easier.  Feedback from real customers has been overwhelmingly positive.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

Hi

I've been a loyal OsC user since it's MS2.2 version, which I had to update to 2.3.4 over a year ago due to my hosting no longer supporting that old version of PHP. I have the BS3 edition. The mobile version looks just as the screenshot posted in this thread, and It's up an running, and for the most part I've been able to work with it under a now-aging PHP v5.6. 

 How can I prepare myself (a non-coder) to migrate the site to 2.3.4.1 CE ? I do have some addons like min. purchase amount, and a custom payment gateway plugin.

It may not happen tomorrow, but I do need to work on an update plan.

Thanks!

 

 

 

Edited by Krisz1

Share this post


Link to post
Share on other sites
4 hours ago, Krisz1 said:

How can I prepare myself (a non-coder) to migrate the site to 2.3.4.1 CE ? I do have some addons like min. purchase amount, and a custom payment gateway plugin.

For the add ons you have and can't do without you may have to hire a pro to get them to where you want to be.

I tried keeping up with the updates to get to frozen, but too tedious so I saved my images, config settings, database, etc. Then downloaded Frozen installed that then imported was I saved.

A few hiccups to sort out but overall ended up getting there.

 

 

 

 


I am not a professional webmaster or PHP coder by background or training but I will try to help as best I can.

I remember what it was like when I first started with osC. It can be overwhelming.

However, I strongly recommend considering hiring a professional for extensive site modifications, site cleaning, etc.

There are several good pros here on osCommerce. Look around, you'll figure out who they are.

Share this post


Link to post
Share on other sites

Thanks Altoid.

Is the database structure the same?, More importantly, will current customers be able to login with their same credentials when importing the database?.. I would just import it from a backup in phpmyadmin...

 

Best,

 

Share this post


Link to post
Share on other sites
On 10/30/2018 at 4:37 PM, burt said:

How are we finding the new osCommerce?

Damn nice!

Btw: what is that header slide module you have on the test site?

 

Keep up the good work!

Share this post


Link to post
Share on other sites
On 12/13/2018 at 4:17 PM, Owl Sauron said:

Btw: what is that header slide module you have on the test site?

I made that for the Demo.  It will be available shortly in my next 28d package.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

I have been wondering what would be a point in HAVING to switch to a newer version?

Or can we remain using BS3 Frozen "till the end of times"?

 

Share this post


Link to post
Share on other sites
1 minute ago, honda4 said:

I have been wondering what would be a point in HAVING to switch to a newer version?

Or can we remain using BS3 Frozen "till the end of times"?

 

So far as I recall, Frozen is good for at least 7.1 and possibly 7.2.

As Frozen is literally "frozen" (ie, no more code changes)...when (eg) php8 comes along...things might break, but that is true of all software.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest Responsive osCommerce CE (community edition) here

Share this post


Link to post
Share on other sites

Hi Gary, thanks for the answer. 

My site is running 7.2.14. Which is I think the latest. So as long as ths version is supported there is no need for concerns?

It's not a matter of Bootstrap version going out of support?

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×