Jump to content
Latest News: (loading..)
Sign in to follow this  
makeit4me

Use of undefined constant FILENAME_MODULES - assumed 'FILENAME_MODULES' (this will throw an Error in a future version of PHP) in ../includes/modules/payment/paypal_express.php on line 699

Recommended Posts

 

I moved to a new server with PHP Version 7.2.9 and MySQL 5.5.5-10.2.17-MariaDB

I completely reinstalled the app, including created brand new database. after configuring PayPay Express, after adding item to cart to test, following error occurs:

Quote

 

Use of undefined constant FILENAME_MODULES - assumed 'FILENAME_MODULES' (this will throw an Error in a future version of PHP) in ../includes/modules/payment/paypal_express.php on line 699


 

all else works fine w/o errors, except : payment modules and Banners, which results in

 

Quote

 

Warning: count(): Parameter must be an array or an object that implements Countable in ../includes/classes/phplot.php on line 1324


 

warning message line repeats for every single banner.  and received error before even adding my old data back. errors occur with new, fresh install with or w/o any additional data added.

and upon new install, I can't even install a payment module. after clicking "Install Module" button, the follow error is displayed for every module available, with the modules to install at the end of the errors

Quote

Warning: Use of undefined constant MODULE_PAYMENT_MODULE_NAME

after install,
 

Quote

 

Warning: Cannot modify header information - headers already sent by (output started at ../includes/modules/payment/authorizenet_cc_aim.php:23) in ../includes/functions/general.php on line 38


 

with all else blank -- no side menu, or anything else, just blank page and you have to manually reload OsCommerce Admin.

are there fixes for these issues? I searched for the error message(s) in this forum, but lots of discussions, not actual answers. clearly this is a developer issue as the product isn't working "out of the box".

if there isn't, I guess I'll have to migrate site to WordPress and use one of their shopping carts, but I really like oscommerce and have used this personal store for over a decade.

thanks.

Share this post


Link to post
Share on other sites

../includes/modules/payment/paypal_express.php line 699:

      $test_url = tep_href_link(FILENAME_MODULES, 'set=payment&module=' . $this->code . '&action=install&subaction=conntest');

this is definitely a developer issue as this happens after install w/ reference to existing code, not anything added

 

Share this post


Link to post
Share on other sites
1 minute ago, ArtcoInc said:

@makeit4me

Which version of oaCommerce are you using?

M

I just downloaded the latest version osCommerce Online Merchant v2.3.4.1 but I see in your footer a link to download another version. how did I miss that when selecting download??

Share this post


Link to post
Share on other sites

I'm gonna wait until I see something official from development. in the meantime, I'll be migrating to another shopping cart option that can grow w/ php and mysql.

thanks

Share this post


Link to post
Share on other sites

Don't wait for a new official release of osCommerce. It's likely to never come (quite literally). Use the 2.3.4.1BS Edge/CE/Frozen for any new system, and if you're running anything older, be thinking about upgrading to this one.

Regarding the errors you reported, the new version (Edge) now hard codes a lot of file names and table names, rather than using defined constants. If you try to mix in old add-on code, you'll have to modify it manually to either define the constants (there is a "compatibility" add-on for that), or hard code the names. I don't know if that will fix the phplot.php error. The "headers already sent"  message will probably go away when you fix the other errors -- it's caused by an error message being sent to the browser "too early", before all the headers have been defined.

Edited by MrPhil

If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get the latest community-supported responsive "Edge" release

Share this post


Link to post
Share on other sites

@makeit4me

As @MrPhil said, the 'official' v2.3.4 (and v2.3.4.1 hot-patch) is very much out of date. The osCommerce project was lead by one person that has been absent for quite some time. In his absence, the "community" has continued with the development of osC. Unfortunately, that one missing person is the only one that can make this continued development an 'official' release.

The 'Community Edition' (also called osC-CE (for Community Edition), osC-BS (for Bootstrap, the platform it is based on), osC-Edge, osC-Final, and/or osC-Frozen. These are all different names for the same thing) is a big improvement over the last 'official' v2.3.4 release in a number of ways:

1) It is responsive. This means that it will adjust the screen layout depending on the size of the screen of your customer's device. This is very important in this day of mobile devices. The 'official' version is not responsive.

2) It will work with the newer version of PHP, the scripting language used in osC. As more and more hosts upgrade their servers to PHP 7.x, older versions of osC (including the 'official' version) will crash.

3) It is much more modular. This means that you can turn features on or off, change the layout, or even add new features, all without touching the core code.

You can find a link to the latest version of the Community Edition in my signature below.

Malcolm


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get the latest community-supported responsive "Edge" release here

Share this post


Link to post
Share on other sites

@ArtcoInc is it legal propagation? Sorry this off topic but I am new here and I see in every stream are talking about the members community version so I wonder why can not see "CE" on addons site opposit to read restrictions about non-oscommerce network contents here: https://forums.oscommerce.com/guidelines/
Why isnt found community edition in Apps Marketplace?
If I have a variant than I could propagate here as "forum version (FV)" in my sign?

Share this post


Link to post
Share on other sites

@tothcom

As I mentioned, the only person that can make these changes has been absent. So we, as the community, are doing what we can, with what is available to us.

osCommerce is an Open Source project. There have been a number of people/teams who have taken the osC source code and 'spun off' their own shopping carts. You may too, if you choose. However, you can not call yours "osCommerce".

M


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get the latest community-supported responsive "Edge" release here

Share this post


Link to post
Share on other sites
On 9/10/2018 at 7:29 PM, tothcom said:

I am new here 

Really?

On 9/10/2018 at 7:29 PM, tothcom said:

If I have a variant than I could propagate here as "forum version (FV)" in my sign?

It would be removed.


This is a signature that appears on all my posts.  
IF YOU MAKE A POST REQUESTING HELP...please state the exact version
of osCommerce that you are using. THANKS

 
Get the latest current code (community-supported responsive 2.3.4.1BS Edge) here

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×