Jump to content
Latest News: (loading..)
Peter M.

Problem add some products into basket

Recommended Posts

Hi ,

I have problem with adding products into basket on my web page www.stolicka-stol.sk

Some clients call me that they are not able to add products into basket. I have the same problem only with one product https://www.stolicka-stol.sk/lacne-70eur/drevena-stolicka-nancy-p-117.html

I expect that the problem is with cookie, so today I changed setting (in COOKIE_DOMAIN I added . before stolicka, COOKIE_PATH I added /) in config file, but it looks that this still doesn't work.

Current config file looks like that :

  define('HTTP_SERVER', 'https://www.stolicka-stol.sk');
  define('HTTPS_SERVER', 'https://www.stolicka-stol.sk');
  define('ENABLE_SSL', true);
  define('HTTP_COOKIE_DOMAIN', '.stolicka-stol.sk');
  define('HTTPS_COOKIE_DOMAIN', '.stolicka-stol.sk');
  define('HTTP_COOKIE_PATH', '/');
  define('HTTPS_COOKIE_PATH', '/');
  define('DIR_WS_HTTP_CATALOG', '/');
  define('DIR_WS_HTTPS_CATALOG', '/');
  define('DIR_WS_IMAGES', 'images/');
  define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
  define('DIR_WS_INCLUDES', 'includes/');
  define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
  define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
  define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
  define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

  define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');
  define('DIR_FS_CATALOG', '/nfsmnt/hosting2_2/e/0/e0a36d07-485a-487c-b2a5-ecda313f54fb/stolicka-stol.sk/web/');
  define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');
  define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

  define('DB_SERVER', 'xxx');
  define('DB_SERVER_USERNAME', 'xxx');
  define('DB_SERVER_PASSWORD', 'xxx');
  define('DB_DATABASE', 'xxx');
  define('USE_PCONNECT', 'false');
  define('STORE_SESSIONS', 'mysql');
  define('CFG_TIME_ZONE', 'Europe/Bratislava');

 

Can you look where can be a problem ?

 

I readed many topics on site, but I don't found solution.

Thanks, Peter

Share this post


Link to post
Share on other sites

Yor site is working fine! Just added the product you listed and many others to the basket with no problems. Clear the browser cache and try again.


 

Share this post


Link to post
Share on other sites

Work fine for me too. I add correctly the 3 in the basket.

My Firefox : 61.0.2 (x64).

Clear the cache, close Firefox and restart it. If the problem is allways here, perhaps it can be a FireFox Addon which make a bad thing ... ?


Live   : OsC 2.2, php 5.4 & UTF-8  |  Local : OsC 234BS php7.2 Edge for future shop

Share this post


Link to post
Share on other sites

Also try to clear the errors that are being reported for your site. These are reported by both chrome and Firefox. Firefox is complaining about the product you said you are having issues with.

image.thumb.png.8849a7ba2edc297dc3cec3e79e8ebe77.png

 

 

image.thumb.png.ac5e81a619245e40c922d90853e3bc9a.png


 

Share this post


Link to post
Share on other sites

In teplate_top.php I have :

<link href="//fonts.googleapis.com/css?family=Open+Sans:400,300,300italic,400italic,600italic,600,700,700italic,800,800italic&subset=latin,cyrillic-ext,greek-ext,latin-ext" rel="stylesheet" type="text/css">
<link href="//maxcdn.bootstrapcdn.com/font-awesome/4.2.0/css/font-awesome.min.css" rel="stylesheet">

 

When I changed it for

<link href="https://fonts.googleapis.com/css?family=Open+Sans:400,300,300italic,400italic,600italic,600,700,700italic,800,800italic&subset=latin,cyrillic-ext,greek-ext,latin-ext" rel="stylesheet" type="text/css">
<link href="https://maxcdn.bootstrapcdn.com/font-awesome/4.2.0/css/font-awesome.min.css" rel="stylesheet">

 

still the same error

Share this post


Link to post
Share on other sites

This can happen if you have it more than one bad link. It is still showing this and 3 other critical errors. You need to fix them all.

http://fonts.googleapis.com/css?family=Noto+Sans:400,700,400italic,700italic

ReferenceError: loadHeight is not defined

Content Security Policy: The page's settings observed the loading of a resource at self ("script-src"). A CSP report is being sent. Source: onclick attribute on A element. fastbutton

Content Security Policy: The page's settings observed the loading of a resource at self ("script-src"). A CSP report is being sent. Source: onclick attribute on A element. sharebutton


 

Share this post


Link to post
Share on other sites

If you require SSl on your site then you will have problems with mixed content you need to replace all http with https. Just a quick review of your site finds lots of issues.

 

Line 135:     ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    Line 150:         <div style='clear:both;height:59px;padding:0 15px 0 15px;position:relative;z-index:10000;text-align:center;'><a href="http://www.microsoft.com/windows/internet-explorer/default.aspx?ocid=ie6_countdown_bannercode"><img src="http://storage.ie6countdown.com/assets/100/images/banners/warning_bar_0000_us.jpg" border="0" height="42" width="820" alt="You are using an outdated browser. For a faster, safer browsing experience, upgrade for free today." /></a></div>
    Line 150:         <div style='clear:both;height:59px;padding:0 15px 0 15px;position:relative;z-index:10000;text-align:center;'><a href="http://www.microsoft.com/windows/internet-explorer/default.aspx?ocid=ie6_countdown_bannercode"><img src=http:"//storage.ie6countdown.com/assets/100/images/banners/warning_bar_0000_us.jpg" border="0" height="42" width="820" alt="You are using an outdated browser. For a faster, safer browsing experience, upgrade for free today." /></a></div>
    Line 523:                 loadingIcon: 'http://www.elevateweb.co.uk/spinner.gif'
    Line 579: </script> <a title="Facebook" href="https://www.facebook.com/share.php?u=https%3A%2F%2Fwww.stolicka-stol.sk%2Flacne-70eur%2Fdrevena-stolicka-nancy-p-117.html" target="_blank"><i class="fa fa-facebook"></i></a> <a title="twitter" href="http://twitter.com/home?status=https%3A%2F%2Fwww.stolicka-stol.sk%2Flacne-70eur%2Fdrevena-stolicka-nancy-p-117.html" target="_blank"><i class="fa fa-twitter"></i></a> <div class="g-plus" data-action="share" data-href="https://www.stolicka-stol.sk/lacne-70eur/drevena-stolicka-nancy-p-117.html" data-annotation="none" data-height="15" data-align="left"></div><script type="text/javascript">
    Line 608:                 loadingIcon: 'http://www.elevateweb.co.uk/spinner.gif'
    Line 661: document.write(decodeURI("%3Cscript id='pap_x2s6df8d' src='" + (("https:" == document.location.protocol) ? "https://" : "http://") +
    Line 686:             <div class="footer-boxes row"><div class="footer-box col-xs-4">    <h4>Váš účet</h4>    <ul>   <li><a href="https://www.stolicka-stol.sk/shipping.


 

Share this post


Link to post
Share on other sites

I changed all http to https, except

ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';

 

How I can remove error from apis.google.com  ?

Content Security Policy: The page's settings observed the loading of a resource at self ("script-src"). A CSP report is being sent. Source: onclick attribute on A element. fastbutton

Content Security Policy: The page's settings observed the loading of a resource at self ("script-src"). A CSP report is being sent. Source: onclick attribute on A element. sharebutton

Edited by Peter M.

Share this post


Link to post
Share on other sites

The button issue is a bit ore complex, It looks as if its complaining that you have defined that the script should be loded from a local resourse using (self) but infact is beeing loded from an unsecure external source. The problem is in the script from what I can see it looks like this part, but please check before making any changes.

 

</style><svg version="1.1" xmlns="http://www.w3.org/2000/svg" preserveAspectRatio="xMidYMid meet" width="22px" height="13px" viewBox="-6 -4 44 26" class="ozWidgetRioButtonSvg_ ozWidgetRioButtonPlusOne_"><path d="M23 5h-2v3h-3v2h3v3h2v-3h3V8h-3V5z"></path><path d="M8.2 8.2v3.3h4.4c-.3 1.9-2 3.3-4.4 3.3-2.7 0-4.8-2.3-4.8-4.9S5.5 5 8.2 5c1.2 0 2.3.4 3.1 1.2l2.4-2.4c-1.4-1.3-3.3-2.1-5.5-2.1C3.7 1.7 0 5.4 0 9.8S3.7 18 8.2 18c4.7 0 7.8-3.4 7.8-8 0-.6-.1-1.2-.2-1.8H8.2z"></path></svg><div class="ozWidgetRioButtonPlusOneSvgFallback_ ozWidgetRioButtonPlusOneSvgFallback_-13"></div></div></div></div></div></span></div></a></div><script nonce="BGSKbOWLb7WL6XGRdgzCjiWmep4">window.__GOOGLEAPIS = {googleapis: {versions: {pos: 'v1'}}};window['__P1_BASEURL'] = 'https:\/\/apis.google.com\/se\/0\/'; window['__P1_LOCALE'] = 'sk'; var OZ_domReady = 1;
      var _DumpException = function(e) {

 

Share this post


Link to post
Share on other sites

The other error 😊 I’m afraid I can not help with as it something to do with one of your attribute functions, This link may help https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Errors/Not_defined

ReferenceError: loadHeight is not defined


$('.productThumbsWrapperAcessories').css({height: loadHeight});

productThumbsHeightAcessories();


 

Share this post


Link to post
Share on other sites

ReferenceError: loadHeight is not defined  :)

 

Declaration is there one line above :)

                var loadHeight = $('#productThumbs > li').height();
                var showAllHeight = $('#productThumbs').height();
                $('.productThumbsWrapper').css({height: loadHeight});

Probably I'm tired and I don't see something similar

 

Thanks a lot for all, Zahid

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×