Jump to content
Latest News: (loading..)
zefeena

New install - can't access admin

Recommended Posts

I have just done a new install, and everything seems okay except I cannot log onto the admin.   I tried the php admin reset password but not with any joy!  Can anyone suggest why its not working?

I live in an internet blackspot - could this be causing a problem - i.e not updated the password. 

I also notice every time I try to go to the login page it flashes up in the browser with 'website not secure' in red.  I have set a password on my admin folder(after not getting in the admin as I thought maybe the insecure bit was the problem), and changed the admin name.

Totally stuck now.  Desperately need help - this is an obstacle I never seem to be Abel to overcome!!

thank you


Running a botched up version of  osCommerce Online Merchant v2.3.4 bootstrap with the dresscode theme installed, numerous add-ons, terrible coding, terrible website, but will have to make do until I have made up for my losses and can risk shutting down for a couple of weeks while I start all over again. - I did not install my program but am endeavouring to fix it with your help.

Share this post


Link to post
Share on other sites

Well that won't help as it will just happen again.  I wrote down the password originally, so I know that I was inputting the correct details.  The error is not in the install process., so repeating it is pointless.

 


Running a botched up version of  osCommerce Online Merchant v2.3.4 bootstrap with the dresscode theme installed, numerous add-ons, terrible coding, terrible website, but will have to make do until I have made up for my losses and can risk shutting down for a couple of weeks while I start all over again. - I did not install my program but am endeavouring to fix it with your help.

Share this post


Link to post
Share on other sites

Yes it will, it is quite posiable that the install was messed up during instalation or the files you used to do the install did not unzip properly. You need to check thinks one step at a time.

 


 

Share this post


Link to post
Share on other sites

Well I went through the whole process again, and the same thing happens.  It won't let me into admin.  Odd thing about this red warning in the browser, and mostly when I input the user/password it just clears rather than actually failing as a login.  After several attempts I now get this error!  I am thinking this is all either to do with my impoverished internet connection, or safari, or the server security or something, rather than a dodgy install on my behalf.  1850322518_ScreenShot2018-08-23at22_09_59.png.e3b770661cf7b1866e4dd90bdd23193c.png


Running a botched up version of  osCommerce Online Merchant v2.3.4 bootstrap with the dresscode theme installed, numerous add-ons, terrible coding, terrible website, but will have to make do until I have made up for my losses and can risk shutting down for a couple of weeks while I start all over again. - I did not install my program but am endeavouring to fix it with your help.

Share this post


Link to post
Share on other sites

This is what it shows in the browser as soon as I go to enter my user/password details

467108317_ScreenShot2018-08-23at22_14_02.png.5e70f15232a07f6d7cf38cfa41fbcb9d.png


Running a botched up version of  osCommerce Online Merchant v2.3.4 bootstrap with the dresscode theme installed, numerous add-ons, terrible coding, terrible website, but will have to make do until I have made up for my losses and can risk shutting down for a couple of weeks while I start all over again. - I did not install my program but am endeavouring to fix it with your help.

Share this post


Link to post
Share on other sites

@zefeena

1) Are you running a SSL certificate on your site, either partially or entirely?

2) Do you know if your host is running a Linux or Windows server?

M


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get the latest community-supported responsive "Frozen" release here

Share this post


Link to post
Share on other sites

It seems I need to log in on an Https:// address but I'm currently set to a www.  address, how do I change it, as it automatically re-directs to www.  when I put in the https, and my browser is having none of it!


Running a botched up version of  osCommerce Online Merchant v2.3.4 bootstrap with the dresscode theme installed, numerous add-ons, terrible coding, terrible website, but will have to make do until I have made up for my losses and can risk shutting down for a couple of weeks while I start all over again. - I did not install my program but am endeavouring to fix it with your help.

Share this post


Link to post
Share on other sites

There is ssl installed.  But Mac has had an update and its this that seems to be stopping me getting through


Running a botched up version of  osCommerce Online Merchant v2.3.4 bootstrap with the dresscode theme installed, numerous add-ons, terrible coding, terrible website, but will have to make do until I have made up for my losses and can risk shutting down for a couple of weeks while I start all over again. - I did not install my program but am endeavouring to fix it with your help.

Share this post


Link to post
Share on other sites
10 hours ago, zefeena said:

It seems I need to log in on an Https:// address but I'm currently set to a www

Set this in you config files. At first I would turn off all redirects untill you have both admin and shop front working. When you know you have it all set up as you need you can introduce the redirects as required.

The rewrites should work with this,

RewriteEngine On
RewriteCond %{HTTPS} off

# this makes it a permanent redirect
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

 

config Should look like this for normall root store.

<?php
  define('HTTP_SERVER', 'https://www-somedomain-com');
  define('HTTPS_SERVER', 'https://www-somedomain-com');
  define('ENABLE_SSL', true);
  define('HTTP_COOKIE_DOMAIN', '');
  define('HTTPS_COOKIE_DOMAIN', '');
  define('HTTP_COOKIE_PATH', '/youradmin');
  define('HTTPS_COOKIE_PATH', '/youradmin');
  define('HTTP_CATALOG_SERVER', 'https://www-somedomain-com');
  define('HTTPS_CATALOG_SERVER', 'https://www-somedomain-com');
  define('ENABLE_SSL_CATALOG', 'false');
  define('DIR_FS_DOCUMENT_ROOT', '/home/somedomain/public_html/');
  define('DIR_WS_ADMIN', '/youradmin/');
  define('DIR_WS_HTTPS_ADMIN', '/youradmin/');
  define('DIR_FS_ADMIN', '/home/somedomain/public_html/youradmin/');
  define('DIR_WS_CATALOG', '/');
  define('DIR_WS_HTTPS_CATALOG', '/');
  define('DIR_FS_CATALOG', '/home/somedomain/public_html/');
  define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');
  define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');
  define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');
  define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');
  define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');
  define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');
  define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');
  define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

  define('DB_SERVER', 'www-somedomain-com');
  define('DB_SERVER_USERNAME', 'YourUsername');
  define('DB_SERVER_PASSWORD', 'YourPassword');
  define('DB_DATABASE', 'somedomain_store');
  define('USE_PCONNECT', 'false');
  define('STORE_SESSIONS', 'mysql');
  define('CFG_TIME_ZONE', 'Europe/London');
 
  ?>


 

Share this post


Link to post
Share on other sites

Issue for config.php files: do you want SSL (https) on all pages, or just critical ones? It's now considered best practice to use SSL on all pages, which you do by changing all "http://..." entries in the config.php files to "https://..." (and of course, SSL is installed and enabled). That includes those starting with HTTP_.

Issues for .htaccess: if you are using SSL on all pages, you should have a URL rewrite to take any incoming http: and redirect it (R=301) to https:. At the same time (only issue one redirect if at all possible), you should either force the use of www. in the domain name, or its absence.

When you say your address is "set to" www., that's a misunderstanding on your part. The default protocol for just typing in a URL starting with a domain name is http: (the browser adds it if you don't type it in, to help lazy people). It sounds like your existing .htaccess has a redirect from non-www to www, but it's coded to send it to http:. That needs to be fixed, or you may get a loop (too many redirects).


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get (stable) Frozen or (unstable) Edge. See also the naming convention and the latest community-supported responsive "Edge" release

Share this post


Link to post
Share on other sites

I did check all of the above, made a few changes, but still same problems -  nothing updates/saves when I change details in a catalogue and they disappear/reappear randomly when I click on other items!


Running a botched up version of  osCommerce Online Merchant v2.3.4 bootstrap with the dresscode theme installed, numerous add-ons, terrible coding, terrible website, but will have to make do until I have made up for my losses and can risk shutting down for a couple of weeks while I start all over again. - I did not install my program but am endeavouring to fix it with your help.

Share this post


Link to post
Share on other sites

With a few changes I got past the SSL issues, but the install is still corrupt it seems so unfortunately I think I'm going to have to scrap it until I can find someone who has a stable internet connection to do it for me.  We get beautiful country views here - but terrible internet! lol


Running a botched up version of  osCommerce Online Merchant v2.3.4 bootstrap with the dresscode theme installed, numerous add-ons, terrible coding, terrible website, but will have to make do until I have made up for my losses and can risk shutting down for a couple of weeks while I start all over again. - I did not install my program but am endeavouring to fix it with your help.

Share this post


Link to post
Share on other sites

@zefeena

Do you have success using your FTP program to move files on and off the server for your old store? Could you have something configures in your FTP program that is messing thing up when you try to upload your new store? Just a thought ...

M


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get the latest community-supported responsive "Frozen" release here

Share this post


Link to post
Share on other sites

I think the main problem is my internet.  It takes hours to transfer the files and the internet connection cannot remain stable for that length of time.  It is always on and off. I'm going to take my Mac to a friends on Saturday and have another go. 


Running a botched up version of  osCommerce Online Merchant v2.3.4 bootstrap with the dresscode theme installed, numerous add-ons, terrible coding, terrible website, but will have to make do until I have made up for my losses and can risk shutting down for a couple of weeks while I start all over again. - I did not install my program but am endeavouring to fix it with your help.

Share this post


Link to post
Share on other sites

"website not secure" is likely a reminder from your browser that you are using http: instead of https: to log into your site. As long as you have SSL installed (for https), you might as well make the entire site under SSL (all https). If you're already all-SSL, could this be a message from osCommerce? Can you tell which is which?

If you have poor Internet connectivity (frequent signal drops, etc.), you need to talk to your Internet supplier (ISP). Is this wireless or wired? If wireless, you may simply be in an area with poor signal. If there are others in the same boat, perhaps you could interest the provider in upgrading their network (i.e., it could be profitable for them). In the meantime, can you switch to DSL or cable modem?


If you are running the "official" osC 2.3.4 or 2.3.4.1 download, your installation is obsolete! Get (stable) Frozen or (unstable) Edge. See also the naming convention and the latest community-supported responsive "Edge" release

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×