Jump to content
porrier

contact_us_registered

Recommended Posts

Hallo!

Im alten Shop hatte ich das Modul contact_us_registered eingebaut. Gibt es das nicht mehr für die neue Version osCommerce Online Merchant v2.3.4?

Gibt es ein Modul, das auch diese Funktion bietet, dass nur angemeldete Benutzer anfragen können?

 

Grüße

Share this post


Link to post
Share on other sites

Hi, wie wärs damit ? 

 

if (!tep_session_is_registered('customer_id')) {
    $navigation->set_snapshot();
    tep_redirect(tep_href_link('login.php', '', 'SSL'));
  }

Share this post


Link to post
Share on other sites
vor 21 Stunden, Yepi1533005574 said:

Hi, wie wärs damit ? 

 

if (!tep_session_is_registered('customer_id')) {
    $navigation->set_snapshot();
    tep_redirect(tep_href_link('login.php', '', 'SSL'));
  }

Danke! Sagst Du mir auch noch, in welcher Zeile ich das einbauen soll? Kann leider kein php.

Grüße

Share this post


Link to post
Share on other sites
On ‎16‎.‎05‎.‎2018 at 23:27, Yepi1533005574 said:

Hi, wie wärs damit ? 

Bitte die Zeile mit dem Redirect der Vollständigkeit halber besser so notieren:

 tep_redirect(tep_href_link(FILENAME_LOGIN, '', 'SSL'));

 

Share this post


Link to post
Share on other sites
vor 11 Stunden, IngoPhisto said:

Bitte die Zeile mit dem Redirect der Vollständigkeit halber besser so notieren:


 tep_redirect(tep_href_link(FILENAME_LOGIN, '', 'SSL'));

 

Funktioniert nicht, bekomme einen 404.

Share this post


Link to post
Share on other sites
vor 3 Minuten, porrier said:

Funktioniert nicht, bekomme einen 404.

Ah, da waren wohl die Quotes bei FILENAME_LOGIN zuviel.

FILENAME_LOGIN
Edited by porrier

Share this post


Link to post
Share on other sites

Ich weiss nicht welche osC-Version du nutzt aber schau mal in includes ob du die Datei filenames.php hast. Wenn nicht dann meinen redirect:

if (!tep_session_is_registered('customer_id')) {
    $navigation->set_snapshot();
    tep_redirect(tep_href_link('login.php', '', 'SSL'));
  }

 

ansonsten den von Ingo

if (!tep_session_is_registered('customer_id')) {
    $navigation->set_snapshot();
    tep_redirect(tep_href_link(FILENAME_LOGIN, '', 'SSL'));
  }

Share this post


Link to post
Share on other sites
vor 15 Stunden, Yepi1533005574 said:

Ich weiss nicht welche osC-Version du nutzt aber schau mal in includes ob du die Datei filenames.php hast. Wenn nicht dann meinen redirect:

if (!tep_session_is_registered('customer_id')) {
    $navigation->set_snapshot();
    tep_redirect(tep_href_link('login.php', '', 'SSL'));
  }

 

ansonsten den von Ingo

if (!tep_session_is_registered('customer_id')) {
    $navigation->set_snapshot();
    tep_redirect(tep_href_link(FILENAME_LOGIN, '', 'SSL'));
  }

Es gibt die filenames.php in includes. Der redirect von Ingo funktioniert. Danke euch!

Share this post


Link to post
Share on other sites

×