Jump to content
Sign in to follow this  
MaxiDVD

[Contribution] HTML WYSIWYG Editor for Product Desc, MS1 2.2

Recommended Posts

What is HTML WYSIWYG Editor for Product Descriptions ?

 

htmlArea is a WYSIWYG (what you see is what you get) editor replacement for <textarea> - PRODUCT DESCRIPTIONS and CATEGORIES DESCRIPTIONS fields in osCommerce.

By adding a few simple lines of JavaScript to your categories.php and a MySQL database script via PHPMyAdmin, you can administer and replace the regular textarea description field [Multi-Lingual] with a rich text html editor that lets you do the following:

 

Insert hyperlinks and images.

Format text to be bold, italicized, or underlined.

Change the face, size, style and colour.

align Left, centre, or right-justify paragraphs.

Make bulleted or numbered lists.

Indent or un-indent paragraphs.

Linked Multi-lingual language translator.

Insert a horizontal line.

HTML is automatically inserted into your fields (no copying or pasting) this HTML editor actually replaces your old description fields.

View the raw HTML source of what your editing.

and much more...

 

If you want to see a live demo of this WYSIWYG Editor,

http://www.interactivetools.com/products/h...index.html#demo

 

This version is a smaller and more compact unit modified to suit osCommerce categories and description fields, with the extra ability to support multiple languages and changes to the size, colours, layout ect via your store /admin/

 

NOTE: Theres is a readme.htm file in the "htmlarea" folder, but as this contibution was based on external software

(not originally designed for osCommerce)I have had to make some modifications to the code for it to work with osCommerce MS1 2.2

so the readme.htm thats in that folder does not necessarily apply to this contribution, but it makes for a good

educating read if you have never used a WYSIWYG HTML EDITOR --> once this is installed you should get the hang of things quiet easy.

 

this is very expanadable in the sense you can add you own functions and buttons, This wisywig html editor has the lot! -> it lacks nothing!

 

Installed on OsCommerce MS1 2.2

 

1. System Requirements

----------------------------------------------------

- Internet Explorer 5.5 for Windows or above

 

I will add a direct link to the contibution download shortly after submitting this post.

 

Any questions will be answered in this forum.

 

Cheers Lee

Share this post


Link to post
Share on other sites

Hi !

 

I have installed this contribution but it don't work, there comes a link "HTML WYSIWYG Editor" and I can change settings but I can't see any editor in categories or products page except that usual textarea...

 

In install.txt there is this line: "By adding a few simple lines of JavaScript to your categories.php and application_top.php" and so on...

but there is no mention about modifying this application_top.php later...


Sammy 1001

Share this post


Link to post
Share on other sites

hello,

 

I have installed the contrib. I can't see html-editor in the article-treatment.

 

my script (head)

 

<!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN">

<html <?php echo HTML_PARAMS; ?>>

<head>

<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">

<title><?php echo TITLE; ?></title>

<link rel="stylesheet" type="text/css" href="includes/stylesheet.css">

<script language="javascript" src="includes/general.js"></script>

 

<script language="Javascript1.2"><!-- // load htmlarea

_editor_url = "<?php echo (($request_type == 'SSL') ? HTTPS_SERVER : HTTP_SERVER) . DIR_WS_ADMIN; ?>htmlarea/"; // URL to htmlarea files

var win_ie_ver = parseFloat(navigator.appVersion.split("MSIE")[1]);

if (navigator.userAgent.indexOf('Mac') >= 0) { win_ie_ver = 0; }

if (navigator.userAgent.indexOf('Windows CE') >= 0) { win_ie_ver = 0; }

if (navigator.userAgent.indexOf('Opera') >= 0) { win_ie_ver = 0; }

if (win_ie_ver >= 5.5) {

document.write('<scr' + 'ipt src="' +_editor_url+ 'editor.js"');

document.write(' language="Javascript1.2"></scr' + 'ipt>');

} else { document.write('<scr'+'ipt>function editor_generate() { return false; }</scr'+'ipt>'); }

// --></script>

 

</head>

 

 

and

 

<tr>

<td class="main" align="right"><?php echo tep_draw_hidden_field('products_date_added', (($pInfo->products_date_added) ? $pInfo->products_date_added : date('Y-m-d'))) . tep_image_submit('button_preview.gif', IMAGE_PREVIEW) . '  <a href="' . tep_href_link(FILENAME_CATEGORIES, 'cPath=' . $cPath . '&pID=' . $HTTP_GET_VARS['pID']) . '">' . tep_image_button('button_cancel.gif', IMAGE_CANCEL) . '</a>'; ?></td>

</form></tr>

 

<script language="JavaScript1.2" defer>

var config = new Object(); // create new config object

config.width = "<?php echo HTML_AREA_WYSIWYG_WIDTH; ?>px";

config.height = "<?php echo HTML_AREA_WYSIWYG_HEIGHT; ?>px";

config.bodyStyle = 'background-color: <?php echo HTML_AREA_WYSIWYG_BG_COLOUR; ?>; font-family: "<?php echo HTML_AREA_WYSIWYG_FONT_TYPE; ?>"; color: <?php echo HTML_AREA_WYSIWYG_FONT_COLOUR; ?>; font-size: <?php echo HTML_AREA_WYSIWYG_FONT_SIZE; ?>pt;';

config.debug = <?php echo HTML_AREA_WYSIWYG_DEBUG; ?>;

// Add additional editor config settings here...

editor_generate('products_description[1]',config); //Language No 1. IE ENGLISH

editor_generate('products_description[2]',config); //Language No 2. IE ESPANOL -> best to remove // if not in use.

editor_generate('products_description[3]',config); //Language No 3. IE GERMAN -> best to remove // if not in use.

//editor_generate('products_description[4]',config); // uncomment this line if you have more than 3 Languages defined.

//editor_generate('products_description[5]',config); // uncomment this line if you have more than 4 Languages defined.

//editor_generate('products_description[6]',config); // uncomment this line if you have more than 5 Languages defined.

// fields can be added or removed (dependeding on qty of languages installed) by adding/removing the // at beggining of line.

</script>

 

 

<?php

} elseif ($HTTP_GET_VARS['action'] == 'new_product_preview') {

if ($HTTP_POST_VARS) {

$pInfo = new objectInfo($HTTP_POST_VARS);

$products_name = $HTTP_POST_VARS['products_name'];

$products_shortdescription = $HTTP_POST_VARS['products_shortdescription'];

$products_description = $HTTP_POST_VARS['products_description'];

$products_url = $HTTP_POST_VARS['products_url'];

 

 

can help me ??

 

regards

rainer

Share this post


Link to post
Share on other sites

Hi,

 

I made an error in /admin/categories.php line numbers where wrong and its important that you change them with the update v1.1, as the HTML WYSIWG box wont appear.

 

Also update MySQL as there was a error there too.

 

The reason application_top.php is not used: I converted the values over to MySQL (instructions now show this) so changes can made to the HTML box in admin easyway :-)

 

Installation instructions have been fixed, and MySQL database fixed, was some small errors with package below. this full package fix has been tested on clean install of MS1 2.2 and worked perfectly.

 

 

DOWNLOAD FIX (FULL Version):

http://www.oscommerce.com/community/contributions,1279

Share this post


Link to post
Share on other sites

BTW does this use 2.x or the 3.x ? I noticed that while 2.x made the same crappy mshtml all IE based javascript gimmicks use, the 3.x makes almost perfect xhtml capable html.


"Use no way as way, have no limitation as limitation." - Bruce Lee

Share this post


Link to post
Share on other sites

its 3.x...

 

and maxiDVD, thanks for the great contribution...

 

here is one small thing I did to it...

 

the part with all the languages:

// Add additional editor config settings here... 

editor_generate('products_description[1]',config); //Language No 1. IE ENGLISH 

editor_generate('products_description[2]',config); //Language No 2. IE ESPANOL -> best to remove // if not in use. 

editor_generate('products_description[3]',config); //Language No 3. IE GERMAN -> best to remove // if not in use. 

//editor_generate('products_description[4]',config); // uncomment this line if you have more than 3 Languages defined. 

//editor_generate('products_description[5]',config); // uncomment this line if you have more than 4 Languages defined. 

//editor_generate('products_description[6]',config); // uncomment this line if you have more than 5 Languages defined. 

// fields can be added or removed (dependeding on qty of languages installed) by adding/removing the // at beggining of line.

 

I changed to dynamically generate the editor box for each language:

<?php for ($i = 0, $n = sizeof($languages); $i < $n; $i++) { ?>

editor_generate('products_description[<?php echo $languages[$i]['id']; ?>]',config);

<?php } ?>


The only thing necessary for evil to flourish is for good men to do nothing

- Edmund Burke

Share this post


Link to post
Share on other sites

Cheers dreamscape,

 

thats a good addition, I have just place that code in my categories.php and works great, I will add that into the contribution update if thats ok?

 

Cheers Lee

Share this post


Link to post
Share on other sites
Cheers dreamscape,

 

thats a good addition, I have just place that code in my categories.php and works great, I will add that into the contribution update if thats ok?

 

Cheers Lee

 

go for it mate!


The only thing necessary for evil to flourish is for good men to do nothing

- Edmund Burke

Share this post


Link to post
Share on other sites

Hi i get an error when i try to add to database:

 

 

SQL-query :

 

INSERT INTO configuration_group( configuration_group_id, configuration_group_title, configuration_group_description, sort_order, visible )

VALUES (

 

'25', 'HTML Editor', 'HTML Area 1.0 Options', '15', '1'

)

 

MySQL said:

 

 

Duplicate entry '25' for key 1

 

I have 2 stores but i get this error when i add to an up to date snapshot version but is ok with my feb 2003 2.2cvs version.

 

Thanks Carl

Share this post


Link to post
Share on other sites

Hi Carl,

 

Ok the reason you get that error is because "25" is already assigned to some other contribution you may have installed.

 

its easy enough to change. if you open up HTML_WYSIWYG_SQL.sql, with notepad or some other text/code editiing application you may have and change every instance of the number "25" to something else like 67 you should see it about eight times in the SQL.

 

change them "save" and then run the HTML_WYSIWYG_SQL.sql via PHPMyAdmin again.

 

--> if you want to be sure 67 is not in use --> open PHPMyAdmin, youe osCommerce Database, look down the list on the left , find the table configuration_group open it, Click browse button, and look at the column configuration_group_id you will see the number 25 is assigned to something else.., check to make sure you dont have the number 67 (or what ever number you decide on) in that list...

 

all should be sweet...

 

if you have any dramas I can email you a modified HTML_WYSIWYG_SQL.sql for your second store..

 

in future I will change 25 to something higher as it seems to be a very common number for contributions.

 

Cheers Lee

Share this post


Link to post
Share on other sites

Thanks for your help, worked fine. Top contribution, will make things alot easier and allow a more personal description etc....

 

A++++

 

 

cheers bud

 

 

Carl

Share this post


Link to post
Share on other sites

WYSIWYG HTML Area Box + Admin Function v1.3 Author: Lee Nielsen

===============================================

NEW RELEASE: ADDED FEATURE 1.3

Admin Control to Enable/Disable the displaying the HTML WYSIWYG Box.

Why? some people may already have pre-written HTML code they prefer to paste.

admittedly - pre-written HTML code can still be pasted with the HTML WYSIWYG turned on.

 

 

http://www.oscommerce.com/community/contributions,1279

Share this post


Link to post
Share on other sites

I get this error when I install the sql file. and the html area is not displaying in my categories.

 

SQL-query :

 

INSERT INTO `configuration` ( `configuration_id` , `configuration_title` , `configuration_key` , `configuration_value` , `configuration_description` , `configuration_group_id` , `sort_order` , `last_modified` , `date_added` , `use_function` , `set_function` )

VALUES (

 

'', 'Allow HTML AREA in debug mode', 'HTML_AREA_WYSIWYG_DEBUG', '0', 'Moniter Live-html, It updates as you type in a 2nd field below it.<p><b>0=disable debug<b><br>1=enable debug<br>(default=0)', 167, 7, now( ) , now( ) , 'tep_cfg_select_option(array('0', '1'),'

)

 

MySQL said:

 

 

Column count doesn't match value count at row 1

Share this post


Link to post
Share on other sites

Yeah your right, it was missing a value,

 

replace the SQL content with this and let me know, HTML area wont show until you successfully install database values.

 

 

INSERT INTO configuration_group (configuration_group_id, configuration_group_title, configuration_group_description, sort_order, visible) VALUES ('167', 'WYSIWYG Editor', 'HTML Area 1.3 Options', '15', '1');

INSERT INTO `configuration` (`configuration_id`, `configuration_title`, `configuration_key`, `configuration_value`, `configuration_description`, `configuration_group_id`, `sort_order`, `last_modified`, `date_added`, `use_function`, `set_function`) VALUES ('', 'Enable or Disable use of WYSIWYG Area', 'HTML_AREA_WYSIWYG_DISABLE', 'Enable', 'Enable/Disable WYSIWYG box', 167, 0, now(), now(), NULL, 'tep_cfg_select_option(array('Enable', 'Disable'),');

INSERT INTO `configuration` (`configuration_id`, `configuration_title`, `configuration_key`, `configuration_value`, `configuration_description`, `configuration_group_id`, `sort_order`, `last_modified`, `date_added`, `use_function`, `set_function`) VALUES ('', 'Set WYSIWYG HTML AREA Table Width', 'HTML_AREA_WYSIWYG_WIDTH', '460', 'How wide the text area should be in pixels (default: 460)', 167, 1, NULL, now(), NULL, '');

INSERT INTO `configuration` (`configuration_id`, `configuration_title`, `configuration_key`, `configuration_value`, `configuration_description`, `configuration_group_id`, `sort_order`, `last_modified`, `date_added`, `use_function`, `set_function`) VALUES ('', 'Set WYSIWYG HTML AREA Table Height', 'HTML_AREA_WYSIWYG_HEIGHT', '200', 'How high the text area should be in pixels (default: 200)', 167, 2, NULL, now(), NULL, '');

INSERT INTO `configuration` (`configuration_id`, `configuration_title`, `configuration_key`, `configuration_value`, `configuration_description`, `configuration_group_id`, `sort_order`, `last_modified`, `date_added`, `use_function`, `set_function`) VALUES ('', 'UIFT - User Interface Font Type', 'HTML_AREA_WYSIWYG_FONT_TYPE', 'Arial', 'User Interface Font Type<br>(not saved to product description)', 167, 3, now(), now(), NULL, 'tep_cfg_select_option(array('Arial', 'Courier New', 'Georgia', 'Impact', 'Tahoma', 'Times New Roman', 'Veranda', 'Wingdings'),');

INSERT INTO `configuration` (`configuration_id`, `configuration_title`, `configuration_key`, `configuration_value`, `configuration_description`, `configuration_group_id`, `sort_order`, `last_modified`, `date_added`, `use_function`, `set_function`) VALUES ('', 'UIFS - User Interface Font Size', 'HTML_AREA_WYSIWYG_FONT_SIZE', '10', 'User Interface Font Size<br>(not saved to product description)<p><b>10 Equals 10 pt', 167, 4, now(), now(), NULL, 'tep_cfg_select_option(array('8', '10', '12', '14', '18', '24', '36'),');

INSERT INTO `configuration` (`configuration_id`, `configuration_title`, `configuration_key`, `configuration_value`, `configuration_description`, `configuration_group_id`, `sort_order`, `last_modified`, `date_added`, `use_function`, `set_function`) VALUES ('', 'UIFC - User Interface Font Colour', 'HTML_AREA_WYSIWYG_FONT_COLOUR', 'Black', 'White, Black, C0C0C0, Red, FFFFF, Yellow, Pink, Blue, Grey, 000000, ect..<br>basically any colour or html colour code!', 167, 5, now(), now(), NULL, '');

INSERT INTO `configuration` (`configuration_id`, `configuration_title`, `configuration_key`, `configuration_value`, `configuration_description`, `configuration_group_id`, `sort_order`, `last_modified`, `date_added`, `use_function`, `set_function`) VALUES ('', 'UIFB - User Interface Background Colour', 'HTML_AREA_WYSIWYG_BG_COLOUR', 'White', 'White, Black, C0C0C0, Red, FFFFF, Yellow, Pink, Blue, Grey, 000000, ect..<br>basically any colour or html colour code!', 167, 6, now(), now(), NULL, '');

INSERT INTO `configuration` (`configuration_id`, `configuration_title`, `configuration_key`, `configuration_value`, `configuration_description`, `configuration_group_id`, `sort_order`, `last_modified`, `date_added`, `use_function`, `set_function`) VALUES ('', 'Allow HTML AREA in debug mode', 'HTML_AREA_WYSIWYG_DEBUG', '0', 'Moniter Live-html, It updates as you type in a 2nd field below it.<p><b>0=disable debug<b><br>1=enable debug<br>(default=0)', 167, 7, now(), now(), NULL, 'tep_cfg_select_option(array('0', '1'),');

 

Cheers Lee

Share this post


Link to post
Share on other sites

Hi MaxiDVD,

 

nice contrib,

installed without a problem to (since I got the 1.4 release anyway :wink: )

 

just 1 problem though... when I edit a product, my IE v6.1 pops a javascript error:

A Runtime Error has occured.

Do you wish to Debug?

 

Line: 237

Error:'document.all[...].style' is null or not an object

 

You think you could give me a hand with this one?

I've checked all the code I had to change in 'categories.php' multiple times. And also the db entries look ok.

 

So I guess it must have something to do with some javascript...

Any ideas???

 

thanks!!!

 

DicE


_____.:::.________###__________|/______

:(o o): . (o o) (o o)

ooO--(_)--Ooo-ooO--(_)--Ooo-ooO--(_)--Ooo-

Share this post


Link to post
Share on other sites

Hi DicE,

 

I ironed out all the runtime errors in the javascript 8) , so I can only assume its a conflict with something else you may have installed or code placement issue.

 

I have just completed a fresh install (after reading this post) as per my included instructions on another clean MS1 2.2 Dev store and it was successful, I to have IE 6.0 -> no java or runtime errors present.

 

Just check that you can see 8 new entries in the admin area like so:

 

WYSIWYG Editor

 

Enable or Disable use of WYSIWYG Area Enable

Set WYSIWYG HTML AREA Table Width 460

Set WYSIWYG HTML AREA Table Height 200

UIFT - User Interface Font Type Arial

UIFS - User Interface Font Size 10

UIFC - User Interface Font Colour Black

UIFB - User Interface Background Colour White

Allow HTML AREA in debug mode 0

 

If so? we continue...

 

A Runtime Error has occured.

Do you wish to Debug?

 

Line: 237

Error:'document.all[...].style' is null or not an object

This Line Number Indicates to me this could be a issue in the <head> tags </head> make sure its inbetween them, and not running into the other javascript functions in the head.

 

I had the same error you have a while back --> it just turned out to be that the code was wrongly placed. it really needs to be place where I have instructed.

 

try using this below and replace everything in and between including your <head> tags </head>

 

 <head>

<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">

<title><?php echo TITLE; ?></title>

<link rel="stylesheet" type="text/css" href="includes/stylesheet.css">

<script language="javascript" src="includes/general.js"></script>

<script language="Javascript1.2"><!-- // load htmlarea

//MaxiDVD Added WYSIWYG HTML Area Box + Admin Function v1.3 <head>

     _editor_url = "<?php echo (($request_type == 'SSL') ? HTTPS_SERVER : HTTP_SERVER) . DIR_WS_ADMIN; ?>htmlarea/";  // URL to htmlarea files

       var win_ie_ver = parseFloat(navigator.appVersion.split("MSIE")[1]);

        if (navigator.userAgent.indexOf('Mac')        >= 0) { win_ie_ver = 0; }

         if (navigator.userAgent.indexOf('Windows CE') >= 0) { win_ie_ver = 0; }

          if (navigator.userAgent.indexOf('Opera')      >= 0) { win_ie_ver = 0; }

           if (win_ie_ver >= 5.5) {

      document.write('<scr' + 'ipt src="' +_editor_url+ 'editor.js"');

      document.write(' language="Javascript1.2"></scr' + 'ipt>');

         } else { document.write('<scr'+'ipt>function editor_generate() { return false; }</scr'+'ipt>'); }

// --></script>

</head>

Dont rely on my line numbers to much as your code/version of osCommerce could be different look mainly at the included example:

 

look for this part aprox line 495

        <td class="main" align="right"><?php echo tep_draw_hidden_field('products_date_added', (($pInfo->products_date_added) ? $pInfo->products_date_added : date('Y-m-d'))) . tep_image_submit('button_preview.gif', IMAGE_PREVIEW) . '  <a href="' . tep_href_link(FILENAME_CATEGORIES, 'cPath=' . $cPath . '&pID=' . $HTTP_GET_VARS['pID']) . '">' . tep_image_button('button_cancel.gif', IMAGE_CANCEL) . '</a>'; ?></td>

</form></tr>

 

and directly under it paste this:

 

   <?php if (HTML_AREA_WYSIWYG_DISABLE == 'Disable') {} else { ?>

   <script language="JavaScript1.2" defer>

       // MaxiDVD Added WYSIWYG HTML Area Box + Admin Function v1.3 Products Description

          var config = new Object();  // create new config object

          config.width = "<?php echo HTML_AREA_WYSIWYG_WIDTH; ?>px";

          config.height = "<?php echo HTML_AREA_WYSIWYG_HEIGHT; ?>px";

          config.bodyStyle = 'background-color: <?php echo HTML_AREA_WYSIWYG_BG_COLOUR; ?>; font-family: "<?php echo HTML_AREA_WYSIWYG_FONT_TYPE; ?>"; color: <?php echo HTML_AREA_WYSIWYG_FONT_COLOUR; ?>; font-size: <?php echo HTML_AREA_WYSIWYG_FONT_SIZE; ?>pt;';

          config.debug = <?php echo HTML_AREA_WYSIWYG_DEBUG; ?>;

          // More Configs can added here:

          // Dreamscape added Dynamic Language Function

       <?php for ($i = 0, $n = sizeof($languages); $i < $n; $i++) { ?>

       editor_generate('products_description[<?php echo $languages[$i]['id']; ?>]',config);

    <?php } } ?>

</script>

 

This should fix-it

Let me know how you go.

 

Cheers Lee

Share this post


Link to post
Share on other sites

I love this contribution.

 

Easy to install

Enhance the look of the shop

And makes my customers happy

 

Thanks a million MaxiDVD :D

 

Keep up the good work!

Share this post


Link to post
Share on other sites
Hi MaxiDVD,

 

nice contrib,

installed without a problem to (since I got the 1.4 release anyway  :wink: )

 

just 1 problem though... when I edit a product, my IE v6.1 pops a javascript error:

A Runtime Error has occured.

Do you wish to Debug?

 

Line: 237

Error:'document.all[...].style' is null or not an object

 

You think you could give me a hand with this one?

I've checked all the code I had to change in 'categories.php' multiple times. And also the db entries look ok.

 

So I guess it must have something to do with some javascript...

Any ideas???

 

thanks!!!

 

DicE

 

That error is returned if an HTML area is defined that doesn't exist. I got this, and is one of the reasons I came up with the dynamic language thing and posted it here... though MaxiDVD has implemented it into the newer releases, so if you installed v1.4, then you should have gotten the update.

 

Anyways before the HTML areas were called like:

 

editor_generate('products_description[1]',config);

editor_generate('products_description[2]',config);

editor_generate('products_description[3]',config);

etc...

 

if you did have language ID 2 or 3 then you'd get that JS error since those text input boxes don't exist to have the HTML area placed in them.

 

but again, I just downloaded v1.4 and it contains the language fix so it shouldn't be a problem for you, unless you upgraded and just ignored the changes to categories.php


The only thing necessary for evil to flourish is for good men to do nothing

- Edmund Burke

Share this post


Link to post
Share on other sites
if you did have language ID 2 or 3 then you'd get that JS error since those text input boxes don't exist to have the HTML area placed in them.

 

sorry that should read "if you did NOT have language ID..."


The only thing necessary for evil to flourish is for good men to do nothing

- Edmund Burke

Share this post


Link to post
Share on other sites

==========================================================================

NEW IMPROVED + ADDED FEATURES v1.5 + FIX

==========================================================================

WHATS NEW?

 

No need to FTP them extra images up to your website anymore! Yippe!!

 

1. Image uploader -> Image Directory Manager and Image URL,

This unreal addon allows you to directly upload images from your

computer all via the WYSIWYG Editor it uploads and place's the new image/s

directly in your existing /images directory or into a newly made

folder, It can create and delete folders/images on your website, Not to mention

automatically inserting the image into your products description field while you work.

 

2. Added WYSIWYG Editor Box to osCommerce Newsletter, now you can create

your Newsletters in Full colour with links and upload/insert Images all online..

Feature can be turned on and off at will.

 

3. Added WYSIWYG Editor Box to osCommerce Customer Email, now you can create

Customer Emails in Full colour with links and upload/insert all online..

Feature can also be turned on and off at will.

 

4. To top it all off I have combined this with the "Admin Comments Toolbar 2.1 by Skeedo.com Enterprises"

contibution, this feature is only Enabled in Newsletter and Customer Email when the WYSIWYG Editor Box

is disabled, its a nifty little mod that allows you to pre-write repetitve emails tasks and replies like

store name, address, url, emails, thank yous, newsletter info, automatic date insertions,

subscribe and unsubscribe email terms ect.. all-non-html <--thats why its Enabled when WYSIWYG is Disabled.

 

5. Admin control for each individual HTML WYSIWYG Box, Size, Height, Colour, Enabled/Disabled.

 

Current v1.4 WYSIWYG user can simply copy the HTMLAREA box Directly over the Old one in Admin --> this

is for the new image upload feature only!! - from above ADDED FEATURES #1.

if you want to add the additon features you need to follow the changes,

and import the new SQL file (Always Make a Back-up)

 

This release also fixes a small problem with inserting images and table creation,

Thanks to clive jenkinson for pointing the issue out.

 

This is a NEW (full) v1.5 install,

================================================================================

==

END: ADDED FEATURES 1.5 + FIX

================================================================================

===

 

DOWNLOAD IT HERE

http://www.oscommerce.com/community/contributions,1279

Share this post


Link to post
Share on other sites

Hi maxidvd

 

i insalled your contribution 1.5 plus today and i have the following things to ask about

1)where i can get the image uploader i can not see any link to do so

2) when i clcik on add picture in your html area it does nothing and even teh otehr stuff too libke bold , underline ...etc it does not work

3)i have the following code appear once i go to ad,in.categories.php

function popupImageWindow(url) { window.open(url,'popupImageWindow','toolbar=no,location=no,directories=no,status=no,menubar=no,scrollbars=no,resizab

le=yes,copyhistory=no,width=100,height=100,screenX=150,screenY=150,top=150,left=1

50') }

 

by teh way teh copy and apste feature for teh pcitures work fine

looking forward for your reply

thanks

Share this post


Link to post
Share on other sites

hi again

 

i forgot to mention the following features doesnot appear on teh admin too:

2. Added WYSIWYG Editor Box to osCommerce Newsletter, now you can create

your Newsletters in Full colour with links and upload/insert Images all online..

Feature can be turned on and off at will.

 

3. Added WYSIWYG Editor Box to osCommerce Customer Email, now you can create

Customer Emails in Full colour with links and upload/insert all online..

Feature can also be turned on and off at will.

 

4. To top it all off I have combined this with the "Admin Comments Toolbar 2.1 by Skeedo

 

hmm what am i missing ?

 

 

thanks

 

I.O

Share this post


Link to post
Share on other sites

opps again :oops:

i fogot to mention the version of htmlarea that i have before is back inn march .

 

 

regards,

i.o

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×