Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Sign in to follow this  
Guest

[Contribution] HTML WYSIWYG Editor for Product Desc, MS1 2.2

Recommended Posts

Guest

Hi i.o,

 

If you have installed "Version back in March" 2002? thats not mine, the coding would be different.

 

so a simple copypaste wont work,

 

where i can get the image uploader i can not see any link to do so

 

here--> when i clcik on add picture in your html area it does nothing, it replaces the old image add feature (pops up a new window)

 

function popupImageWindow(url) { window.open(url,'popupImageWindow','toolbar=no,location=no,directories=no,status=no,menubar=no,scrollbars=no,resizab

le=yes,copyhistory=no,width=100,height=100,screenX=150,screenY=150,top=150,left=1

50') }

 

make sure you have

//--></script>

at the bottom of that javasript function in your categories.php

 

 

2. Added WYSIWYG Editor Box to osCommerce Newsletter, now you can create

your Newsletters in Full colour with links and upload/insert Images all online..

Feature can be turned on and off at will.

 

3. Added WYSIWYG Editor Box to osCommerce Customer Email, now you can create

Customer Emails in Full colour with links and upload/insert all online..

Feature can also be turned on and off at will.

 

if you ran the HTML_WYSIWYG_SQL.sql script into PHPMyAdmin you will see the new options under a Admin--> Configuration-->HTML WYSIWYG 1.5-->HERE!

 

4. To top it all off I have combined this with the "Admin Comments Toolbar 2.1 by Skeedo

 

this is a sustitute for HTML area ONLY IF - HTML WYSIWYG Area is Disabled.

 

If you go with a NEW install and follow the instructions, all these features will appear and work.

 

hope this helps you.

 

I just searched contributions and found 3 diffrent types of HTML Areas,

 

Cheers Lee

Share this post


Link to post
Share on other sites

Hi maxi,

 

thanks for your work. I started to use HtmlArea last week...took me quite a while to find that missing Null in the last line of the sql (use_function/set_function).

I?ve now installed 1.5 and here are my questions:

 

1. file htmlarea/config.ic.php :

what about the "<?php ??" in line 412

 

2. the image upload won?t work

- how do i reset the image dir in line 16 (i?ve osc in a subdir http../shop/catalog/) in the img. manager i don?t see the content of catalog/images/

- do i need netbpm to resize / upload ?

- is there an upload limit to the size / dpi or can i set it?

- do i need to set chmod of img dir to 777 ?

 

I have some more questions but i?ll keep them until the upload works.

 

thanks

george

 

(to everybody upgrading: clear browser cache to see new image manager-popup!)

Share this post


Link to post
Share on other sites
Guest

Hi George,

 

Good point!, I should have mentioned this earlier as I had the same thing when compiling the image uploader.

(to everybody upgrading: clear browser cache to see new image manager-popup!)

 

in otherwords if your upgrading but dont see the new pop-up image uploader try Emptying Temperary Internet Files.

 

As for line 412 it was there from the creator, so I figured I'd leave it there wasnt doing any harm, anyway I just deleted it from my file and all features still work so I can safely say it can be deleted.

1. file htmlarea/config.ic.php :

what about the "<?php ??" in line 412

 

If you want to define your own directorys /catalog, /Image dirs ect its very similar to osCommerce config file, I'll place an example here for you

 

With the /htmlarea/config.inc.php file I assigned the osCommerce config settings in there to make it simpler and straight foward for user, but as some people have there /admin and catelog directorys renamed all over the place you may want to try defining your own direct paths.

 

below is a guide as to what goes in there:

 

// CONSTRAIN_* indicates the image constraints used to scale uploads (0 = none)

define("CONSTRAIN_HEIGHT", 0);

define("CONSTRAIN_WIDTH", 0);



// IMAGE_DIR and IMAGE_URL identify the Image directory "root" (MUST end in "/")

// Do NOT include "http://my.hostname.com" in IMAGE_URL; just the path from the

// DocumentRoot of your webserver.

define("IMAGE_DIR", trim("/path/from/filesystem/root/"));

define("IMAGE_URL", trim("/path/from/webserver/document/root/"));



// NETPBM_DIR identifies the directory where NETPBM is located (MUST end in "/")

// Not used if either CONSTRAIN_HEIGHT or CONSTRAIN_WIDTH (above) is specified as "0".

define("NETPBM_DIR", trim("/path/from/filesystem/root/"));



// SCRIPT_DIR and SCRIPT_URL identify where these scripts reside (MUST end in "/")

// Do NOT include "http://my.hostname.com" in SCRIPT_URL; just the path from the

// DocumentRoot of your webserver.

define("SCRIPT_DIR", trim("/path/from/filesystem/root/"));

define("SCRIPT_URL", trim("/path/from/webserver/document/root/"));



// SUPPORT_* identify optional features

define("SUPPORT_BITMAP", TRUE);  // supported by Internet Explorer ONLY!

define("SUPPORT_CREATE", TRUE);

define("SUPPORT_DELETE", TRUE);

define("SUPPORT_METAFILE", TRUE);// supported by Internet Explorer ONLY!

define("SUPPORT_UPLOAD", TRUE);



// UPLOAD_LIMIT indicates the maximum file size (in BYTES!) which can be uploaded (0 = unlimited)

define("UPLOAD_LIMIT", 0);

 

With NETBPM, you dont need it to UPLOAD, it is used for resizing images on Windows Servers, I have both Windows Server and UNIX, I had no problems with anything - but I dont use the resize feature, as I found it easy enough to drag the image sizes around from with in the description field.

It was also to big to included in the contibution upload: if you want you can D/L the full image upload addon app and assing all your own paths.

http://dsear.org/htmlArea/phpImageManager-...mlArea-2.03.zip

 

img dir to 777 --> that is Affirmative, the application requires full read and write access to delete upload and create..

 

same goes on windows servers you need to set file permissions to the same --> I can never remeber how I do it on my pc...

 

is there an upload limit to the size / dpi or can i set it?

 

Theres no upload MAX inplace I didnt see the point if it was being used for admin purpose, you can however set up MAX size upload (more geared towards forums I think. but the option is there.

 

I uploaded a 1.2 MB image just for benchmarking purposes, I tried the resize feature, it claimed to have reduced it but I couldnt tell. its all trial and error.

 

I will get all bugs cleaned if any, I have it running perfect on 4 oscommerce stores. I cant imagine not using one now..

 

im uploading a new version later tonight, with Advanced and Basic HTML WYSIWYG versions, as the last contrib was the advanced version, Ive had it in production on my site but found it can be sluggish to load, 50 odd images all the time, but my host is sluggish to ATM.

 

the basic version is much faster and still includes Image Management.

 

hope I help some.

Share this post


Link to post
Share on other sites
Guest

==========================================================================

ADDED FEATURES v1.6

==========================================================================

Advanced or Basic Version HTMLAREA Option in Admin,

Why, The Advanced Version offers loads More Features for HTML Table Minupulation,

Cut, Copy, Paste, special charachters, product description seach and print options.

Now thats all good and dandy if you like/use these added features, but It also slows

page loading by about 50%, So included both options Basic and Advanced into the one package

Basic Version is set Enabled by defualt and offers all the standard HTML tools for getting the job done.

If you want the advanced option, admin-->configuration-->HTML WYSIWYG OPTIONS-->

BTW its coded so that if you install all three HTML boxes in Product/categories description,

Newsletter, and customer email -you can define them individually as to what HTMLAREA should be

Advanced or Basic, also individually sizing and colouring via admin.

 

******** IT IS STRONGLY SUGGESTED TO MAKE A BACK-UP OF THESE FILES FIRST **********

Whenever Importing any new SQL files to your Database ALWAYS do a FULL DATABASE EXPORT first:

include STRUCTURE, DATA and DROPTABLE - this enables a quick restore alternative if errors do occur,

I have assigned configuration_group_id to 112 to avoid any possible conflicts with other contributions.

 

You Must SET your Image directory to CHMOD 777 to allow the Image upload application to create and delete

files and folders from your image directory.

 

if your upgrading from version 1.4, you need clear your browser cache in order to see the new image tool.

Share this post


Link to post
Share on other sites
Guest

Heres a couple of screenies,

 

screen3.jpg

 

screen1.jpg

 

screen2.jpg

 

 

Cheers Lee :roll:

Share this post


Link to post
Share on other sites

thanks for your reply, got it working now.

 

For everybody who has a problem with the dir setting:

- Look into includes/configure.php there are the DIR_FS_DOCUMENT_ROOT, etc. defined so you can see where those tags are pointing to. Now you can write your special directory behind those tags. Here are mine :

define("IMAGE_DIR", trim(DIR_FS_DOCUMENT_ROOT . "/catalog/images/produkt_bilder/"));

define("IMAGE_URL", trim(DIR_WS_CATALOG_IMAGES . "/produkt_bilder/"));

 

My new problem is now when i want to preview a new artikle I get this error Message:

Fatal error: Cannot instantiate non-existent class: upload in /htdocs/.../shop/admin/categories.php on line 594

 

right before this line i put in the 2nd htmlarea tag. But I can?t find the reason why the upload class doesn?t work.

HtmlArea is the only mod i made to configure.php

 

 

where can i switch specific htmlarea buttons on and off?

 

george

Share this post


Link to post
Share on other sites

Nice contribution :)

 

There is only one mistake in the HTML_WYSIWYG_SQL.sql

 

Veranda should be Verdana

Share this post


Link to post
Share on other sites

dutch translation for mail.php

 

<?php

/*

$Id: mail.php,v 1.8 2002/01/18 17:28:53 hpdl Exp $

 

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2002 Pruts0r

 

Released under the GNU General Public License

*/

 

define('HEADING_TITLE', 'Zenden van e-mail naar klanten');

 

define('TEXT_CUSTOMER', 'Klant:');

define('TEXT_SUBJECT', 'Onderwerp:');

define('TEXT_FROM', 'Van:');

define('TEXT_MESSAGE', 'Bericht:');

define('TEXT_SELECT_CUSTOMER', 'Selecteer klant');

define('TEXT_ALL_CUSTOMERS', 'Alle klanten');

define('TEXT_NEWSLETTER_CUSTOMERS', 'Naar alle nieuwsbriefontvangers');

define('TEXT_EMAIL_BUTTON_TEXT', '<p><HR><b><font color="red">De TERUG Button is uitgeschakeld omdat de HTML WYSIWG Editor op ON staat,</b></font> Waarom ? - Omdat als je op de TERUG KNOP klikt om html te bewerken, de PHP(php.ini)"Magic Quotes = On" automatisch "" backslashes toevoegd overal waar een " verschijnt (HTML gebruikt dit in links, plaatjes en meer) en dit verstoord de HTML code en de plaatjes zullen verdwijnen als u nog een keer op de verzend knop drukt, Als u de WYSIWYG Editor op OFF zet in de Admin dan zal de HTML mogenlijkheid van Oscommerce ook uitgeschakeld zijn en zal de TERUG BUTTON weer verschijnen.<br><br><b>Als u een preview wilt zien voor u verzend, gebruik dan de Preview knop van WYSIWYG Editor.<br><HR>');

define('TEXT_EMAIL_BUTTON_HTML', '<p><HR><b><font color="red">HTML is uitgeschakeld!</b></font><br><br>Als u HTML email wilt versturen, verander dit dan in: Admin-->Configuration-->WYSIWYG Editor-->Options<br>');

define('NOTICE_EMAIL_SENT_TO', 'E-mail verzonden naar: %s');

define('ERROR_NO_CUSTOMER_SELECTED', 'FOUT: Er zijn geen klanten geselecteerd.');

?>

Share this post


Link to post
Share on other sites
Guest

Hi George

 

Good to see you got the directories sorted out,

 

as for this error:

Fatal error: Cannot instantiate non-existent class: upload in /htdocs/.../shop/admin/categories.php on line 594

 

I havent had that error, so I cant really comment.

non-existent class: upload

have a look at line 594 in categories.php and see what the code is actually trying to do, I have lots of custom work on my categories.php and line numbers are way out.

 

Hi Chet.

There is only one mistake in the HTML_WYSIWYG_SQL.sql

Veranda should be Verdana

 

I will fix this haha, your right - I have always thought it was spelt Veranda.

I will include your Dutch translation of mail.php in the next update if thats ok?

 

Cheers Lee

Share this post


Link to post
Share on other sites
Guest
where can i switch specific htmlarea buttons on and off?

 

For everyone who would like to maually customize which buttons and features should be displayed on the WYSIWYG editor:

 

depending on what version you have

v1.1,v1.2,v1.3,v1.4,v1.5 /admin/html/editor.js

 

v1.6 /admin/html/editor_basic.js

and

v1.6 /admin/html/editor_advanced.js

 

The .js means these are Javascript files, they can be opened with, notepad or any code editor software. Look for

 

this.toolbar = [

//    ['fontstyle'],

   ['formatblock'],

   ['fontname'],

   ['fontsize'],

   ['preview','print','separator'],

   ['cut','copy','paste','find'],

   ['linebreak'],

   ['OrderedList','UnOrderedList','Outdent','Indent','separator'],

   ['justifyleft','justifycenter','justifyright','separator'],

   ['bold','italic','underline','separator'],

   ['forecolor','backcolor'],

   ['separator'],

   ['Createlink','InsertImage','separator'],

   ['strikethrough','subscript','superscript','separator'],

   ['translation'],

   ['separator'],

   ['popupeditor'],

   ['htmlmode'],

   ['InsertTable','TableProperties','RowProperties','InsertRowBefore','InsertRowAfter','DeleteRow','InsertColumnBefore','InsertColumnAfter','DeleteColumn','CellProperties','InsertCellBefore','InsertCellAfter','DeleteCell','SplitCell','MergeCells','SplitRow','MergeRows','separator'],

//    ['custom1','custom3','separator'],

//    ['about'],

//    ['help'],

   ['HorizontalRule'],

   ['showborder'],

   ['specchar','separator'],

   ['maxidvd'],

   ['custom2']];

 

use double fowardslashes before the buttons to disable like so //.

the can ba re-arranged how ever you like.

 

Cheers Lee

Share this post


Link to post
Share on other sites
Guest

===============================================

ADDED FEATURE and FIX v1.6.1 (FILE MANAGER UPLOADER plug-in)

===============================================

 

Thanks to Chet, for contributing Dutch Translation, and pointing out a spelling mistake in SQL FONT TYPES.

Included a FILE MANAGER UPLOADER plug-in (new button on WYSIWYG Editor) much like the Image Uploaded, the new file manger

plug-in allows the user to upload ANY file into a choosen directory on your website and product description, or it can create new directories,

the bueaty of this, is it will put a direct download-link to that new file on your website in the products description/email or newsletter.

 

Why would you want this? Well you might sell Music, Games, Demos ect.. it will add a download-link like so: unreal.zip (143 btyes)

in the products description this allows potential webshoppers, to download a sample song, game ect from your

site with-out directly having to create an account and go throught the whole add-to-cart as a freebie process, also

there is no upload/download limit like the oscommerce one that restricts upload download to a specific MB.

 

and it can be used in a million different otherways that was my example. it can be disable simply by commenting out

like so:

 

// ['linktofile'],

 

in both /admin/html/editor_basic.js and /admin/html/editor_advanced.js

 

as with the Image Uploaded, you need to set read write permissions CHMOD 777 on the directories you would like to use.

I should also mention that like osCommerce both these feature have a configuration file, config.inc.php in these files

you "MAY" need to define where your webroot and image dir, upload dir ect reside, I have altered these file to be UNIVERSAL with

most standard osCommerce installations ie: /catalog/admin/ config types if you have changed your Catalog or Admin

folders names or locations different to that of osCommerce default you "MAY" need to alter the twos files to suit your store.

 

these two files can be found in:

 

IMAGE UPLOADED: admin/htmlarea/popups/config.inc.php

FILE UPLOADER admin/htmlarea/popups/file/config.inc.php

 

these should only be altered if your image/file upload popups are not working or have error messages.

 

If your just upgrading from v1.6 <--(only) for the FILE MANAGER UPLOADER plug-in, simply BACKUP and replace your HTMLarea folder

with this new one, If you dont need/want a FILE MANAGER UPLOADER dont upgrade....

 

******** IT IS STRONGLY SUGGESTED TO MAKE A BACK-UP OF THESE FILES FIRST **********

Whenever Importing any new SQL files to your Database ALWAYS do a FULL DATABASE EXPORT first:

include STRUCTURE, DATA and DROPTABLE - this enables a quick restore alternative if errors do occurer,

I have assigned configuration_group_id to 112 to avoid any possible conflicts with other contributions.

file_uploader.jpg

Share this post


Link to post
Share on other sites
Guest

Hi,

I have got the contribution working ok but i am getting these problems

 

Insert Image Dialog

Upload New image button doesnt do anything! i select an image and a name enter resize dimensions then click upload and nothing happens

 

Either does create a new folder!!

Selected image works ok

 

Enlarge Image button get a new page split into two panes, but no buttons etc and this error

 

Line: 94

Char: 3

Error: Object Expected

Code: 0

URL: ]http://192.168.0.1/admin/htmlarea/popups/f..._description[1]

 

Insert Table get this error

 

Line 14

char 1

error object doesnt support this property or method

code: 0

URL URL: ]http://192.168.0.1/admin/htmlarea/popups/i..._description[1]

 

Now the only thing I am guilty of is on the installation instructions it says

 

1a. OPEN: /catalog/admin/categories.php

================================================================================

====

Look for this around line 350: (CHANGEs Made for v1.6)

================================================================================

====

 

 

<script language="javascript"><!--

function popupImageWindow(url) {

window.open(url,'popupImageWindow','toolbar=no,location=no,directories=no,status=no,menubar=no,scrollbars=no,resizab

le=yes,copyhistory=no,width=100,height=100,screenX=150,screenY=150,top=150,left=1

50')

}

 

//--></script>

 

 

================================================================================

====

And directly underneath it add this: (CHANGEs Made for v1.6)

================================================================================

====

 

<script language="Javascript1.2"><!-- // load htmlarea

//MaxiDVD Added WYSIWYG HTML Area Box + Admin Function v1.6 <head>

........

...........

 

I couldnt find the block of code mentioned on the categories page so i stuck it in after this code around line 390

 

<link rel="stylesheet" type="text/css" href="includes/javascript/spiffyCal/spiffyCal_v2_1.css">

<script language="JavaScript" src="includes/javascript/spiffyCal/spiffyCal_v2_1.js"></script>

<script language="javascript">

var dateAvailable = new ctlSpiffyCalendarBox("dateAvailable", "new_product", "products_date_available","btnDate1","<?php echo $pInfo->products_date_available; ?>",scBTNMODE_CUSTOMBLUE);

 

....

 

Can anyone shed some light :)

 

Apart from that its a great contribution and i am probably responsible for screwing it up anyway!!

Share this post


Link to post
Share on other sites
Guest

hi nostrodamned,

 

The tables is a bug you just found it :-) thanks, I fixed the table problem and will upload v1.6.2 in a minute, I recommenr downloading it an replace your whole /htmlarea folder with this newone.. as for the image problem....

 

with the Image Uploaded, you need to set read write permissions CHMOD 777 on the directories OR WINDOWS SERVER PERMISSIONS NEED TO BE SET.

 

I should also mention that like osCommerce both these feature have a configuration file, config.inc.php in these files

you "MAY" need to define where your webroot and image dir, upload dir ect reside, I have altered these file to be UNIVERSAL with

most standard osCommerce installations ie: /catalog/admin/ config types if you have changed your Catalog or Admin

folders names or locations different to that of osCommerce default you "MAY" need to alter the twos files to suit your store.

 

these two files can be found in:

 

IMAGE UPLOADER: admin/htmlarea/popups/config.inc.php

FILE UPLOADER admin/htmlarea/popups/file/config.inc.php

 

IMAGE UPLOADER: admin/htmlarea/popups/config.inc.php

you will find this file in the new download and also admin/htmlarea/popups/ORIGINAL_config.inc.php

 

open ORIGINAL_config.inc.php define your webroot directories as you would osCommerce install, then rename, save ands replace config.inc.php

 

This would be related to the file settings from above and file permissions on your images directory.

Insert Image Dialog

Upload New image button doesnt do anything! i select an image and a name enter resize dimensions then click upload and nothing happens

 

Either does create a new folder!!

Selected image works ok

 

Just one question are you running a windows server?.

 

The script your guilty of should be changed, do you have a code editing program that allows you to search? i recommend Winsyntax its free.

 

Search for </head> in categories.php and move the code above it.

It will cause problems if its placed below </head>

 

Cheers Lee

Share this post


Link to post
Share on other sites
Guest

Thanks for the quick reply!

I'm running OScommerce locally on winxp with apache server (no clue if its configured right but everything else seems to be working locally) so some probs may be due to this!!

I'm going to upload it to my unix server and see how it goes :)

My admin and catalog folder are at the same root level not catalog insode admin would this cause the problem iin the two files you mention, I thought if the variables were ok the location should be updated?

Share this post


Link to post
Share on other sites
Guest

Update is uploaded now,

 

yeah /admin /catalog in the root should be ok! but i havnt tested it in theory, the htmlarea is sourcing its config setting from oscommerce /admin/includes/configuration.cfg, so as long as the access to that file is ok,

 

since /admin is in the root directory you may have to open config.inc.php you will see this at the top of the file.

 

require('../../includes/configure.php');

 

if you have no luck --> try dropping it back a level like so.

 

require('../includes/configure.php');

 

you will know straight away if the image uploaded cant find the path, it displays a error or page cant be found.

 

Cheers Lee

Share this post


Link to post
Share on other sites
Guest

Hi,

I installed your update and the tables insertion is fine,

 

I have tried millions of combinations to try and update the config file but i get an error in the image manager sections.

This is the error

Warning: main (includes/modules/infopages/configure.php)

function.main]: failed to create stream: No such file or directory in /hsphere/local/home/highland/xxxxx/admin/includes/configure.php on line 39.

 

Line 39 is a line from the infopages module

 

require(DIR_WS_MODULES . 'infopages/configure.php');

 

I dont know if its causing the problem :(

 

help :)

Share this post


Link to post
Share on other sites

Help,

 

I just installed 1.6.2 and this is my error.

 

When I add a product I can work on the HTML WYSIWYG Box but when I click on preview it only shows xcxcxc

And when I view the product on the catalog nothing appears.

 

Please help.

 

Thanks

Share this post


Link to post
Share on other sites
Guest

I added this mod to my files. I can see it in the Newsletter and E-mail section but not in my product description area

Share this post


Link to post
Share on other sites
Guest

nostrodamned

 

includes/modules/infopages/configure.php

thats not the configuration file it should be looking for.

it should be looking for admin/includes/configure.php

 

delete this line //require('../../includes/configure.php');

 

and try adding direct paths to your admin/html areas example:

-

define("IMAGE_DIR", 'trim("c:/php/www/catalog/images"));

define("IMAGE_URL", trim("catalog/images/"));

 

define("SCRIPT_DIR", trim("c:/php/www/admin/htmlarea/popups/"));

define("SCRIPT_URL", trim("admin/htmlarea/popups/"));

 

you should get the idea, your php folder may differ.

 

oliverm

 

I will do a clean install tonight on MS1 and see if I can simulate your error, im not sure why you have that, but it may be just a code placement problem,

 

did you change the code in your categories.php in between the <head> tags</head> or run the new SQL script?

 

bluephoenix

 

your problem exists in admin/categories.php check your code placement with the instructions.txt file.

Share this post


Link to post
Share on other sites
Guest

I have double checked and triple checked the edits and I did exactly as it states and still no go. Any help would be very appreciated.

Share this post


Link to post
Share on other sites

MaxiDVD,

 

This is where I place the code for the categories.php

 

 

<html <?php echo HTML_PARAMS; ?>>

<head>

<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">

<title><?php echo TITLE; ?></title>

<link rel="stylesheet" type="text/css" href="includes/stylesheet.css">

<script language="javascript" src="includes/general.js"></script>

 

 

<script language="Javascript1.2"><!-- // load htmlarea

//MaxiDVD Added WYSIWYG HTML Area Box + Admin Function v1.6 <head>

_editor_url = "<?php echo (($request_type == 'SSL') ? HTTPS_SERVER : HTTP_SERVER) . DIR_WS_ADMIN; ?>htmlarea/"; // URL to htmlarea files

var win_ie_ver = parseFloat(navigator.appVersion.split("MSIE")[1]);

if (navigator.userAgent.indexOf('Mac') >= 0) { win_ie_ver = 0; }

if (navigator.userAgent.indexOf('Windows CE') >= 0) { win_ie_ver = 0; }

if (navigator.userAgent.indexOf('Opera') >= 0) { win_ie_ver = 0; }

<?php if (HTML_AREA_WYSIWYG_BASIC_PD == 'Basic'){ ?> if (win_ie_ver >= 5.5) {

document.write('<scr' + 'ipt src="' +_editor_url+ 'editor_basic.js"');

document.write(' language="Javascript1.2"></scr' + 'ipt>');

} else { document.write('<scr'+'ipt>function editor_generate() { return false; }</scr'+'ipt>'); }

<?php } else{ ?> if (win_ie_ver >= 5.5) {

document.write('<scr' + 'ipt src="' +_editor_url+ 'editor_advanced.js"');

document.write(' language="Javascript1.2"></scr' + 'ipt>');

} else { document.write('<scr'+'ipt>function editor_generate() { return false; }</scr'+'ipt>'); }

<?php }?>

// --></script>

 

 

</head>

 

 

And I did run the new sql by going to myphpdmin, select database, and click on sql, browse, and go

 

Thanks for your help

Share this post


Link to post
Share on other sites
Guest

Hi juliankrye,

 

PHPMyAdmin is Free!, its not so difficult to install either.

there is another method but im not sure how its done, maybe someone else could tell you.

 

Download it 1634 kb here:

 

http://www.phpmyadmin.net/

 

cheers Lee

Share this post


Link to post
Share on other sites
Guest

bluephoenix can you send me a copy of your categories.php I will have a look it, and see if I can find anything wrong.

 

oliverm that part of the code is right.

 

Im still working on it.

 

:roll: Lee

Share this post


Link to post
Share on other sites

I am trying to install phpmyadmin but I am having problems: Can some please show me how you have your config file.

 

thank you

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×