Jump to content
Sign in to follow this  
Luzifer

Admin Passwort ?

Recommended Posts

Guten Abend zusammen,

ich habe folgendes Problem, habe meine Seite eingerichtet funktioniert auch einwandfrei, nur kann jeder in den Pfad meiner Domain.........catalog/admin reinkommen und dort alles basteln wie er es mag.

Das kann natürlich nicht sein, ich finde aber nirgends was um den Adminbereich mit einem Passwort zu sichern ?

Wäre für eure Hilfe sehr dankbar

Gruß Luzi

Share this post


Link to post
Share on other sites

Manchmal bietet dir auch dein Webhoster so eine Funktion an.

Bei meinem kann ich es relativ leicht einrichten:

Ich wähle das Verzeichnis aus (z.B. das admin-Verzeichnis) und muss dann nur noch einen Benutzernamen plus Passwort eingeben.

Der Passwortschutz wird dann automatisch eingerichtet.

Falls dein Provider sowas nicht anbietet, einfach dem Link von Carla folgen. B)

Share this post


Link to post
Share on other sites

Hallo zusammen,

habe das ganze auch installiert und es wird alles korrekt angezeigt.

nur bin ich mir nicht sicher, ob es überhaupt das tool war was ich brauche!? B)

wollte mein admin-passwort ändern...habe ich dann nach der installation von Admin-PHP-Access auch probiert, komme aber trotzdem mit meinem alten passw rein.

jmd eine idee was ich noch ändern soll bzw wo ich das dann überhaupt ändern kann?

Danke

Gruß

Share this post


Link to post
Share on other sites

hallo, hab mich auch schon gewundert über den offenen adminbereich.

würde auch am liebsten das normale .htaccess benutzen, weiss aber nicht, was ich da reinschreiben soll.

hab's aber doch mal mit dem phpaccess versucht - muss diese ins admin-verzeichnis (mit den entsprechenden attributen versehen)?

merci, stella

Share this post


Link to post
Share on other sites

hallo,

hab die anleitung im readme.txt gefunden betr. installation. nur wurde da nicht erwähnt dass das file phpaccess.php auf CHMOD 775 und das ganze Admin-Verzeichnis auf CHMOD 777 geändert werden muss, sonst kann man keine User eröffnen etc.

anway, ich hab's immer noch nicht kapiert. das ist ja alles schön und gut mit den benutzervergaben, aber ich komm trotzdem ohne passwort rein.

wieso denn???

merci und gruss, stella

Share this post


Link to post
Share on other sites

hallo,

hab die anleitung im readme.txt gefunden betr. installation. nur wurde da nicht erwähnt dass das file phpaccess.php auf CHMOD 775 und das ganze Admin-Verzeichnis auf CHMOD 777 geändert werden muss, sonst kann man keine User eröffnen etc.

anway, ich hab's immer noch nicht kapiert. das ist ja alles schön und gut mit den benutzervergaben, aber ich komm trotzdem ohne passwort rein.

wieso denn???

merci und gruss, stella

genau das gleiche problem habe ich auch :-)

Share this post


Link to post
Share on other sites

hallo,

also, ich hab das adminverzeichnis versucht zu schützen.

wenn ich's über das administrations-panel bei meinem provider mache, stimmt das passwort nicht (es kommt immer dieselbe eingabemaske wieder).

wenn ich's über .htaccess mache, ist es immer noch nicht geschützt.

frage: muss die .htaccess in den ordner 'admin' oder eine stufe weiter oben?

und wo kommt die .htusers.txt hin? kann die in einem ordner im 'admin' directory sein?

dann hab ich noch ne frage:

es hat ja schon eine .htaccess datei im shop drin, mit folgendem inhalt:

# $Id: .htaccess,v 1.1 2003/06/20 00:18:30 hpdl Exp $

#

# This is used with Apache WebServers

#

# For this to work, you must

include the parameter 'Options' to

# the AllowOverride configuration

#

# Example:

#

# <Directory "/usr/local/apache/htdocs">

#

AllowOverride Options

# </Directory>

#

# 'All' with also work. (This configuration is in the

# apache/conf/httpd.conf file)

# The

following makes adjustments to the SSL protocol for Internet

# Explorer browsers

<IfModule mod_setenvif.c>

<IfDefine SSL>

SetEnvIf User-Agent ".*MSIE.*" \

nokeepalive ssl-unclean-shutdown \

downgrade-1.0 force-response-1.0

</IfDefine>

</IfModule>

# If Search Engine Friendly URLs do not work, try enabling the

# following Apache configuration

parameter

#

# AcceptPathInfo On

# Fix certain PHP values

# (commented out by default to prevent errors occuring on certain

#

servers)

#

#<IfModule mod_php4.c>

# php_value session.use_trans_sid 0

# php_value register_globals 1

#</IfModule>

leider kann ich damit überhaupt nichts anfangen.....

vielen dank für eure hilfe, stella

Share this post


Link to post
Share on other sites

Mach's doch folgendermaßen:

erstelle zwei Dateien

.htaccess

und

.htpasswd

In die .htaccess schreibst du folgendes:

<IfModule mod_setenvif.c>

<IfDefine SSL>

SetEnvIf User-Agent ".*MSIE.*" \

nokeepalive ssl-unclean-shutdown \

downgrade-1.0 force-response-1.0

</IfDefine>

</IfModule>

AuthUserFile /www/htdocs/(voller Pfad zu deinem Webverzeichnis... findest du irgendwo bei deinem Provider)

AuthGroupFile /dev/null

AuthName ByPassword

AuthType Basic

<Limit GET POST>

require user USERNAME

</Limit>

USERNAME ersetzt du durch deinen nutzernamen, z.B. "admin123" oder so.

Dann gehst du auf ne Seite, die dir ein verschlüsseltes htpasswort generiert, z.B. auf

http://www.php-space.info/php/space/htpasswd-generatoren.php

Da trägst du dein gewünschtes nutzername/passwort-paar ein und erhältst als ergebnis so etwas wie:

admin:$1$/J69Za72$HDSyY7muo0QfGE.aXUV4N.

Diese Zeile copypastest du dann in deine .htpasswd-Datei und kopierst die beiden Dateien in deinen Admin-Ordner.

Fertig! :)

Edited by SkalpellChef

Share this post


Link to post
Share on other sites

hallo SkalpellChef,

vielen dank für deinen input. hab der anleitung gefolgt und es genau so gemacht, aber er nimmt das passwort nicht an. ich nehme an, der pfad stimmt nicht (hab jetzt aber alle möglichen variationen ausprobiert, und er schnallt es einfach nicht).

also, wenn ich USERNAME durch meinen login-namen ersetze (admin), dann ist der in der Login-Maske schon drin, dh. das liest er ja aus dem .htaccess file raus. soweit so gut.

beim pfad im .htaccess hab ich folgendes eingegeben:

AuthUserFile /www.coffin.com/shop/catalog/admin/

das ist der ort, wo mein .htpasswd drin ist.

scheint er nicht zu schnallen.

und ich auch nicht....

gruss, und danke, stella

Share this post


Link to post
Share on other sites

also,ich steh komplett aufm schlauch.

vielleicht habt ihr eine idee, wenn ihr meine files anguckt:

das .htaccess hat diesen Inhalt:

<IfModule mod_setenvif.c>

<IfDefine SSL>

SetEnvIf User-Agent ".*MSIE.*" \

nokeepalive ssl-unclean-shutdown \

downgrade-1.0 force-response-1.0

</IfDefine>

</IfModule>

AuthUserFile http://www.coffin.com/shop/catalog/admin/'>http://www.coffin.com/shop/catalog/admin/

AuthGroupFile /dev/null

AuthName ByPassword

AuthType Basic

<Limit GET POST>

require user admin

</Limit>

das .htpasswd hat diesen eintrag:

admin:$1$01/DxXvW$DSG6UsFqLSSmJMc4kHYBO.

und sonst nichts.

was mich wundert: muss es beim .htpasswd wirklich einen Punkt jeweils am Schluss haben? (habs mit und ohne probiert, ging beides nicht).

und mein shop liegt ja in diesem verzeichnis:

http://www.coffin.com/shop/catalog/

das admin verzeichnis darunter enthält diese beiden dateien. jetzt noch ein anderer gedanke: muss das .htpasswd wirklich auch in dieses verzeichnis?

ps: die domain ist nicht echt....

danke für eure inputs...

Share this post


Link to post
Share on other sites

AuthUserFile http://www.coffin.com/shop/catalog/admin/

Der Pfad ist falsch. Nicht absolut angeben, sondern relativ, also so z.B:

/www/htdocs/home/web47/domainname/shop/catalog/admin

Steinigt mich bitte nicht, wenn ich Unrecht habe.

Edited by gsvarel

Share this post


Link to post
Share on other sites

sorry... definitiv zu doof....

das wäre dann:

AuthUserFile /www/httpdocs/shop/catalog/admin

?????

geht nicht....

ich versteh den unterschied der verzeichnisse htdocs und httpdocs nicht

egal. aber ich versteh den ganzen pfad nicht.

wie ist denn der richtig abgeleitet, wenn die verzeichnisse so sind:

http://www.coffin.com/shop/catalog/admin/

danke....

stella

Share this post


Link to post
Share on other sites

Da ich die Verzeichnisstruktur auf Deinem Server nicht kenne, schau am besten mal in eine der beiden configure.php. Da steht so eine Pfadangabe drin. Die übernimmst Du dann.

Share this post


Link to post
Share on other sites

Hallo,

wollte mich nur kurz bedanken für Eure Inputs. Ich hab's auf alle möglichen Arten manuell versucht, aber es hat einfach nicht geklappt.

Mittlerweile hab ich auch auf dem Server über das Plesk-Tool das Verzeichnis geschützt - das funktioniert auch ganz gut, nur kann man sich nicht richtig abmelden und der Cache verhindert ein erneutes Anmelden.

Merci und Gruss, Stella

Share this post


Link to post
Share on other sites
Sign in to follow this  

×